diff options
author | Samuli Piippo <samuli.piippo@digia.com> | 2014-03-31 15:48:02 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@digia.com> | 2014-04-04 13:41:34 +0300 |
commit | 03be9b83d45659d0d98fa1bf69853e0aa297ed32 (patch) | |
tree | 534bfaffc99f288f395297c625e284fea6e50401 /recipes | |
parent | cadcb919c9cb71cfe994f9924bc3ddec0890fc99 (diff) | |
download | meta-boot2qt-03be9b83d45659d0d98fa1bf69853e0aa297ed32.tar.gz |
wpa-supplicant: include headers and sources for external usage
Needed sources and headers are included in -dev packages, and
that is included in the sdk.
Task-number: QTEE-451
Change-Id: Ieb5978000856a7c2780102ab751c09e7fe2a01f8
Reviewed-by: Andy Nichols <andy.nichols@digia.com>
Reviewed-by: Gatis Paeglis <gatis.paeglis@digia.com>
Diffstat (limited to 'recipes')
-rw-r--r-- | recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-target.bb | 1 | ||||
-rw-r--r-- | recipes/wpa-supplicant/wpa-supplicant_2.0.bbappend | 18 |
2 files changed, 19 insertions, 0 deletions
diff --git a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-target.bb b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-target.bb index 9260495..457ea56 100644 --- a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-target.bb +++ b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-target.bb | |||
@@ -48,6 +48,7 @@ RDEPENDS_${PN} += "\ | |||
48 | tslib-dev \ | 48 | tslib-dev \ |
49 | hunspell-dev \ | 49 | hunspell-dev \ |
50 | libcap-dev \ | 50 | libcap-dev \ |
51 | wpa-supplicant-dev \ | ||
51 | ${@base_contains("DISTRO_FEATURES", "bluetooth", "bluez4-dev", "", d)} \ | 52 | ${@base_contains("DISTRO_FEATURES", "bluetooth", "bluez4-dev", "", d)} \ |
52 | ${MACHINE_EXTRA_INSTALL_SDK} \ | 53 | ${MACHINE_EXTRA_INSTALL_SDK} \ |
53 | " | 54 | " |
diff --git a/recipes/wpa-supplicant/wpa-supplicant_2.0.bbappend b/recipes/wpa-supplicant/wpa-supplicant_2.0.bbappend new file mode 100644 index 0000000..9a200b2 --- /dev/null +++ b/recipes/wpa-supplicant/wpa-supplicant_2.0.bbappend | |||
@@ -0,0 +1,18 @@ | |||
1 | do_install_append () { | ||
2 | install -d ${D}${includedir}/wpa-supplicant | ||
3 | |||
4 | install -m 0644 ${S}/src/common/wpa_ctrl.c ${D}${includedir}/wpa-supplicant/ | ||
5 | install -m 0644 ${S}/src/common/wpa_ctrl.h ${D}${includedir}/wpa-supplicant/ | ||
6 | |||
7 | install -m 0644 ${S}/src/utils/build_config.h ${D}${includedir}/wpa-supplicant/ | ||
8 | install -m 0644 ${S}/src/utils/common.h ${D}${includedir}/wpa-supplicant/ | ||
9 | install -m 0644 ${S}/src/utils/includes.h ${D}${includedir}/wpa-supplicant/ | ||
10 | install -m 0644 ${S}/src/utils/os.h ${D}${includedir}/wpa-supplicant/ | ||
11 | install -m 0644 ${S}/src/utils/os_unix.c ${D}${includedir}/wpa-supplicant/ | ||
12 | install -m 0644 ${S}/src/utils/trace.h ${D}${includedir}/wpa-supplicant/ | ||
13 | install -m 0644 ${S}/src/utils/wpa_debug.h ${D}${includedir}/wpa-supplicant/ | ||
14 | install -m 0644 ${S}/src/utils/wpabuf.h ${D}${includedir}/wpa-supplicant/ | ||
15 | } | ||
16 | |||
17 | FILES_${PN}-dev += "${includedir}/wpa-supplicant/*" | ||
18 | |||