diff options
author | Samuli Piippo <samuli.piippo@digia.com> | 2014-05-13 09:50:49 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@digia.com> | 2014-05-14 11:47:27 +0300 |
commit | 75738f4153d7088a389500bdbdb1d92735a90498 (patch) | |
tree | a5558aa557d6ddd473e8d39ab6f41f61c7023def /recipes | |
parent | 320e03e97c777e4e63d0a1f45f75771182069e77 (diff) | |
download | meta-boot2qt-75738f4153d7088a389500bdbdb1d92735a90498.tar.gz |
sabresd: add function fs support to sabresd kernel
Function FS needed for the adb connection, include kernel support
in the SABRE SD kernel.
Change-Id: I00f635aff7e71a097941dc8b1ecfb07a4ee3177f
Reviewed-by: Andy Nichols <andy.nichols@digia.com>
Diffstat (limited to 'recipes')
-rw-r--r-- | recipes/linux/linux-imx_3.10.17.bbappend | 32 |
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/linux/linux-imx_3.10.17.bbappend b/recipes/linux/linux-imx_3.10.17.bbappend new file mode 100644 index 0000000..082c431 --- /dev/null +++ b/recipes/linux/linux-imx_3.10.17.bbappend | |||
@@ -0,0 +1,32 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://qt.digia.com/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | do_configure_prepend() { | ||
24 | # FunctionFS for adb | ||
25 | echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig | ||
26 | |||
27 | # Enable USB serial support | ||
28 | echo "CONFIG_USB_SERIAL=m" >> ${WORKDIR}/defconfig | ||
29 | echo "CONFIG_USB_SERIAL_GENERIC=y" >> ${WORKDIR}/defconfig | ||
30 | echo "CONFIG_USB_SERIAL_FTDI_SIO=m" >> ${WORKDIR}/defconfig | ||
31 | echo "CONFIG_USB_SERIAL_PL2303=m" >> ${WORKDIR}/defconfig | ||
32 | } | ||