summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-09-22 15:02:09 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2016-09-22 15:56:17 +0300
commit650460f8f125d18ae03c0622e3dd93630efb0fc7 (patch)
treecccae5089a35efb860e9bbe0ae9c20be114bf35a /recipes
parentf668dddf1f95318b14737c6eb17dabbca213ca22 (diff)
parent2b9e77c40609da75fa44e3376341f484e0ab0288 (diff)
downloadmeta-boot2qt-650460f8f125d18ae03c0622e3dd93630efb0fc7.tar.gz
Merge remote-tracking branch 'origin/jethro' into merge
* origin/jethro: Rename last references to b2qt-utils Rename b2qt-utils to qtdeviceutilities toradex: apply u-boot and flashing script changes to colibri-imx7 nitrogen6x: add Nitrogen6QP_MAX and SOMv2 support qt5: update submodules toradex: use latest u-boot and flashing scripts kontron: update to SMARC-sAMX6i BSP release v2.0, RC2 Use code.qt.io with git protocol instead of codereview Use new repo url for utils and appcontroller kontron: patch kernel to support newer vivante drivers Fetch only external repos for repo mirror qt5: update submodules Add rsync to image Fix raspberry3 build error in perl deployment rcar-gen2: USB fixups ostree: Added dependency for systemd qtquickcompiler: update revision qtquickcompiler: update revision Fix typo in RPi overlay config Update meta layers Conflicts: conf/distro/include/toradex.inc meta-fsl-extras/recipes/u-boot/u-boot-script-toradex/mx6/flash_blk.scr meta-fsl-extras/recipes/u-boot/u-boot-script-toradex/mx6/flash_mmc.scr meta-fsl-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_blk.scr meta-fsl-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_mmc.scr meta-fsl-extras/recipes/u-boot/u-boot-toradex/0001-Update-default-args-for-apalis-imx6.patch meta-fsl-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend recipes/ostree/ostree.bb recipes/samba/samba_4.1.12.bbappend scripts/manifest_jethro.xml Change-Id: I6b6ec105394f03fb57d8f922e358fef51de1e848
Diffstat (limited to 'recipes')
-rw-r--r--recipes/ostree/ostree.bb2
-rw-r--r--recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb1
-rw-r--r--recipes/samba/samba_4.%.bbappend31
3 files changed, 33 insertions, 1 deletions
diff --git a/recipes/ostree/ostree.bb b/recipes/ostree/ostree.bb
index f38088c..75d5bd5 100644
--- a/recipes/ostree/ostree.bb
+++ b/recipes/ostree/ostree.bb
@@ -49,7 +49,7 @@ SRCREV = "8ece4d6d51bdbe3e41ab318259276bb83e553aa0"
49 49
50S = "${WORKDIR}/git" 50S = "${WORKDIR}/git"
51 51
52DEPENDS = "glib-2.0 e2fsprogs gpgme attr libsoup-2.4 libassuan xz" 52DEPENDS = "glib-2.0 e2fsprogs gpgme attr libsoup-2.4 libassuan xz systemd"
53# Bash is needed by the shipped dracut module. This dracut module is used to generate initramfs image. 53# Bash is needed by the shipped dracut module. This dracut module is used to generate initramfs image.
54# The production image do not require bash for proper working. 54# The production image do not require bash for proper working.
55RDEPENDS_${PN} += "bash" 55RDEPENDS_${PN} += "bash"
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb
index a0efef9..17b278c 100644
--- a/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb
+++ b/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb
@@ -43,5 +43,6 @@ RDEPENDS_${PN} = "\
43 ntp \ 43 ntp \
44 connman-client \ 44 connman-client \
45 iproute2 \ 45 iproute2 \
46 rsync \
46 ${@base_contains("DISTRO_FEATURES", "systemd", "systemd-analyze", "", d)} \ 47 ${@base_contains("DISTRO_FEATURES", "systemd", "systemd-analyze", "", d)} \
47 " 48 "
diff --git a/recipes/samba/samba_4.%.bbappend b/recipes/samba/samba_4.%.bbappend
new file mode 100644
index 0000000..4a86809
--- /dev/null
+++ b/recipes/samba/samba_4.%.bbappend
@@ -0,0 +1,31 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DEPENDS += "perl"
31