diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2016-08-25 17:17:41 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2016-09-12 12:33:51 +0000 |
commit | 9ef1bfb8bc50f90a8688c23183146605d1cc88c9 (patch) | |
tree | aa9b2ecf7fdafdee5b7930acc21833cfbab3b4aa /recipes | |
parent | 15536e85fe84345e5f8aef5c1a1bf50983829fa2 (diff) | |
download | meta-boot2qt-9ef1bfb8bc50f90a8688c23183146605d1cc88c9.tar.gz |
gstreamer1.0: patch was applied upstream
Change-Id: Ib45f8818ab568674e0aeda3b528bf7451e00506b
Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'recipes')
-rw-r--r-- | recipes/gstreamer/gstreamer1.0-plugins-base/fix-gstvolume.patch | 23 | ||||
-rw-r--r-- | recipes/gstreamer/gstreamer1.0-plugins-base_%.bbappend | 32 |
2 files changed, 0 insertions, 55 deletions
diff --git a/recipes/gstreamer/gstreamer1.0-plugins-base/fix-gstvolume.patch b/recipes/gstreamer/gstreamer1.0-plugins-base/fix-gstvolume.patch deleted file mode 100644 index f67a840..0000000 --- a/recipes/gstreamer/gstreamer1.0-plugins-base/fix-gstvolume.patch +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | diff --git a/gst/volume/gstvolume.c b/gst/volume/gstvolume.c | ||
2 | index 0f5b362..94d03a3 100644 | ||
3 | --- a/gst/volume/gstvolume.c | ||
4 | +++ b/gst/volume/gstvolume.c | ||
5 | @@ -250,10 +250,14 @@ volume_update_volume (GstVolume * self, const GstAudioInfo * info, | ||
6 | self->current_mute = FALSE; | ||
7 | self->current_volume = volume; | ||
8 | |||
9 | - self->current_vol_i8 = volume * VOLUME_UNITY_INT8; | ||
10 | - self->current_vol_i16 = volume * VOLUME_UNITY_INT16; | ||
11 | - self->current_vol_i24 = volume * VOLUME_UNITY_INT24; | ||
12 | - self->current_vol_i32 = volume * VOLUME_UNITY_INT32; | ||
13 | + self->current_vol_i8 = | ||
14 | + (gint) ((gdouble) volume * (gdouble) VOLUME_UNITY_INT8); | ||
15 | + self->current_vol_i16 = | ||
16 | + (gint) ((gdouble) volume * (gdouble) VOLUME_UNITY_INT16); | ||
17 | + self->current_vol_i24 = | ||
18 | + (gint) ((gdouble) volume * (gdouble) VOLUME_UNITY_INT24); | ||
19 | + self->current_vol_i32 = | ||
20 | + (gint) ((gdouble) volume * (gdouble) VOLUME_UNITY_INT32); | ||
21 | |||
22 | passthrough = (self->current_vol_i16 == VOLUME_UNITY_INT16); | ||
23 | } | ||
diff --git a/recipes/gstreamer/gstreamer1.0-plugins-base_%.bbappend b/recipes/gstreamer/gstreamer1.0-plugins-base_%.bbappend deleted file mode 100644 index 646faa5..0000000 --- a/recipes/gstreamer/gstreamer1.0-plugins-base_%.bbappend +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
31 | |||
32 | SRC_URI += "file://fix-gstvolume.patch" | ||