diff options
author | Mikko Gronoff <mikko.gronoff@qt.io> | 2017-03-21 13:03:58 +0200 |
---|---|---|
committer | Mikko Gronoff <mikko.gronoff@qt.io> | 2017-03-21 13:06:39 +0200 |
commit | 160bd85916f723ecdde8b0514c8a67fdeb4dfe73 (patch) | |
tree | e6e92edead0d78aeaf5b879e5c26a90a99b98861 /scripts | |
parent | d481b98fe28e5bbb7d5e5a73f89abed1fedf4efb (diff) | |
parent | 00b5087da9fa37ab49a29021bf4b1e405634a751 (diff) | |
download | meta-boot2qt-160bd85916f723ecdde8b0514c8a67fdeb4dfe73.tar.gz |
Merge remote-tracking branch 'origin/krogoth' into dev
* origin/krogoth:
AM: update revision
Add appman versions of Kit and Qt to creator
fonts: add recipe for GNU FreeFonts
Add multiscreen automotive demo
neptune: update to include fix for i18ndemo
fonts: update URL for lohit font
Update GammaRay to the same version as used by the QtAS 1.1 host tools
emulator: correctly append qtsimulator configuration
Update automotive components
setup-environment: don't exit the shell on error
neptune-ui: add runtime dependencies
update meta-qt5 (merged upstream/master) SHA1 to manifest.xml
AM: Add appman tools to automotive nativesdk
configure-qtcreator: suppress unnecessary error
Update GammaRay to the latest 2.7 branch
Conflicts:
recipes-qt/automotive/neptune-ui_git.bb
recipes-qt/automotive/qtapplicationmanager_git.bb
recipes-qt/qt5/qtlocation_git.bbappend
scripts/manifest.xml
Change-Id: I96601e7d7a1827a6631fe59d18101d2ad3b70871
Diffstat (limited to 'scripts')
-rwxr-xr-x | scripts/configure-qtcreator.sh | 29 | ||||
-rwxr-xr-x | scripts/setup-environment.sh | 2 |
2 files changed, 28 insertions, 3 deletions
diff --git a/scripts/configure-qtcreator.sh b/scripts/configure-qtcreator.sh index 0ebbe55..c1a3e8e 100755 --- a/scripts/configure-qtcreator.sh +++ b/scripts/configure-qtcreator.sh | |||
@@ -35,7 +35,7 @@ CONFIG="" | |||
35 | 35 | ||
36 | printUsage () | 36 | printUsage () |
37 | { | 37 | { |
38 | echo "Usage: $0 --config <environment-setup-file> [--remove] [--qtcreator <path>] [--name <basename>]" | 38 | echo "Usage: $0 --config <environment-setup-file> [--remove] [--qtcreator <path>] [--name <basename>] [--appman]" |
39 | } | 39 | } |
40 | 40 | ||
41 | while test -n "$1"; do | 41 | while test -n "$1"; do |
@@ -43,6 +43,9 @@ while test -n "$1"; do | |||
43 | "--remove") | 43 | "--remove") |
44 | REMOVEONLY=1 | 44 | REMOVEONLY=1 |
45 | ;; | 45 | ;; |
46 | "--appman") | ||
47 | APPMAN=1 | ||
48 | ;; | ||
46 | "--qtcreator") | 49 | "--qtcreator") |
47 | shift | 50 | shift |
48 | QTCREATOR=$1 | 51 | QTCREATOR=$1 |
@@ -96,10 +99,12 @@ NAME=${NAME:-"Custom Qt ${RELEASE} ${MACHINE}"} | |||
96 | BASEID="byos.${RELEASE}.${MACHINE}" | 99 | BASEID="byos.${RELEASE}.${MACHINE}" |
97 | 100 | ||
98 | ${SDKTOOL} rmKit --id ${BASEID}.kit 2>/dev/null || true | 101 | ${SDKTOOL} rmKit --id ${BASEID}.kit 2>/dev/null || true |
102 | ${SDKTOOL} rmKit --id ${BASEID}.am.kit 2>/dev/null || true | ||
99 | ${SDKTOOL} rmQt --id ${BASEID}.qt || true | 103 | ${SDKTOOL} rmQt --id ${BASEID}.qt || true |
104 | ${SDKTOOL} rmQt --id ${BASEID}.am.qt || true | ||
100 | ${SDKTOOL} rmTC --id ProjectExplorer.ToolChain.Gcc:${BASEID}.gcc || true | 105 | ${SDKTOOL} rmTC --id ProjectExplorer.ToolChain.Gcc:${BASEID}.gcc || true |
101 | ${SDKTOOL} rmTC --id ProjectExplorer.ToolChain.Gcc:${BASEID}.g++ || true | 106 | ${SDKTOOL} rmTC --id ProjectExplorer.ToolChain.Gcc:${BASEID}.g++ || true |
102 | ${SDKTOOL} rmDebugger --id ${BASEID}.gdb || true | 107 | ${SDKTOOL} rmDebugger --id ${BASEID}.gdb 2>/dev/null || true |
103 | 108 | ||
104 | if [ -n "${REMOVEONLY}" ]; then | 109 | if [ -n "${REMOVEONLY}" ]; then |
105 | echo "Kit removed: ${NAME}" | 110 | echo "Kit removed: ${NAME}" |
@@ -145,4 +150,24 @@ ${SDKTOOL} addKit \ | |||
145 | --icon ":/boot2qt/images/B2Qt_QtC_icon.png" \ | 150 | --icon ":/boot2qt/images/B2Qt_QtC_icon.png" \ |
146 | --mkspec "${MKSPEC}" | 151 | --mkspec "${MKSPEC}" |
147 | 152 | ||
153 | if [ -n "${APPMAN}" ]; then | ||
154 | ${SDKTOOL} addQt \ | ||
155 | --id "${BASEID}.am.qt" \ | ||
156 | --name "${NAME} [Application Manager]" \ | ||
157 | --type "AM.Qt" \ | ||
158 | --qmake "$(type -p qmake)" | ||
159 | |||
160 | ${SDKTOOL} addKit \ | ||
161 | --id "${BASEID}.am.kit" \ | ||
162 | --name "${NAME} [Application Manager]" \ | ||
163 | --qt "${BASEID}.am.qt" \ | ||
164 | --debuggerid "${BASEID}.gdb" \ | ||
165 | --sysroot "${SDKTARGETSYSROOT}" \ | ||
166 | --devicetype "AM.Device.Type" \ | ||
167 | --Ctoolchain "ProjectExplorer.ToolChain.Gcc:${BASEID}.gcc" \ | ||
168 | --Cxxtoolchain "ProjectExplorer.ToolChain.Gcc:${BASEID}.g++" \ | ||
169 | --icon ":/boot2qt/images/B2Qt_QtC_icon.png" \ | ||
170 | --mkspec "${MKSPEC}" | ||
171 | fi | ||
172 | |||
148 | echo "Configured Qt Creator with new kit: ${NAME}" | 173 | echo "Configured Qt Creator with new kit: ${NAME}" |
diff --git a/scripts/setup-environment.sh b/scripts/setup-environment.sh index d9a6713..df53284 100755 --- a/scripts/setup-environment.sh +++ b/scripts/setup-environment.sh | |||
@@ -44,7 +44,7 @@ done | |||
44 | THIS_SCRIPT="setup-environment.sh" | 44 | THIS_SCRIPT="setup-environment.sh" |
45 | if [ "$(basename -- $0)" = "${THIS_SCRIPT}" ]; then | 45 | if [ "$(basename -- $0)" = "${THIS_SCRIPT}" ]; then |
46 | echo "Error: This script needs to be sourced. Please run as '. $0'" | 46 | echo "Error: This script needs to be sourced. Please run as '. $0'" |
47 | exit 1 | 47 | return 1 |
48 | fi | 48 | fi |
49 | 49 | ||
50 | if [ -z "$MACHINE" ]; then | 50 | if [ -z "$MACHINE" ]; then |