summaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-08-25 16:16:13 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2016-08-25 16:16:59 +0300
commit0765ab46150bfa6a930487e25ecb0eed365d90f1 (patch)
tree6ad4a5b5b24828ffdf6897f3f90197cd281624c5 /scripts
parent38f883909812a8ca6815431295c8a0fa4e92489d (diff)
parent960945859db570e237c022b2c3269cec3902c876 (diff)
downloadmeta-boot2qt-0765ab46150bfa6a930487e25ecb0eed365d90f1.tar.gz
Merge remote-tracking branch 'origin/jethro' into dev
* origin/jethro: Update meta layers Reuse qt5-git.inc in automotive recipes ota: update recipe Correctly update qtquickcompiler SHA1 Reuse qt5-git.inc to define git repo location Remove automotive recipes Update Qt5 submodules Handle qtquickcompiler in update-qt5-modules.sh script qtwebbrowser: update source uri Correctly use QtQuickCompiler when available gammaray: update revision to match gammaray plugin in QtC 4.1 Fix adb to toradex-imx6 image Change git protocol from ssh to http Update qtdeclarative module Update boot2qt-demos version Change-Id: I1665b538bcd12a0dffb6403a6d387eebb100c762
Diffstat (limited to 'scripts')
-rw-r--r--scripts/manifest.xml4
-rwxr-xr-xscripts/update-qt5-modules.sh3
2 files changed, 5 insertions, 2 deletions
diff --git a/scripts/manifest.xml b/scripts/manifest.xml
index 9d6effc..3354dd2 100644
--- a/scripts/manifest.xml
+++ b/scripts/manifest.xml
@@ -17,11 +17,11 @@
17 17
18 <project name="poky" 18 <project name="poky"
19 remote="yocto" 19 remote="yocto"
20 revision="b1f23d1254682866236bfaeb843c0d8aa332efc2" 20 revision="40376446904ae3529be41737fed9a0b650ed167d"
21 path="sources/poky"/> 21 path="sources/poky"/>
22 <project name="meta-openembedded" 22 <project name="meta-openembedded"
23 remote="oe-mirror" 23 remote="oe-mirror"
24 revision="dc5634968b270dde250690609f0015f881db81f2" 24 revision="8ab04afbffb4bc5184cfe0655049de6f44269990"
25 path="sources/meta-openembedded"/> 25 path="sources/meta-openembedded"/>
26 <project name="meta-qt5" 26 <project name="meta-qt5"
27 remote="qtyocto" 27 remote="qtyocto"
diff --git a/scripts/update-qt5-modules.sh b/scripts/update-qt5-modules.sh
index c9e3949..d4087c3 100755
--- a/scripts/update-qt5-modules.sh
+++ b/scripts/update-qt5-modules.sh
@@ -47,6 +47,9 @@ for S in $SHA1S; do
47 elif [ "${PROJECT}" = "qtwebengine/src/3rdparty" ]; then 47 elif [ "${PROJECT}" = "qtwebengine/src/3rdparty" ]; then
48 sed -i -e "/^SRCREV_chromium/s/\".*\"/\"${SHA1}\"/" qtwebengine_git.bb* 48 sed -i -e "/^SRCREV_chromium/s/\".*\"/\"${SHA1}\"/" qtwebengine_git.bb*
49 echo "qtwebengine (chromium) -> ${SHA1}" 49 echo "qtwebengine (chromium) -> ${SHA1}"
50 elif [ "${PROJECT}" = "tqtc-qmlcompiler" ]; then
51 sed -i -e "/^SRCREV/s/\".*\"/\"${SHA1}\"/" qtquickcompiler_git.bb*
52 echo "qtquickcompiler -> ${SHA1}"
50 elif [ "$(echo *${PROJECT}*_git.bb*)" != "*${PROJECT}*_git.bb*" ]; then 53 elif [ "$(echo *${PROJECT}*_git.bb*)" != "*${PROJECT}*_git.bb*" ]; then
51 sed -i -e "/^SRCREV/s/\".*\"/\"${SHA1}\"/" *${PROJECT}*_git.bb* 54 sed -i -e "/^SRCREV/s/\".*\"/\"${SHA1}\"/" *${PROJECT}*_git.bb*
52 echo "${PROJECT} -> ${SHA1}" 55 echo "${PROJECT} -> ${SHA1}"