diff options
-rw-r--r-- | meta-boot2qt-distro/recipes-qt/qt5/qtdeclarative/0001-Always-use-commit-sha1-for-QML_COMPILE_HASH.patch | 31 | ||||
-rw-r--r-- | meta-boot2qt-distro/recipes-qt/qt5/qtdeclarative_git.bbappend | 4 |
2 files changed, 0 insertions, 35 deletions
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtdeclarative/0001-Always-use-commit-sha1-for-QML_COMPILE_HASH.patch b/meta-boot2qt-distro/recipes-qt/qt5/qtdeclarative/0001-Always-use-commit-sha1-for-QML_COMPILE_HASH.patch deleted file mode 100644 index a734f8a..0000000 --- a/meta-boot2qt-distro/recipes-qt/qt5/qtdeclarative/0001-Always-use-commit-sha1-for-QML_COMPILE_HASH.patch +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | From 260e165993fe15a1668cfd36caee18a95b2d2f59 Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuli Piippo <samuli.piippo@qt.io> | ||
3 | Date: Mon, 2 Jul 2018 13:32:44 +0300 | ||
4 | Subject: [PATCH] Always use commit sha1 for QML_COMPILE_HASH | ||
5 | |||
6 | git describe can produce different strings for the same sha1, depending | ||
7 | on the version of git (length of short hash) and whether release tag was | ||
8 | in place when build was done (v5.11.1-0- vs. v5.11.0-66-). | ||
9 | |||
10 | Instead use rev-parse to get the unambiguous commit sha1 which is also | ||
11 | what is used from the .tag file. | ||
12 | |||
13 | Change-Id: If378f03eb764e2d858bda5b662106aa4402d6559 | ||
14 | Reviewed-by: Simon Hausmann <simon.hausmann@qt.io> | ||
15 | --- | ||
16 | src/qml/qml.pro | 2 +- | ||
17 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
18 | |||
19 | diff --git a/src/qml/qml.pro b/src/qml/qml.pro | ||
20 | index 940ebb325..a76a87b15 100644 | ||
21 | --- a/src/qml/qml.pro | ||
22 | +++ b/src/qml/qml.pro | ||
23 | @@ -31,7 +31,7 @@ DEFINES += QT_NO_FOREACH | ||
24 | !equals(tag, "$${LITERAL_DOLLAR}Format:%H$${LITERAL_DOLLAR}") { | ||
25 | QML_COMPILE_HASH = $$tag | ||
26 | } else:exists($$PWD/../../.git) { | ||
27 | - commit = $$system(git describe --tags --always --long --dirty) | ||
28 | + commit = $$system(git rev-parse HEAD) | ||
29 | QML_COMPILE_HASH = $$commit | ||
30 | } | ||
31 | compile_hash_contents = \ | ||
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtdeclarative_git.bbappend b/meta-boot2qt-distro/recipes-qt/qt5/qtdeclarative_git.bbappend index ec82d40..d9144a8 100644 --- a/meta-boot2qt-distro/recipes-qt/qt5/qtdeclarative_git.bbappend +++ b/meta-boot2qt-distro/recipes-qt/qt5/qtdeclarative_git.bbappend | |||
@@ -27,10 +27,6 @@ | |||
27 | ## | 27 | ## |
28 | ############################################################################ | 28 | ############################################################################ |
29 | 29 | ||
30 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
31 | |||
32 | SRC_URI += "file://0001-Always-use-commit-sha1-for-QML_COMPILE_HASH.patch" | ||
33 | |||
34 | FILES_${PN}-plugins_mingw32 = " \ | 30 | FILES_${PN}-plugins_mingw32 = " \ |
35 | ${OE_QMAKE_PATH_PLUGINS}/*/*.dll \ | 31 | ${OE_QMAKE_PATH_PLUGINS}/*/*.dll \ |
36 | " | 32 | " |