summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/qtquickcompiler.bbclass45
-rw-r--r--recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb3
2 files changed, 34 insertions, 14 deletions
diff --git a/classes/qtquickcompiler.bbclass b/classes/qtquickcompiler.bbclass
index 202d592..1478741 100644
--- a/classes/qtquickcompiler.bbclass
+++ b/classes/qtquickcompiler.bbclass
@@ -1,13 +1,34 @@
1EXTRA_QMAKEVARS_PRE += "CONFIG+=qtquickcompiler CONFIG+=no_qtquickcompiler_depend" 1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
2 22
3DEPENDS_prepend = "qtquickcompiler qtquickcompiler-native " 23python __anonymous() {
4 24 sdk_path = d.getVar('QT_SDK_PATH', True) or ""
5#python __anonymous() { 25 if len(sdk_path) != 0:
6# do the magic: 26 bb.note("TODO: QtQuickCompiler not yet available for external builds")
7# if QT_SDK path is set, 27 else:
8# add dependency to qtquickcompiler-sdk-native package that 28 pn = d.getVar("PN", True)
9# copies the needed files (binary and mkspec files) from the SDK 29 if pn.startswith("nativesdk-"):
10# else 30 d.appendVar('RDEPENDS_' + pn, " nativesdk-qtquickcompiler-tools")
11# add dependency to qtquickcompiler-native package that 31 else:
12# builds it from internal repos 32 d.appendVar('DEPENDS', " qtquickcompiler qtquickcompiler-native")
13#} 33 d.appendVar('EXTRA_QMAKEVARS_PRE', " CONFIG+=qtquickcompiler CONFIG+=no_qtquickcompiler_depend")
34}
diff --git a/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb b/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb
index b424fb7..0437c42 100644
--- a/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb
+++ b/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb
@@ -24,12 +24,11 @@ DESCRIPTION = "Host packages for B2Qt embedded Qt5 SDK"
24LICENSE = "QtEnterprise" 24LICENSE = "QtEnterprise"
25PR = "r0" 25PR = "r0"
26 26
27inherit nativesdk packagegroup 27inherit nativesdk packagegroup qtquickcompiler
28 28
29RDEPENDS_${PN} += "\ 29RDEPENDS_${PN} += "\
30 nativesdk-packagegroup-b2qt-embedded-toolchain-host \ 30 nativesdk-packagegroup-b2qt-embedded-toolchain-host \
31 nativesdk-qttools \ 31 nativesdk-qttools \
32 nativesdk-qtbase-tools \ 32 nativesdk-qtbase-tools \
33 nativesdk-qtbase-tools-staticdev \ 33 nativesdk-qtbase-tools-staticdev \
34 nativesdk-qtquickcompiler-tools \
35 " 34 "