diff options
18 files changed, 246 insertions, 24 deletions
diff --git a/recipes-qt/automotive/gammaray_git.bb b/recipes-qt/automotive/gammaray_git.bb index 6304096..6317040 100644 --- a/recipes-qt/automotive/gammaray_git.bb +++ b/recipes-qt/automotive/gammaray_git.bb | |||
@@ -2,15 +2,15 @@ SUMMARY = "GammaRay Qt introspection probe" | |||
2 | HOMEPAGE = "http://www.kdab.com/gammaray" | 2 | HOMEPAGE = "http://www.kdab.com/gammaray" |
3 | 3 | ||
4 | LICENSE = "GPLv2" | 4 | LICENSE = "GPLv2" |
5 | LIC_FILES_CHKSUM = "file://LICENSE.GPL.txt;md5=5996517d53e3c2722d457fb633e970ed" | 5 | LIC_FILES_CHKSUM = "file://LICENSE.GPL.txt;md5=560b8b2e529f7a17ee5dde6e5d0c0d69" |
6 | 6 | ||
7 | inherit cmake_qt5 | 7 | inherit cmake_qt5 |
8 | 8 | ||
9 | SRC_URI = "git://github.com/KDAB/GammaRay;branch=${BRANCH}" | 9 | SRC_URI = "git://github.com/KDAB/GammaRay;branch=${BRANCH}" |
10 | 10 | ||
11 | BRANCH = "master" | 11 | BRANCH = "2.7" |
12 | SRCREV = "b961eb1b84718256acc678ec16a2b45e98990cd7" | 12 | SRCREV = "a22da6d63cab08f3ef8588611fdbda3f96731efe" |
13 | PV = "master+git${SRCPV}" | 13 | PV = "${BRANCH}+git${SRCPV}" |
14 | 14 | ||
15 | DEPENDS = "qtdeclarative qtlocation qtsvg qttools qtconnectivity qt3d qtivi qtscxml \ | 15 | DEPENDS = "qtdeclarative qtlocation qtsvg qttools qtconnectivity qt3d qtivi qtscxml \ |
16 | ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}" | 16 | ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}" |
diff --git a/recipes-qt/automotive/multiscreen-demo_git.bb b/recipes-qt/automotive/multiscreen-demo_git.bb new file mode 100644 index 0000000..1997bd5 --- /dev/null +++ b/recipes-qt/automotive/multiscreen-demo_git.bb | |||
@@ -0,0 +1,65 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2017 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | DESCRIPTION = "Multiscreen Demo" | ||
31 | LICENSE = "GPLv3 | The-Qt-Company-DCLA-2.1" | ||
32 | LIC_FILES_CHKSUM = "file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073" | ||
33 | |||
34 | inherit qt5-module systemd | ||
35 | require recipes-qt/qt5/qt5-git.inc | ||
36 | |||
37 | QT_GIT = "git://code.qt.io/qt-apps" | ||
38 | QT_MODULE_BRANCH = "master" | ||
39 | |||
40 | SRC_URI += "git://github.com/qtproject/qt-apps-demo-assets;protocol=git;name=assets;destsuffix=git/demo-assets" | ||
41 | |||
42 | SRCREV_multiscreen = "77ecd7d03aeea3bb7d10ac8ef448920da11ae306" | ||
43 | SRCREV_assets = "0d47d21f082d6c9e355a55809ebd38a31ea02264" | ||
44 | |||
45 | SRCREV_FORMAT = "multiscreen_assets" | ||
46 | SRCREV = "${SRCREV_multiscreen}" | ||
47 | |||
48 | DEPENDS = "qtbase qtdeclarative qt3d" | ||
49 | RDEPENDS_${PN} = "qtapplicationmanager qtivi qtvirtualkeyboard" | ||
50 | |||
51 | EXTRA_QMAKEVARS_PRE += "INSTALL_PREFIX=/opt" | ||
52 | |||
53 | do_install_append() { | ||
54 | install -m 0755 ${S}/start.sh ${D}/opt/automotivedemo/ | ||
55 | |||
56 | install -d ${D}${systemd_system_unitdir} | ||
57 | install -m 0644 ${S}/scripts/automotivedemo.service ${D}${systemd_system_unitdir}/ | ||
58 | } | ||
59 | |||
60 | FILES_${PN} += "\ | ||
61 | /opt/automotivedemo \ | ||
62 | " | ||
63 | |||
64 | SYSTEMD_SERVICE_${PN} = "automotivedemo.service" | ||
65 | SYSTEMD_AUTO_ENABLE = "disable" | ||
diff --git a/recipes-qt/automotive/neptune-ui_git.bb b/recipes-qt/automotive/neptune-ui_git.bb index 2db4765..ceceec8 100644 --- a/recipes-qt/automotive/neptune-ui_git.bb +++ b/recipes-qt/automotive/neptune-ui_git.bb | |||
@@ -36,22 +36,18 @@ require recipes-qt/qt5/qt5-git.inc | |||
36 | 36 | ||
37 | QT_GIT = "git://github.com/qtproject" | 37 | QT_GIT = "git://github.com/qtproject" |
38 | QT_MODULE = "qt-apps-neptune-ui" | 38 | QT_MODULE = "qt-apps-neptune-ui" |
39 | QT_MODULE_BRANCH = "master" | ||
40 | 39 | ||
41 | SRC_URI += " \ | 40 | SRC_URI += " \ |
42 | file://neptune.service \ | 41 | file://neptune.service \ |
43 | " | 42 | " |
44 | 43 | ||
45 | SRCREV = "fd18dcbb9f53eb3948da890704530007327c476f" | 44 | SRCREV = "504d9720ed7ef921af7e5f1ebf709662baac6555" |
46 | 45 | ||
47 | DEPENDS = "qtbase qtdeclarative" | 46 | DEPENDS = "qtbase qtdeclarative" |
48 | RDEPENDS_${PN} = "qtapplicationmanager qtivi qtvirtualkeyboard \ | 47 | RDEPENDS_${PN} = "qtapplicationmanager qtivi qtvirtualkeyboard \ |
48 | qtquickcontrols-qmlplugins qtgraphicaleffects-qmlplugins \ | ||
49 | ${@bb.utils.contains('DISTRO_FEATURES', 'webengine', 'qtwebengine', '', d)}" | 49 | ${@bb.utils.contains('DISTRO_FEATURES', 'webengine', 'qtwebengine', '', d)}" |
50 | 50 | ||
51 | do_configure_prepend() { | ||
52 | echo "qml.path = /opt/neptune" >> ${S}/neptuneui.pro | ||
53 | } | ||
54 | |||
55 | do_install_append() { | 51 | do_install_append() { |
56 | install -m 0755 -d ${D}${systemd_unitdir}/system | 52 | install -m 0755 -d ${D}${systemd_unitdir}/system |
57 | install -m 0644 ${WORKDIR}/neptune.service ${D}${systemd_unitdir}/system/ | 53 | install -m 0644 ${WORKDIR}/neptune.service ${D}${systemd_unitdir}/system/ |
diff --git a/recipes-qt/automotive/qtapplicationmanager_git.bb b/recipes-qt/automotive/qtapplicationmanager_git.bb index e22196c..52ee20e 100644 --- a/recipes-qt/automotive/qtapplicationmanager_git.bb +++ b/recipes-qt/automotive/qtapplicationmanager_git.bb | |||
@@ -29,16 +29,18 @@ | |||
29 | 29 | ||
30 | DESCRIPTION = "Qt component for application lifecycle management" | 30 | DESCRIPTION = "Qt component for application lifecycle management" |
31 | LICENSE = "(GFDL-1.3 & The-Qt-Company-GPL-Exception-1.0 & (LGPL-3.0 | GPL-2.0+)) | The-Qt-Company-DCLA-2.1" | 31 | LICENSE = "(GFDL-1.3 & The-Qt-Company-GPL-Exception-1.0 & (LGPL-3.0 | GPL-2.0+)) | The-Qt-Company-DCLA-2.1" |
32 | LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=317fda864ac33d41406ff3938c3e78d1" | 32 | LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=43a31c6abffdd61c938811959b3c1b71" |
33 | 33 | ||
34 | inherit qt5-module | 34 | inherit qt5-module |
35 | require recipes-qt/qt5/qt5-git.inc | 35 | require recipes-qt/qt5/qt5-git.inc |
36 | 36 | ||
37 | SRCREV = "be9e9a37c2cd848cfdbb97990e0047f1a0834a8a" | 37 | SRCREV = "f472ef3662cf0a9bc2bf727c7cef18fd884df5a2" |
38 | 38 | ||
39 | DEPENDS = "qtbase qtdeclarative libyaml libarchive \ | 39 | DEPENDS = "qtbase qtdeclarative libyaml libarchive \ |
40 | ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}" | 40 | ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}" |
41 | |||
41 | RDEPENDS_${PN} = "libcrypto ${PN}-tools" | 42 | RDEPENDS_${PN} = "libcrypto ${PN}-tools" |
43 | RDEPENDS_${PN}_remove_mingw32 = "libcrypto" | ||
42 | 44 | ||
43 | EXTRA_QMAKEVARS_PRE += "\ | 45 | EXTRA_QMAKEVARS_PRE += "\ |
44 | ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "-config force-multiprocess", "-config force-singleprocess", d)} \ | 46 | ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "-config force-multiprocess", "-config force-singleprocess", d)} \ |
@@ -55,3 +57,12 @@ do_install_append() { | |||
55 | FILES_${PN} += "\ | 57 | FILES_${PN} += "\ |
56 | /opt/am \ | 58 | /opt/am \ |
57 | " | 59 | " |
60 | |||
61 | BBCLASSEXTEND += "nativesdk" | ||
62 | |||
63 | DEPENDS_class-nativesdk = "qtbase nativesdk-glibc-locale" | ||
64 | DEPENDS_class-nativesdk_remove_mingw32 += "nativesdk-glibc-locale" | ||
65 | |||
66 | EXTRA_QMAKEVARS_PRE_class-nativesdk += "\ | ||
67 | -config tools-only \ | ||
68 | " | ||
diff --git a/recipes-qt/b2qt-addons/b2qt-appcontroller/tegra-t18x/appcontroller.conf b/recipes-qt/b2qt-addons/b2qt-appcontroller/tegra-t18x/appcontroller.conf index 64226cb..7236378 100644 --- a/recipes-qt/b2qt-addons/b2qt-appcontroller/tegra-t18x/appcontroller.conf +++ b/recipes-qt/b2qt-addons/b2qt-appcontroller/tegra-t18x/appcontroller.conf | |||
@@ -3,5 +3,5 @@ env=QT_IM_MODULE=qtvirtualkeyboard | |||
3 | env=QT_QPA_EGLFS_FORCE888=0 | 3 | env=QT_QPA_EGLFS_FORCE888=0 |
4 | env=QT_QUICK_CONTROLS_STYLE=Flat | 4 | env=QT_QUICK_CONTROLS_STYLE=Flat |
5 | env=XDG_RUNTIME_DIR=/tmp | 5 | env=XDG_RUNTIME_DIR=/tmp |
6 | env=QSG_RENDER_LOOP=windows | 6 | env=QSG_RENDER_LOOP=basic |
7 | base=linux | 7 | base=linux |
diff --git a/recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb b/recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb index e74dd92..94bf48d 100644 --- a/recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb +++ b/recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb | |||
@@ -34,6 +34,6 @@ LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b" | |||
34 | 34 | ||
35 | inherit populate_b2qt_qt5_sdk | 35 | inherit populate_b2qt_qt5_sdk |
36 | 36 | ||
37 | TOOLCHAIN_HOST_TASK += "nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host" | 37 | TOOLCHAIN_HOST_TASK += "nativesdk-packagegroup-b2qt-automotive-qt5-toolchain-host" |
38 | TOOLCHAIN_TARGET_TASK += "packagegroup-b2qt-embedded-qt5-toolchain-target \ | 38 | TOOLCHAIN_TARGET_TASK += "packagegroup-b2qt-embedded-qt5-toolchain-target \ |
39 | packagegroup-b2qt-automotive-qt5-toolchain-target" | 39 | packagegroup-b2qt-automotive-qt5-toolchain-target" |
diff --git a/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-automotive-qt5-toolchain-host.bb b/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-automotive-qt5-toolchain-host.bb new file mode 100644 index 0000000..acae372 --- /dev/null +++ b/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-automotive-qt5-toolchain-host.bb | |||
@@ -0,0 +1,39 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | DESCRIPTION = "Host packages for B2Qt automotive Qt5 SDK" | ||
31 | LICENSE = "The-Qt-Company-DCLA-2.1" | ||
32 | PR = "r0" | ||
33 | |||
34 | inherit nativesdk packagegroup qtquickcompiler | ||
35 | |||
36 | RDEPENDS_${PN} += "\ | ||
37 | nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host \ | ||
38 | nativesdk-qtapplicationmanager-tools \ | ||
39 | " | ||
diff --git a/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb b/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb index 1bf8da1..be15207 100644 --- a/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb +++ b/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb | |||
@@ -42,4 +42,5 @@ RDEPENDS_${PN} += " \ | |||
42 | ${@bb.utils.contains('DISTRO_FEATURES', 'webengine', 'qtwebbrowser', '', d)} \ | 42 | ${@bb.utils.contains('DISTRO_FEATURES', 'webengine', 'qtwebbrowser', '', d)} \ |
43 | gammaray \ | 43 | gammaray \ |
44 | qmllive-target \ | 44 | qmllive-target \ |
45 | multiscreen-demo \ | ||
45 | " | 46 | " |
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bbappend b/recipes-qt/qt5/nativesdk-qtbase_git.bbappend index 78106f8..d79bf57 100644 --- a/recipes-qt/qt5/nativesdk-qtbase_git.bbappend +++ b/recipes-qt/qt5/nativesdk-qtbase_git.bbappend | |||
@@ -33,5 +33,10 @@ SRC_URI += "\ | |||
33 | file://0001-Add-win32-g-oe-mkspec-that-uses-the-OE_-environment.patch \ | 33 | file://0001-Add-win32-g-oe-mkspec-that-uses-the-OE_-environment.patch \ |
34 | " | 34 | " |
35 | 35 | ||
36 | PACKAGECONFIG += "openssl" | ||
37 | PACKAGECONFIG_remove_mingw32 += "openssl" | ||
38 | |||
39 | PACKAGECONFIG[openssl] = "-openssl,-no-openssl,openssl,libssl" | ||
40 | |||
36 | fakeroot do_generate_qt_environment_file_mingw32() { | 41 | fakeroot do_generate_qt_environment_file_mingw32() { |
37 | } | 42 | } |
diff --git a/recipes-qt/qt5/qtlocation_git.bbappend b/recipes-qt/qt5/qtlocation_git.bbappend index f199937..2a949eb 100644 --- a/recipes-qt/qt5/qtlocation_git.bbappend +++ b/recipes-qt/qt5/qtlocation_git.bbappend | |||
@@ -27,5 +27,5 @@ | |||
27 | ## | 27 | ## |
28 | ############################################################################ | 28 | ############################################################################ |
29 | 29 | ||
30 | EXTRA_QMAKEVARS_PRE_emulator += "CONFIG+=simulator" | 30 | EXTRA_QMAKEVARS_PRE_append_emulator = " CONFIG+=simulator" |
31 | DEPENDS_emulator += "qtsimulator" | 31 | DEPENDS_append_emulator = " qtsimulator" |
diff --git a/recipes-qt/qt5/qtsensors_git.bbappend b/recipes-qt/qt5/qtsensors_git.bbappend index 890656c..655364b 100644 --- a/recipes-qt/qt5/qtsensors_git.bbappend +++ b/recipes-qt/qt5/qtsensors_git.bbappend | |||
@@ -27,5 +27,5 @@ | |||
27 | ## | 27 | ## |
28 | ############################################################################ | 28 | ############################################################################ |
29 | 29 | ||
30 | EXTRA_QMAKEVARS_PRE_emulator += "SENSORS_PLUGINS=simulator" | 30 | EXTRA_QMAKEVARS_PRE_append_emulator = " SENSORS_PLUGINS=simulator" |
31 | DEPENDS_emulator += "qtsimulator" | 31 | DEPENDS_append_emulator = " qtsimulator" |
diff --git a/recipes-qt/qt5/qtsystems_git.bbappend b/recipes-qt/qt5/qtsystems_git.bbappend index f199937..2a949eb 100644 --- a/recipes-qt/qt5/qtsystems_git.bbappend +++ b/recipes-qt/qt5/qtsystems_git.bbappend | |||
@@ -27,5 +27,5 @@ | |||
27 | ## | 27 | ## |
28 | ############################################################################ | 28 | ############################################################################ |
29 | 29 | ||
30 | EXTRA_QMAKEVARS_PRE_emulator += "CONFIG+=simulator" | 30 | EXTRA_QMAKEVARS_PRE_append_emulator = " CONFIG+=simulator" |
31 | DEPENDS_emulator += "qtsimulator" | 31 | DEPENDS_append_emulator = " qtsimulator" |
diff --git a/recipes/fonts/ttf-devanagari_2.94.0.bb b/recipes/fonts/ttf-devanagari_2.94.0.bb index 1073096..ee0ea06 100644 --- a/recipes/fonts/ttf-devanagari_2.94.0.bb +++ b/recipes/fonts/ttf-devanagari_2.94.0.bb | |||
@@ -37,7 +37,7 @@ INHIBIT_DEFAULT_DEPS = "1" | |||
37 | 37 | ||
38 | inherit allarch fontcache | 38 | inherit allarch fontcache |
39 | 39 | ||
40 | SRC_URI = "https://fedorahosted.org/releases/l/o/lohit/lohit-devanagari-ttf-${PV}.tar.gz" | 40 | SRC_URI = "https://releases.pagure.org/lohit/lohit-devanagari-ttf-${PV}.tar.gz" |
41 | 41 | ||
42 | SRC_URI[md5sum] = "57527ee536a18b443cf786d4b8fd5ec8" | 42 | SRC_URI[md5sum] = "57527ee536a18b443cf786d4b8fd5ec8" |
43 | SRC_URI[sha256sum] = "a6618aeb1d25df46d3c22e528c38ea1d1147654e19904497a1e97f4684c55353" | 43 | SRC_URI[sha256sum] = "a6618aeb1d25df46d3c22e528c38ea1d1147654e19904497a1e97f4684c55353" |
diff --git a/recipes/fonts/ttf-freefont_20120503.bb b/recipes/fonts/ttf-freefont_20120503.bb new file mode 100644 index 0000000..abf9562 --- /dev/null +++ b/recipes/fonts/ttf-freefont_20120503.bb | |||
@@ -0,0 +1,49 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2017 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | DESCRIPTION = "GNU FreeFont is a free family of scalable outline fonts" | ||
31 | HOMEPAGE = "http://savannah.gnu.org/projects/freefont" | ||
32 | LICENSE = "GPLv3" | ||
33 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
34 | |||
35 | require recipes-graphics/ttf-fonts/ttf.inc | ||
36 | |||
37 | inherit allarch fontcache | ||
38 | |||
39 | S = "${WORKDIR}/freefont-${PV}" | ||
40 | |||
41 | SRC_URI = "http://ftp.gnu.org/gnu/freefont/freefont-ttf-${PV}.zip" | ||
42 | |||
43 | SRC_URI[md5sum] = "879b76d2e3c8003d567b555743f39154" | ||
44 | SRC_URI[sha256sum] = "7c85baf1bf82a1a1845d1322112bc6ca982221b484e3b3925022e25b5cae89af" | ||
45 | |||
46 | PACKAGES = "${PN}-sans ${PN}-mono ${PN}-serif" | ||
47 | FILES_${PN}-sans = "${datadir}/fonts/truetype/FreeSans*.ttf" | ||
48 | FILES_${PN}-mono = "${datadir}/fonts/truetype/FreeMono*.ttf" | ||
49 | FILES_${PN}-serif = "${datadir}/fonts/truetype/FreeSerif*.ttf" | ||
diff --git a/recipes/libyaml/libyaml_%.bbappend b/recipes/libyaml/libyaml_%.bbappend new file mode 100644 index 0000000..728a546 --- /dev/null +++ b/recipes/libyaml/libyaml_%.bbappend | |||
@@ -0,0 +1,30 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | BBCLASSEXTEND += "nativesdk" | ||
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb index 066ba29..65f7f5e 100644 --- a/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb +++ b/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb | |||
@@ -44,6 +44,7 @@ RDEPENDS_${PN} = "\ | |||
44 | ttf-opensans \ | 44 | ttf-opensans \ |
45 | ttf-dejavu-common \ | 45 | ttf-dejavu-common \ |
46 | ttf-dejavu-sans \ | 46 | ttf-dejavu-sans \ |
47 | ttf-freefont-mono \ | ||
47 | otf-noto \ | 48 | otf-noto \ |
48 | dbus-session-init \ | 49 | dbus-session-init \ |
49 | tzdata \ | 50 | tzdata \ |
diff --git a/scripts/configure-qtcreator.sh b/scripts/configure-qtcreator.sh index 0ebbe55..c1a3e8e 100755 --- a/scripts/configure-qtcreator.sh +++ b/scripts/configure-qtcreator.sh | |||
@@ -35,7 +35,7 @@ CONFIG="" | |||
35 | 35 | ||
36 | printUsage () | 36 | printUsage () |
37 | { | 37 | { |
38 | echo "Usage: $0 --config <environment-setup-file> [--remove] [--qtcreator <path>] [--name <basename>]" | 38 | echo "Usage: $0 --config <environment-setup-file> [--remove] [--qtcreator <path>] [--name <basename>] [--appman]" |
39 | } | 39 | } |
40 | 40 | ||
41 | while test -n "$1"; do | 41 | while test -n "$1"; do |
@@ -43,6 +43,9 @@ while test -n "$1"; do | |||
43 | "--remove") | 43 | "--remove") |
44 | REMOVEONLY=1 | 44 | REMOVEONLY=1 |
45 | ;; | 45 | ;; |
46 | "--appman") | ||
47 | APPMAN=1 | ||
48 | ;; | ||
46 | "--qtcreator") | 49 | "--qtcreator") |
47 | shift | 50 | shift |
48 | QTCREATOR=$1 | 51 | QTCREATOR=$1 |
@@ -96,10 +99,12 @@ NAME=${NAME:-"Custom Qt ${RELEASE} ${MACHINE}"} | |||
96 | BASEID="byos.${RELEASE}.${MACHINE}" | 99 | BASEID="byos.${RELEASE}.${MACHINE}" |
97 | 100 | ||
98 | ${SDKTOOL} rmKit --id ${BASEID}.kit 2>/dev/null || true | 101 | ${SDKTOOL} rmKit --id ${BASEID}.kit 2>/dev/null || true |
102 | ${SDKTOOL} rmKit --id ${BASEID}.am.kit 2>/dev/null || true | ||
99 | ${SDKTOOL} rmQt --id ${BASEID}.qt || true | 103 | ${SDKTOOL} rmQt --id ${BASEID}.qt || true |
104 | ${SDKTOOL} rmQt --id ${BASEID}.am.qt || true | ||
100 | ${SDKTOOL} rmTC --id ProjectExplorer.ToolChain.Gcc:${BASEID}.gcc || true | 105 | ${SDKTOOL} rmTC --id ProjectExplorer.ToolChain.Gcc:${BASEID}.gcc || true |
101 | ${SDKTOOL} rmTC --id ProjectExplorer.ToolChain.Gcc:${BASEID}.g++ || true | 106 | ${SDKTOOL} rmTC --id ProjectExplorer.ToolChain.Gcc:${BASEID}.g++ || true |
102 | ${SDKTOOL} rmDebugger --id ${BASEID}.gdb || true | 107 | ${SDKTOOL} rmDebugger --id ${BASEID}.gdb 2>/dev/null || true |
103 | 108 | ||
104 | if [ -n "${REMOVEONLY}" ]; then | 109 | if [ -n "${REMOVEONLY}" ]; then |
105 | echo "Kit removed: ${NAME}" | 110 | echo "Kit removed: ${NAME}" |
@@ -145,4 +150,24 @@ ${SDKTOOL} addKit \ | |||
145 | --icon ":/boot2qt/images/B2Qt_QtC_icon.png" \ | 150 | --icon ":/boot2qt/images/B2Qt_QtC_icon.png" \ |
146 | --mkspec "${MKSPEC}" | 151 | --mkspec "${MKSPEC}" |
147 | 152 | ||
153 | if [ -n "${APPMAN}" ]; then | ||
154 | ${SDKTOOL} addQt \ | ||
155 | --id "${BASEID}.am.qt" \ | ||
156 | --name "${NAME} [Application Manager]" \ | ||
157 | --type "AM.Qt" \ | ||
158 | --qmake "$(type -p qmake)" | ||
159 | |||
160 | ${SDKTOOL} addKit \ | ||
161 | --id "${BASEID}.am.kit" \ | ||
162 | --name "${NAME} [Application Manager]" \ | ||
163 | --qt "${BASEID}.am.qt" \ | ||
164 | --debuggerid "${BASEID}.gdb" \ | ||
165 | --sysroot "${SDKTARGETSYSROOT}" \ | ||
166 | --devicetype "AM.Device.Type" \ | ||
167 | --Ctoolchain "ProjectExplorer.ToolChain.Gcc:${BASEID}.gcc" \ | ||
168 | --Cxxtoolchain "ProjectExplorer.ToolChain.Gcc:${BASEID}.g++" \ | ||
169 | --icon ":/boot2qt/images/B2Qt_QtC_icon.png" \ | ||
170 | --mkspec "${MKSPEC}" | ||
171 | fi | ||
172 | |||
148 | echo "Configured Qt Creator with new kit: ${NAME}" | 173 | echo "Configured Qt Creator with new kit: ${NAME}" |
diff --git a/scripts/setup-environment.sh b/scripts/setup-environment.sh index d9a6713..df53284 100755 --- a/scripts/setup-environment.sh +++ b/scripts/setup-environment.sh | |||
@@ -44,7 +44,7 @@ done | |||
44 | THIS_SCRIPT="setup-environment.sh" | 44 | THIS_SCRIPT="setup-environment.sh" |
45 | if [ "$(basename -- $0)" = "${THIS_SCRIPT}" ]; then | 45 | if [ "$(basename -- $0)" = "${THIS_SCRIPT}" ]; then |
46 | echo "Error: This script needs to be sourced. Please run as '. $0'" | 46 | echo "Error: This script needs to be sourced. Please run as '. $0'" |
47 | exit 1 | 47 | return 1 |
48 | fi | 48 | fi |
49 | 49 | ||
50 | if [ -z "$MACHINE" ]; then | 50 | if [ -z "$MACHINE" ]; then |