diff options
-rw-r--r-- | meta-renesas-extras/recipes/qt5/qtwebengine/0001-Workaround-missing-eglGetProcAddress.patch | 28 | ||||
-rw-r--r-- | meta-renesas-extras/recipes/qt5/qtwebengine_git.bbappend | 32 |
2 files changed, 60 insertions, 0 deletions
diff --git a/meta-renesas-extras/recipes/qt5/qtwebengine/0001-Workaround-missing-eglGetProcAddress.patch b/meta-renesas-extras/recipes/qt5/qtwebengine/0001-Workaround-missing-eglGetProcAddress.patch new file mode 100644 index 0000000..ed1339b --- /dev/null +++ b/meta-renesas-extras/recipes/qt5/qtwebengine/0001-Workaround-missing-eglGetProcAddress.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From 4b59d8fa3ba5647834d29fad58b9231c154b9136 Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuli Piippo <samuli.piippo@qt.io> | ||
3 | Date: Tue, 16 Oct 2018 13:43:43 +0300 | ||
4 | Subject: [PATCH] Workaround missing eglGetProcAddress | ||
5 | |||
6 | Renesas boards are unable to find address for the eglGetProcAddress | ||
7 | symbol at runtime, instead do it already at link time. | ||
8 | |||
9 | Task-number: QTBUG-71152 | ||
10 | Change-Id: Ibc4251c0ab7e878a65d8c6e7b4da3952807cbc91 | ||
11 | --- | ||
12 | src/core/ozone/gl_ozone_egl_qt.cpp | 3 +++ | ||
13 | 1 file changed, 3 insertions(+) | ||
14 | |||
15 | diff --git a/src/core/ozone/gl_ozone_egl_qt.cpp b/src/core/ozone/gl_ozone_egl_qt.cpp | ||
16 | index 2fa86d79..d2362477 100644 | ||
17 | --- a/src/core/ozone/gl_ozone_egl_qt.cpp | ||
18 | +++ b/src/core/ozone/gl_ozone_egl_qt.cpp | ||
19 | @@ -98,6 +98,9 @@ bool GLOzoneEGLQt::LoadGLES2Bindings(gl::GLImplementation /*implementation*/) | ||
20 | } | ||
21 | #endif | ||
22 | |||
23 | + if (!get_proc_address) | ||
24 | + get_proc_address = &eglGetProcAddress; | ||
25 | + | ||
26 | if (!get_proc_address) { | ||
27 | LOG(ERROR) << "eglGetProcAddress not found."; | ||
28 | base::UnloadNativeLibrary(eglgles2Library); | ||
diff --git a/meta-renesas-extras/recipes/qt5/qtwebengine_git.bbappend b/meta-renesas-extras/recipes/qt5/qtwebengine_git.bbappend new file mode 100644 index 0000000..cc13b74 --- /dev/null +++ b/meta-renesas-extras/recipes/qt5/qtwebengine_git.bbappend | |||
@@ -0,0 +1,32 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2018 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
31 | |||
32 | SRC_URI += "file://0001-Workaround-missing-eglGetProcAddress.patch" | ||