diff options
-rw-r--r-- | conf/distro/include/colibri-imx7.conf | 3 | ||||
-rw-r--r-- | meta-intel-extras/recipes/grub/grub-efi_2.00.bbappend | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtdeviceutilities.bb | 4 | ||||
-rw-r--r-- | recipes/fonts/otf-noto_git.bb | 3 | ||||
-rw-r--r-- | recipes/fonts/ttf-opensans.bb | 12 |
5 files changed, 13 insertions, 11 deletions
diff --git a/conf/distro/include/colibri-imx7.conf b/conf/distro/include/colibri-imx7.conf index 6e80e00..4e0daa7 100644 --- a/conf/distro/include/colibri-imx7.conf +++ b/conf/distro/include/colibri-imx7.conf | |||
@@ -41,3 +41,6 @@ PREFERRED_PROVIDER_virtual/egl = "opengldummy" | |||
41 | PREFERRED_PROVIDER_virtual/libgles2 = "opengldummy" | 41 | PREFERRED_PROVIDER_virtual/libgles2 = "opengldummy" |
42 | 42 | ||
43 | DISTRO_FEATURES_remove = "webengine wayland" | 43 | DISTRO_FEATURES_remove = "webengine wayland" |
44 | |||
45 | # try to limit the maximum size of the tezi image | ||
46 | RDEPENDS_packagegroup-b2qt-embedded-base_remove_pn-packagegroup-b2qt-embedded-base = "linux-firmware" | ||
diff --git a/meta-intel-extras/recipes/grub/grub-efi_2.00.bbappend b/meta-intel-extras/recipes/grub/grub-efi_2.00.bbappend index 0104aab..f3a95f2 100644 --- a/meta-intel-extras/recipes/grub/grub-efi_2.00.bbappend +++ b/meta-intel-extras/recipes/grub/grub-efi_2.00.bbappend | |||
@@ -32,7 +32,7 @@ SRC_URI += "file://grub.cfg" | |||
32 | 32 | ||
33 | do_install[depends] += " \ | 33 | do_install[depends] += " \ |
34 | virtual/kernel:do_deploy \ | 34 | virtual/kernel:do_deploy \ |
35 | ${INITRAMFS_IMAGE}:do_rootfs \ | 35 | ${INITRAMFS_IMAGE}:do_image_complete \ |
36 | ${@bb.utils.contains('MACHINE_FEATURES', 'intel-ucode', 'intel-microcode:do_deploy', '', d)} \ | 36 | ${@bb.utils.contains('MACHINE_FEATURES', 'intel-ucode', 'intel-microcode:do_deploy', '', d)} \ |
37 | " | 37 | " |
38 | 38 | ||
diff --git a/recipes-qt/qt5/qtdeviceutilities.bb b/recipes-qt/qt5/qtdeviceutilities.bb index 18dab6d..17c90a4 100644 --- a/recipes-qt/qt5/qtdeviceutilities.bb +++ b/recipes-qt/qt5/qtdeviceutilities.bb | |||
@@ -1,6 +1,6 @@ | |||
1 | ############################################################################ | 1 | ############################################################################ |
2 | ## | 2 | ## |
3 | ## Copyright (C) 2017 The Qt Company Ltd. | 3 | ## Copyright (C) 2018 The Qt Company Ltd. |
4 | ## Contact: https://www.qt.io/licensing/ | 4 | ## Contact: https://www.qt.io/licensing/ |
5 | ## | 5 | ## |
6 | ## This file is part of the Boot to Qt meta layer. | 6 | ## This file is part of the Boot to Qt meta layer. |
@@ -43,6 +43,6 @@ SRC_URI = " \ | |||
43 | git://codereview.qt-project.org/qt/qtdeviceutilities;${QT_MODULE_BRANCH_PARAM};protocol=http \ | 43 | git://codereview.qt-project.org/qt/qtdeviceutilities;${QT_MODULE_BRANCH_PARAM};protocol=http \ |
44 | " | 44 | " |
45 | 45 | ||
46 | SRCREV = "b5eea82532059738a7da751222ebef68539508f1" | 46 | SRCREV = "e0a8b06317bb51ca844818682ebec3cd2c2b5108" |
47 | 47 | ||
48 | DEPENDS = "qtbase qtdeclarative qtconnectivity" | 48 | DEPENDS = "qtbase qtdeclarative qtconnectivity" |
diff --git a/recipes/fonts/otf-noto_git.bb b/recipes/fonts/otf-noto_git.bb index 3be53c2..093ee33 100644 --- a/recipes/fonts/otf-noto_git.bb +++ b/recipes/fonts/otf-noto_git.bb | |||
@@ -45,8 +45,7 @@ S = "${WORKDIR}/git" | |||
45 | 45 | ||
46 | do_install() { | 46 | do_install() { |
47 | install -m 0755 -d ${D}${datadir}/fonts/otf/noto | 47 | install -m 0755 -d ${D}${datadir}/fonts/otf/noto |
48 | install -m 0644 ${S}/NotoSansCJKsc-*.otf ${D}${datadir}/fonts/otf/noto | 48 | install -m 0644 ${S}/NotoSansCJKsc-Regular.otf ${D}${datadir}/fonts/otf/noto |
49 | install -m 0644 ${S}/NotoSansMonoCJKsc-*.otf ${D}${datadir}/fonts/otf/noto | ||
50 | } | 49 | } |
51 | 50 | ||
52 | PACKAGES = "${PN}" | 51 | PACKAGES = "${PN}" |
diff --git a/recipes/fonts/ttf-opensans.bb b/recipes/fonts/ttf-opensans.bb index a4af90e..1d581ac 100644 --- a/recipes/fonts/ttf-opensans.bb +++ b/recipes/fonts/ttf-opensans.bb | |||
@@ -31,20 +31,20 @@ SUMMARY = "Open Sans Fonts" | |||
31 | SECTION = "fonts" | 31 | SECTION = "fonts" |
32 | HOMEPAGE = "https://fonts.google.com" | 32 | HOMEPAGE = "https://fonts.google.com" |
33 | LICENSE = "Apache-2.0" | 33 | LICENSE = "Apache-2.0" |
34 | LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE.txt;md5=d273d63619c9aeaf15cdaf76422c4f87" | 34 | LIC_FILES_CHKSUM = "file://apache/opensans/LICENSE.txt;md5=d273d63619c9aeaf15cdaf76422c4f87" |
35 | 35 | ||
36 | INHIBIT_DEFAULT_DEPS = "1" | 36 | INHIBIT_DEFAULT_DEPS = "1" |
37 | do_unpack[depends] += "unzip-native:do_populate_sysroot" | ||
38 | 37 | ||
39 | inherit allarch fontcache | 38 | inherit allarch fontcache |
40 | 39 | ||
41 | SRC_URI = "https://fonts.google.com/download?family=Open%20Sans;downloadfilename=Open_Sans.zip" | 40 | SRC_URI = "git://github.com/google/fonts" |
42 | # Google packs fonts package on demand which results in unpredictable md5sum, so disable checksum check | 41 | SRCREV = "beaec0837bd21524b57ecb435158f9011fc03999" |
43 | BB_STRICT_CHECKSUM = "" | 42 | |
43 | S = "${WORKDIR}/git" | ||
44 | 44 | ||
45 | do_install() { | 45 | do_install() { |
46 | install -m 0755 -d ${D}${datadir}/fonts/truetype/opensans | 46 | install -m 0755 -d ${D}${datadir}/fonts/truetype/opensans |
47 | install -m 0644 ${WORKDIR}/*.ttf ${D}${datadir}/fonts/truetype/opensans | 47 | install -m 0644 apache/opensans/*.ttf ${D}${datadir}/fonts/truetype/opensans |
48 | } | 48 | } |
49 | 49 | ||
50 | PACKAGES = "${PN}" | 50 | PACKAGES = "${PN}" |