diff options
-rw-r--r-- | recipes-qt/meta/b2qt-sdk.inc | 69 | ||||
-rw-r--r-- | recipes-qt/meta/files/qmake.conf (renamed from recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk/qmake.conf) | 0 | ||||
-rw-r--r-- | recipes-qt/meta/files/qplatformdefs.h (renamed from recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk/qplatformdefs.h) | 0 | ||||
-rw-r--r-- | recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb | 29 | ||||
-rw-r--r-- | recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk.bb | 48 | ||||
-rw-r--r-- | recipes-qt/packagegroups/packagegroup-b2qt-automotive-qt5-toolchain-target.bb | 32 | ||||
-rwxr-xr-x | scripts/upload.sh | 2 |
7 files changed, 132 insertions, 48 deletions
diff --git a/recipes-qt/meta/b2qt-sdk.inc b/recipes-qt/meta/b2qt-sdk.inc new file mode 100644 index 0000000..9eddadc --- /dev/null +++ b/recipes-qt/meta/b2qt-sdk.inc | |||
@@ -0,0 +1,69 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | LICENSE = "QtEnterprise" | ||
24 | LIC_FILES_CHKSUM = "file://${QT_LICENCE};md5=7bc9c54e450006250a60e96604c186c9" | ||
25 | |||
26 | inherit populate_sdk populate_sdk_qt5_base | ||
27 | |||
28 | SRC_URI = " \ | ||
29 | file://qmake.conf \ | ||
30 | file://qplatformdefs.h \ | ||
31 | " | ||
32 | S = "${WORKDIR}" | ||
33 | |||
34 | SDK_MKSPEC_DIR = "${SDK_OUTPUT}${SDKTARGETSYSROOT}${libdir}/${QT_DIR_NAME}/mkspecs" | ||
35 | SDK_MKSPEC = "devices/linux-oe-generic-g++" | ||
36 | SDK_DEVICE_PRI = "${SDK_MKSPEC_DIR}/qdevice.pri" | ||
37 | SDK_DYNAMIC_FLAGS = "-O. -pipe -g" | ||
38 | |||
39 | create_sdk_files_append () { | ||
40 | # Install the toolchain user's generic device mkspec | ||
41 | install -d ${SDK_MKSPEC_DIR}/${SDK_MKSPEC} | ||
42 | install -m 0644 ${WORKDIR}/qmake.conf ${SDK_MKSPEC_DIR}/${SDK_MKSPEC} | ||
43 | install -m 0644 ${WORKDIR}/qplatformdefs.h ${SDK_MKSPEC_DIR}/${SDK_MKSPEC} | ||
44 | |||
45 | # Fill in the qdevice.pri file which will be used by the device mksspec | ||
46 | static_cflags="${TARGET_CFLAGS}" | ||
47 | static_cxxflags="${TARGET_CXXFLAGS}" | ||
48 | for i in ${SDK_DYNAMIC_FLAGS}; do | ||
49 | static_cflags=$(echo $static_cflags | sed -e "s/$i //") | ||
50 | static_cxxflags=$(echo $static_cxxflags | sed -e "s/$i //") | ||
51 | done | ||
52 | echo "MACHINE = ${MACHINE}" > ${SDK_DEVICE_PRI} | ||
53 | echo "CROSS_COMPILE = ${SDKPATHNATIVE}${bindir_nativesdk}/${TARGET_SYS}/${TARGET_PREFIX}" >> ${SDK_DEVICE_PRI} | ||
54 | echo "QMAKE_CFLAGS *= ${TARGET_CC_ARCH} --sysroot=${SDKTARGETSYSROOT} ${static_cflags}" >> ${SDK_DEVICE_PRI} | ||
55 | echo "QMAKE_CXXFLAGS *= ${TARGET_CC_ARCH} --sysroot=${SDKTARGETSYSROOT} ${static_cxxflags}" >> ${SDK_DEVICE_PRI} | ||
56 | echo "QMAKE_LFLAGS *= ${TARGET_CC_ARCH} --sysroot=${SDKTARGETSYSROOT} ${TARGET_LDFLAGS}" >> ${SDK_DEVICE_PRI} | ||
57 | |||
58 | # Setup qt.conf to point at the device mkspec by default | ||
59 | qtconf=${SDK_OUTPUT}/${SDKPATHNATIVE}${OE_QMAKE_PATH_HOST_BINS}/qt.conf | ||
60 | echo 'HostSpec = linux-g++' >> $qtconf | ||
61 | echo 'TargetSpec = devices/linux-oe-generic-g++' >> $qtconf | ||
62 | |||
63 | # change staging paths to target sdk paths, so they can be relocated at install time | ||
64 | sed -i -e 's:${STAGING_DIR_NATIVE}:${SDKPATHNATIVE}:g' ${SDK_MKSPEC_DIR}/*.pri | ||
65 | sed -i -e 's:${STAGING_DIR}/[^/]*:${SDKTARGETSYSROOT}:g' ${SDK_MKSPEC_DIR}/*.pri | ||
66 | } | ||
67 | |||
68 | SDK_POST_INSTALL_COMMAND += "$SUDO_EXEC sed -i -e "s:$DEFAULT_INSTALL_DIR:$target_sdk_dir:g" \ | ||
69 | $target_sdk_dir/sysroots/@REAL_MULTIMACH_TARGET_SYS@/usr/lib/${QT_DIR_NAME}/mkspecs/*.pri ;" | ||
diff --git a/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk/qmake.conf b/recipes-qt/meta/files/qmake.conf index b5962dc..b5962dc 100644 --- a/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk/qmake.conf +++ b/recipes-qt/meta/files/qmake.conf | |||
diff --git a/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk/qplatformdefs.h b/recipes-qt/meta/files/qplatformdefs.h index e10ebcf..e10ebcf 100644 --- a/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk/qplatformdefs.h +++ b/recipes-qt/meta/files/qplatformdefs.h | |||
diff --git a/recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb b/recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb new file mode 100644 index 0000000..6b95276 --- /dev/null +++ b/recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb | |||
@@ -0,0 +1,29 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | DESCRIPTION = "B2Qt embedded Qt5 SDK toolchain" | ||
24 | |||
25 | require b2qt-sdk.inc | ||
26 | |||
27 | TOOLCHAIN_HOST_TASK += "nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host" | ||
28 | TOOLCHAIN_TARGET_TASK += "packagegroup-b2qt-embedded-qt5-toolchain-target \ | ||
29 | packagegroup-b2qt-automotive-qt5-toolchain-target" | ||
diff --git a/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk.bb b/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk.bb index 15c8b97..43f29b3 100644 --- a/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk.bb +++ b/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk.bb | |||
@@ -21,54 +21,8 @@ | |||
21 | ############################################################################# | 21 | ############################################################################# |
22 | 22 | ||
23 | DESCRIPTION = "B2Qt embedded Qt5 SDK toolchain" | 23 | DESCRIPTION = "B2Qt embedded Qt5 SDK toolchain" |
24 | PR = "r0" | ||
25 | LICENSE = "QtEnterprise" | ||
26 | LIC_FILES_CHKSUM = "file://${QT_LICENCE};md5=7bc9c54e450006250a60e96604c186c9" | ||
27 | 24 | ||
28 | inherit populate_sdk populate_sdk_qt5_base | 25 | require b2qt-sdk.inc |
29 | 26 | ||
30 | TOOLCHAIN_HOST_TASK += "nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host" | 27 | TOOLCHAIN_HOST_TASK += "nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host" |
31 | TOOLCHAIN_TARGET_TASK += "packagegroup-b2qt-embedded-qt5-toolchain-target" | 28 | TOOLCHAIN_TARGET_TASK += "packagegroup-b2qt-embedded-qt5-toolchain-target" |
32 | |||
33 | SRC_URI = " \ | ||
34 | file://qmake.conf \ | ||
35 | file://qplatformdefs.h \ | ||
36 | " | ||
37 | S = "${WORKDIR}" | ||
38 | |||
39 | SDK_MKSPEC_DIR = "${SDK_OUTPUT}${SDKTARGETSYSROOT}${libdir}/${QT_DIR_NAME}/mkspecs" | ||
40 | SDK_MKSPEC = "devices/linux-oe-generic-g++" | ||
41 | SDK_DEVICE_PRI = "${SDK_MKSPEC_DIR}/qdevice.pri" | ||
42 | SDK_DYNAMIC_FLAGS = "-O. -pipe -g" | ||
43 | |||
44 | create_sdk_files_append () { | ||
45 | # Install the toolchain user's generic device mkspec | ||
46 | install -d ${SDK_MKSPEC_DIR}/${SDK_MKSPEC} | ||
47 | install -m 0644 ${WORKDIR}/qmake.conf ${SDK_MKSPEC_DIR}/${SDK_MKSPEC} | ||
48 | install -m 0644 ${WORKDIR}/qplatformdefs.h ${SDK_MKSPEC_DIR}/${SDK_MKSPEC} | ||
49 | |||
50 | # Fill in the qdevice.pri file which will be used by the device mksspec | ||
51 | static_cflags="${TARGET_CFLAGS}" | ||
52 | static_cxxflags="${TARGET_CXXFLAGS}" | ||
53 | for i in ${SDK_DYNAMIC_FLAGS}; do | ||
54 | static_cflags=$(echo $static_cflags | sed -e "s/$i //") | ||
55 | static_cxxflags=$(echo $static_cxxflags | sed -e "s/$i //") | ||
56 | done | ||
57 | echo "MACHINE = ${MACHINE}" > ${SDK_DEVICE_PRI} | ||
58 | echo "CROSS_COMPILE = ${SDKPATHNATIVE}${bindir_nativesdk}/${TARGET_SYS}/${TARGET_PREFIX}" >> ${SDK_DEVICE_PRI} | ||
59 | echo "QMAKE_CFLAGS *= ${TARGET_CC_ARCH} --sysroot=${SDKTARGETSYSROOT} ${static_cflags}" >> ${SDK_DEVICE_PRI} | ||
60 | echo "QMAKE_CXXFLAGS *= ${TARGET_CC_ARCH} --sysroot=${SDKTARGETSYSROOT} ${static_cxxflags}" >> ${SDK_DEVICE_PRI} | ||
61 | echo "QMAKE_LFLAGS *= ${TARGET_CC_ARCH} --sysroot=${SDKTARGETSYSROOT} ${TARGET_LDFLAGS}" >> ${SDK_DEVICE_PRI} | ||
62 | |||
63 | # Setup qt.conf to point at the device mkspec by default | ||
64 | qtconf=${SDK_OUTPUT}/${SDKPATHNATIVE}${OE_QMAKE_PATH_HOST_BINS}/qt.conf | ||
65 | echo 'HostSpec = linux-g++' >> $qtconf | ||
66 | echo 'TargetSpec = devices/linux-oe-generic-g++' >> $qtconf | ||
67 | |||
68 | # change staging paths to target sdk paths, so they can be relocated at install time | ||
69 | sed -i -e 's:${STAGING_DIR_NATIVE}:${SDKPATHNATIVE}:g' ${SDK_MKSPEC_DIR}/*.pri | ||
70 | sed -i -e 's:${STAGING_DIR}/[^/]*:${SDKTARGETSYSROOT}:g' ${SDK_MKSPEC_DIR}/*.pri | ||
71 | } | ||
72 | |||
73 | SDK_POST_INSTALL_COMMAND += "$SUDO_EXEC sed -i -e "s:$DEFAULT_INSTALL_DIR:$target_sdk_dir:g" \ | ||
74 | $target_sdk_dir/sysroots/@REAL_MULTIMACH_TARGET_SYS@/usr/lib/${QT_DIR_NAME}/mkspecs/*.pri ;" | ||
diff --git a/recipes-qt/packagegroups/packagegroup-b2qt-automotive-qt5-toolchain-target.bb b/recipes-qt/packagegroups/packagegroup-b2qt-automotive-qt5-toolchain-target.bb new file mode 100644 index 0000000..cfb7245 --- /dev/null +++ b/recipes-qt/packagegroups/packagegroup-b2qt-automotive-qt5-toolchain-target.bb | |||
@@ -0,0 +1,32 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | DESCRIPTION = "Target packages for B2Qt Automotive Qt5 SDK" | ||
24 | LICENSE = "QtEnterprise" | ||
25 | PR = "r0" | ||
26 | |||
27 | inherit packagegroup | ||
28 | |||
29 | PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1" | ||
30 | |||
31 | RDEPENDS_${PN} += " \ | ||
32 | " | ||
diff --git a/scripts/upload.sh b/scripts/upload.sh index f74da52..aba0e76 100755 --- a/scripts/upload.sh +++ b/scripts/upload.sh | |||
@@ -28,7 +28,7 @@ RELEASE=5.6 | |||
28 | UPLOADPATH=QT@ci-files02-hki.ci.local:/srv/jenkins_data/enterprise/b2qt/yocto/${RELEASE}/ | 28 | UPLOADPATH=QT@ci-files02-hki.ci.local:/srv/jenkins_data/enterprise/b2qt/yocto/${RELEASE}/ |
29 | 29 | ||
30 | if [ ${AUTOMOTIVE} = "true" ]; then | 30 | if [ ${AUTOMOTIVE} = "true" ]; then |
31 | scp tmp/deploy/sdk/b2qt-glibc-x86_64-meta-toolchain-b2qt-embedded-qt5-sdk-*.sh ${UPLOADPATH}/b2qt-x86_64-automotive-toolchain-${MACHINE}.sh | 31 | scp tmp/deploy/sdk/b2qt-glibc-x86_64-meta-toolchain-b2qt-automotive-qt5-sdk-*.sh ${UPLOADPATH}/b2qt-x86_64-automotive-toolchain-${MACHINE}.sh |
32 | if [ -e tmp/deploy/images/${MACHINE}/b2qt-automotive-qt5-image-${MACHINE}.hdd ]; then | 32 | if [ -e tmp/deploy/images/${MACHINE}/b2qt-automotive-qt5-image-${MACHINE}.hdd ]; then |
33 | scp tmp/deploy/images/${MACHINE}/b2qt-automotive-qt5-image-${MACHINE}.hdd ${UPLOADPATH}/ | 33 | scp tmp/deploy/images/${MACHINE}/b2qt-automotive-qt5-image-${MACHINE}.hdd ${UPLOADPATH}/ |
34 | elif [ -e tmp/deploy/images/${MACHINE}/b2qt-automotive-qt5-image-${MACHINE}.img ]; then | 34 | elif [ -e tmp/deploy/images/${MACHINE}/b2qt-automotive-qt5-image-${MACHINE}.img ]; then |