diff options
-rw-r--r-- | recipes/wayland/wayland/0001-Use-native-wayland-scanner-when-building-nativesdk-w.patch | 36 | ||||
-rw-r--r-- | recipes/wayland/wayland_1.%.bbappend | 2 |
2 files changed, 18 insertions, 20 deletions
diff --git a/recipes/wayland/wayland/0001-Use-native-wayland-scanner-when-building-nativesdk-w.patch b/recipes/wayland/wayland/0001-Use-native-wayland-scanner-when-building-nativesdk-w.patch index 2a691a1..9e5fe4d 100644 --- a/recipes/wayland/wayland/0001-Use-native-wayland-scanner-when-building-nativesdk-w.patch +++ b/recipes/wayland/wayland/0001-Use-native-wayland-scanner-when-building-nativesdk-w.patch | |||
@@ -1,27 +1,25 @@ | |||
1 | From a9ab89496d32ab42d9f697c43cf8bb04feaeabfa Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuli Piippo <samuli.piippo@digia.com> | ||
3 | Date: Fri, 26 Sep 2014 10:39:51 +0300 | ||
4 | Subject: [PATCH] Use native wayland-scanner when building nativesdk-wayland | ||
5 | |||
6 | The wayland-scanner built for the nativesdk cannot be run during the build, | 1 | The wayland-scanner built for the nativesdk cannot be run during the build, |
7 | so instead use the wayland-scanner from native build. | 2 | so instead use the wayland-scanner from native build. |
8 | --- | ||
9 | src/Makefile.am | 2 +- | ||
10 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
11 | 3 | ||
12 | diff --git a/src/Makefile.am b/src/Makefile.am | 4 | Upstream-Status: Pending |
13 | index b938d17..84fcdf6 100644 | 5 | |
14 | --- a/src/Makefile.am | 6 | Signed-off-by: Samuli Piippo <samuli.piippo@theqtcompany.com> |
15 | +++ b/src/Makefile.am | 7 | --- |
16 | @@ -41,7 +41,7 @@ AM_CFLAGS = $(GCC_CFLAGS) -pthread | 8 | Makefile.am | 4 +--- |
17 | protocoldir = $(top_srcdir)/protocol | 9 | 1 file changed, 1 insertion(+), 3 deletions(-) |
10 | diff --git a/Makefile.am b/Makefile.am | ||
11 | index c15d8b8..45f7133 100644 | ||
12 | --- a/Makefile.am | ||
13 | +++ b/Makefile.am | ||
14 | @@ -62,7 +62,7 @@ nodist_libwayland_client_la_SOURCES = \ | ||
15 | pkgconfig_DATA += src/wayland-client.pc src/wayland-server.pc | ||
18 | 16 | ||
19 | if ENABLE_SCANNER | 17 | if ENABLE_SCANNER |
20 | -wayland_scanner = $(top_builddir)/src/wayland-scanner | 18 | -wayland_scanner = $(top_builddir)/wayland-scanner |
21 | +wayland_scanner = wayland-scanner | 19 | +wayland_scanner = wayland-scanner |
22 | else | 20 | bin_PROGRAMS = wayland-scanner |
23 | wayland_scanner = wayland-scanner | 21 | wayland_scanner_SOURCES = src/scanner.c |
24 | endif | 22 | wayland_scanner_LDADD = $(EXPAT_LIBS) libwayland-util.la |
25 | -- | 23 | -- |
26 | 1.8.3.2 | 24 | 1.9.1 |
27 | 25 | ||
diff --git a/recipes/wayland/wayland_1.%.bbappend b/recipes/wayland/wayland_1.%.bbappend index 8df7524..f61301d 100644 --- a/recipes/wayland/wayland_1.%.bbappend +++ b/recipes/wayland/wayland_1.%.bbappend | |||
@@ -21,7 +21,7 @@ | |||
21 | ############################################################################# | 21 | ############################################################################# |
22 | 22 | ||
23 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | 23 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
24 | SRC_URI_append_class-nativesdk = " file://just-scanner.patch \ | 24 | SRC_URI_append_class-nativesdk = " \ |
25 | file://disable-macro-checks-not-used-for-scanner.patch \ | 25 | file://disable-macro-checks-not-used-for-scanner.patch \ |
26 | file://0001-Use-native-wayland-scanner-when-building-nativesdk-w.patch \ | 26 | file://0001-Use-native-wayland-scanner-when-building-nativesdk-w.patch \ |
27 | " | 27 | " |