diff options
-rw-r--r-- | meta-fsl-extras/recipes/amd-gpu-bin-mx51/amd-gpu-bin-mx51/0001-fix-glTexImage2D-API.patch | 26 | ||||
-rw-r--r-- | meta-fsl-extras/recipes/amd-gpu-bin-mx51/amd-gpu-bin-mx51_11.09.01.bbappend (renamed from meta-fsl-extras/recipes/amd-gpu-x11-bin-mx51/amd-gpu-x11-bin-mx51_11.09.01.bbappend) | 6 |
2 files changed, 30 insertions, 2 deletions
diff --git a/meta-fsl-extras/recipes/amd-gpu-bin-mx51/amd-gpu-bin-mx51/0001-fix-glTexImage2D-API.patch b/meta-fsl-extras/recipes/amd-gpu-bin-mx51/amd-gpu-bin-mx51/0001-fix-glTexImage2D-API.patch new file mode 100644 index 0000000..0a3cd76 --- /dev/null +++ b/meta-fsl-extras/recipes/amd-gpu-bin-mx51/amd-gpu-bin-mx51/0001-fix-glTexImage2D-API.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | From ec1c2b5f637145e2a473820401ab96ecf0f16def Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuli Piippo <samuli.piippo@digia.com> | ||
3 | Date: Mon, 8 Sep 2014 10:23:46 +0300 | ||
4 | Subject: [PATCH] fix glTexImage2D API | ||
5 | |||
6 | internalformat should be GLint and not GLenum. | ||
7 | --- | ||
8 | usr/include/GLES2/gl2.h | 2 +- | ||
9 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
10 | |||
11 | diff --git a/usr/include/GLES2/gl2.h b/usr/include/GLES2/gl2.h | ||
12 | index c0e3a44..5aa6c26 100755 | ||
13 | --- a/usr/include/GLES2/gl2.h | ||
14 | +++ b/usr/include/GLES2/gl2.h | ||
15 | @@ -579,7 +579,7 @@ GL_APICALL void GL_APIENTRY glStencilMask (GLuint mask); | ||
16 | GL_APICALL void GL_APIENTRY glStencilMaskSeparate (GLenum face, GLuint mask); | ||
17 | GL_APICALL void GL_APIENTRY glStencilOp (GLenum fail, GLenum zfail, GLenum zpass); | ||
18 | GL_APICALL void GL_APIENTRY glStencilOpSeparate (GLenum face, GLenum fail, GLenum zfail, GLenum zpass); | ||
19 | -GL_APICALL void GL_APIENTRY glTexImage2D (GLenum target, GLint level, GLenum internalformat, GLsizei width, GLsizei height, GLint border, GLenum format, GLenum type, const void* pixels); | ||
20 | +GL_APICALL void GL_APIENTRY glTexImage2D (GLenum target, GLint level, GLint internalformat, GLsizei width, GLsizei height, GLint border, GLenum format, GLenum type, const GLvoid* pixels); | ||
21 | GL_APICALL void GL_APIENTRY glTexParameterf (GLenum target, GLenum pname, GLfloat param); | ||
22 | GL_APICALL void GL_APIENTRY glTexParameterfv (GLenum target, GLenum pname, const GLfloat* params); | ||
23 | GL_APICALL void GL_APIENTRY glTexParameteri (GLenum target, GLenum pname, GLint param); | ||
24 | -- | ||
25 | 1.8.3.2 | ||
26 | |||
diff --git a/meta-fsl-extras/recipes/amd-gpu-x11-bin-mx51/amd-gpu-x11-bin-mx51_11.09.01.bbappend b/meta-fsl-extras/recipes/amd-gpu-bin-mx51/amd-gpu-bin-mx51_11.09.01.bbappend index 40075c0..23480a8 100644 --- a/meta-fsl-extras/recipes/amd-gpu-x11-bin-mx51/amd-gpu-x11-bin-mx51_11.09.01.bbappend +++ b/meta-fsl-extras/recipes/amd-gpu-bin-mx51/amd-gpu-bin-mx51_11.09.01.bbappend | |||
@@ -20,5 +20,7 @@ | |||
20 | ## | 20 | ## |
21 | ############################################################################# | 21 | ############################################################################# |
22 | 22 | ||
23 | # dependency to x11 only when distro features have it | 23 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" |
24 | DEPENDS = "${@base_contains('DISTRO_FEATURES', 'x11', 'virtual/libx11', '', d)}" | 24 | SRC_URI += " \ |
25 | file://0001-fix-glTexImage2D-API.patch \ | ||
26 | " | ||