diff options
16 files changed, 478 insertions, 0 deletions
diff --git a/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.inc b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.inc new file mode 100644 index 0000000..f661539 --- /dev/null +++ b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.inc | |||
@@ -0,0 +1,246 @@ | |||
1 | # Copyright (C) 2012-2013 Freescale Semiconductor | ||
2 | # Copyright (C) 2012-2013 O.S. Systems Software LTDA. | ||
3 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
4 | |||
5 | DESCRIPTION = "GPU driver and apps for imx6" | ||
6 | SECTION = "libs" | ||
7 | LICENSE = "Proprietary" | ||
8 | LIC_FILES_CHKSUM = "file://usr/include/gc_vdk.h;endline=11;md5=19f5925343fa3da65596eeaa4ddb5fd3" | ||
9 | DEPENDS += "${@base_contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxdamage libxext libxfixes mesa', '', d)}" | ||
10 | PROVIDES += "virtual/wayland-egl virtual/libgl virtual/libgal-x11 virtual/egl virtual/libgles1 virtual/libgles2 virtual/libopenvg" | ||
11 | |||
12 | PE = "1" | ||
13 | |||
14 | inherit fsl-eula-unpack | ||
15 | |||
16 | SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true \ | ||
17 | file://egl.pc \ | ||
18 | file://egl_x11.pc \ | ||
19 | file://glesv1_cm.pc \ | ||
20 | file://glesv1_cm_x11.pc \ | ||
21 | file://glesv2.pc \ | ||
22 | file://glesv2_x11.pc \ | ||
23 | file://vg.pc \ | ||
24 | file://vg_x11.pc \ | ||
25 | file://gc_wayland_protocol.pc \ | ||
26 | file://wayland-egl.pc \ | ||
27 | file://wayland-viv.pc \ | ||
28 | " | ||
29 | |||
30 | PACKAGES =+ "libclc-mx6 libclc-mx6-dev libclc-mx6-dbg \ | ||
31 | libgl-mx6 libgl-mx6-dev libgl-mx6-dbg \ | ||
32 | libgles-mx6 libgles-mx6-dev libgles-mx6-dbg \ | ||
33 | libgles2-mx6 libgles2-mx6-dev libgles2-mx6-dbg \ | ||
34 | libglslc-mx6 libglslc-mx6-dev libglslc-mx6-dbg \ | ||
35 | libopencl-mx6 libopencl-mx6-dev libopencl-mx6-dbg \ | ||
36 | libopenvg-mx6 libopenvg-mx6-dev libopenvg-mx6-dbg \ | ||
37 | libvdk-mx6 libvdk-mx6-dev libvdk-mx6-dbg \ | ||
38 | libegl-mx6 libegl-mx6-dev libegl-mx6-dbg \ | ||
39 | libgal-mx6 libgal-mx6-dev libgal-mx6-dbg \ | ||
40 | libvivante-mx6 libvivante-mx6-dev libvivante-mx6-dbg \ | ||
41 | libvivante-dri-mx6 \ | ||
42 | libvivante-dfb-mx6 \ | ||
43 | libwayland-viv-mx6 libwayland-viv-mx6-dev libwayland-viv-mx6-dbg \ | ||
44 | libgc-wayland-protocol-mx6 libgc-wayland-protocol-mx6-dev libgc-wayland-protocol-mx6-dbg \ | ||
45 | libwayland-egl-mx6-dev \ | ||
46 | " | ||
47 | |||
48 | # Skip package if it does not match the machine float-point type in use | ||
49 | python __anonymous () { | ||
50 | is_machine_hardfp = base_contains("TUNE_FEATURES", "callconvention-hard", True, False, d) | ||
51 | is_package_hardfp = d.getVar("PACKAGE_FP_TYPE", True) == "hardfp" | ||
52 | |||
53 | if is_package_hardfp != is_machine_hardfp: | ||
54 | PN = d.getVar("PN", True) | ||
55 | PV = d.getVar("PV", True) | ||
56 | bb.debug(1, "Skipping %s (%s) as machine and package float-point does not match" % (PN, PV)) | ||
57 | raise bb.parse.SkipPackage("Package Float-Point is not compatible with the machine") | ||
58 | } | ||
59 | |||
60 | USE_X11 = "${@base_contains("DISTRO_FEATURES", "x11", "yes", "no", d)}" | ||
61 | USE_DFB = "${@base_contains("DISTRO_FEATURES", "directfb", "yes", "no", d)}" | ||
62 | USE_WL = "${@base_contains("DISTRO_FEATURES", "wayland", "yes", "no", d)}" | ||
63 | |||
64 | # Inhibit warnings about files being stripped. | ||
65 | INHIBIT_PACKAGE_STRIP = "1" | ||
66 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | ||
67 | |||
68 | # FIXME: The provided binary doesn't provide soname. If in future BSP | ||
69 | # release the libraries are fixed, we can drop this hack. | ||
70 | REALSOLIBS := "${SOLIBS}" | ||
71 | SOLIBS = "${SOLIBSDEV}" | ||
72 | |||
73 | # For the packages that make up the OpenGL interfaces, inject variables so that | ||
74 | # they don't get Debian-renamed (which would remove the -mx6 suffix). | ||
75 | # | ||
76 | # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have | ||
77 | # the source we cannot fix it. Disable the insane check for now. | ||
78 | python __anonymous() { | ||
79 | packages = d.getVar('PACKAGES', True).split() | ||
80 | for p in packages: | ||
81 | d.appendVar("INSANE_SKIP_%s" % p, " ldflags") | ||
82 | |||
83 | for p in (("libegl", "libegl1"), ("libgl", "libgl1"), | ||
84 | ("libgles1", "libglesv1-cm1"), ("libgles2", "libglesv2-2"), | ||
85 | ("libgles3",)): | ||
86 | fullp = p[0] + "-mx6" | ||
87 | pkgs = " ".join(p) | ||
88 | d.setVar("DEBIAN_NOAUTONAME_" + fullp, "1") | ||
89 | d.appendVar("RREPLACES_" + fullp, pkgs) | ||
90 | d.appendVar("RPROVIDES_" + fullp, pkgs) | ||
91 | d.appendVar("RCONFLICTS_" + fullp, pkgs) | ||
92 | |||
93 | # For -dev, the first element is both the Debian and original name | ||
94 | fullp += "-dev" | ||
95 | pkgs = p[0] + "-dev" | ||
96 | d.setVar("DEBIAN_NOAUTONAME_" + fullp, "1") | ||
97 | d.appendVar("RREPLACES_" + fullp, pkgs) | ||
98 | d.appendVar("RPROVIDES_" + fullp, pkgs) | ||
99 | d.appendVar("RCONFLICTS_" + fullp, pkgs) | ||
100 | } | ||
101 | |||
102 | do_install () { | ||
103 | install -d ${D}${libdir} | ||
104 | install -d ${D}${includedir} | ||
105 | |||
106 | cp -a ${S}/usr/lib/*.so* ${D}${libdir} | ||
107 | cp -axr ${S}/usr/include/* ${D}${includedir} | ||
108 | cp -axr ${S}/opt ${D} | ||
109 | |||
110 | install -d ${D}${libdir}/pkgconfig | ||
111 | |||
112 | # The preference order, based in DISTRO_FEATURES, is x11, wayland, directfb and fb | ||
113 | if [ "${USE_X11}" = "yes" ]; then | ||
114 | cp -r ${S}/usr/lib/dri ${D}${libdir} | ||
115 | backend=x11 | ||
116 | |||
117 | install -m 0644 ${WORKDIR}/egl_x11.pc ${D}${libdir}/pkgconfig/egl.pc | ||
118 | install -m 0644 ${WORKDIR}/glesv1_cm_x11.pc ${D}${libdir}/pkgconfig/glesv1_cm.pc | ||
119 | install -m 0644 ${WORKDIR}/glesv2_x11.pc ${D}${libdir}/pkgconfig/glesv2.pc | ||
120 | install -m 0644 ${WORKDIR}/vg_x11.pc ${D}${libdir}/pkgconfig/vg.pc | ||
121 | #FIXME: WL & X11 is not currently functional | ||
122 | #if [ "${USE_WL}" = "yes" ]; then | ||
123 | # install -m 0644 ${WORKDIR}/gc_wayland_protocol.pc ${D}${libdir}/pkgconfig/gc_wayland_protocol.pc | ||
124 | # install -m 0644 ${WORKDIR}/wayland-egl.pc ${D}${libdir}/pkgconfig/wayland-egl.pc | ||
125 | # install -m 0644 ${WORKDIR}/wayland-viv.pc ${D}${libdir}/pkgconfig/wayland-viv.pc | ||
126 | #fi | ||
127 | elif [ "${USE_WL}" = "yes" ]; then | ||
128 | backend=wl | ||
129 | |||
130 | install -m 0644 ${WORKDIR}/egl.pc ${D}${libdir}/pkgconfig/egl.pc | ||
131 | install -m 0644 ${WORKDIR}/glesv1_cm.pc ${D}${libdir}/pkgconfig/glesv1_cm.pc | ||
132 | install -m 0644 ${WORKDIR}/glesv2.pc ${D}${libdir}/pkgconfig/glesv2.pc | ||
133 | install -m 0644 ${WORKDIR}/vg.pc ${D}${libdir}/pkgconfig/vg.pc | ||
134 | install -m 0644 ${WORKDIR}/gc_wayland_protocol.pc ${D}${libdir}/pkgconfig/gc_wayland_protocol.pc | ||
135 | install -m 0644 ${WORKDIR}/wayland-egl.pc ${D}${libdir}/pkgconfig/wayland-egl.pc | ||
136 | install -m 0644 ${WORKDIR}/wayland-viv.pc ${D}${libdir}/pkgconfig/wayland-viv.pc | ||
137 | else | ||
138 | install -m 0644 ${WORKDIR}/egl.pc ${D}${libdir}/pkgconfig/egl.pc | ||
139 | install -m 0644 ${WORKDIR}/glesv1_cm.pc ${D}${libdir}/pkgconfig/glesv1_cm.pc | ||
140 | install -m 0644 ${WORKDIR}/glesv2.pc ${D}${libdir}/pkgconfig/glesv2.pc | ||
141 | install -m 0644 ${WORKDIR}/vg.pc ${D}${libdir}/pkgconfig/vg.pc | ||
142 | |||
143 | if [ "${USE_DFB}" = "yes" ]; then | ||
144 | cp -r ${S}/usr/lib/directfb-1.6-0 ${D}${libdir} | ||
145 | backend=dfb | ||
146 | else | ||
147 | # Regular framebuffer | ||
148 | backend=fb | ||
149 | fi | ||
150 | fi | ||
151 | |||
152 | # We'll only have one backend here so we rename it to generic name | ||
153 | # and avoid rework in other packages, when possible | ||
154 | mv ${D}${libdir}/libGL.so.1.2 ${D}${libdir}/libGL.so.1.2.0 | ||
155 | ln -sf libGL.so.1.2.0 ${D}${libdir}/libGL.so.1.2 | ||
156 | ln -sf libGL.so.1.2.0 ${D}${libdir}/libGL.so | ||
157 | mv ${D}${libdir}/libEGL-${backend}.so ${D}${libdir}/libEGL.so.1.0 | ||
158 | ln -sf libEGL.so.1.0 ${D}${libdir}/libEGL.so.1 | ||
159 | ln -sf libEGL.so.1.0 ${D}${libdir}/libEGL.so | ||
160 | mv ${D}${libdir}/libGAL-${backend}.so ${D}${libdir}/libGAL.so | ||
161 | mv ${D}${libdir}/libVIVANTE-${backend}.so ${D}${libdir}/libVIVANTE.so | ||
162 | |||
163 | for backend in wl x11 fb dfb; do | ||
164 | find ${D}${libdir} -name "*-$backend.so" -exec rm '{}' ';' | ||
165 | done | ||
166 | |||
167 | find ${D}${libdir} -type f -exec chmod 644 {} \; | ||
168 | find ${D}${includedir} -type f -exec chmod 644 {} \; | ||
169 | } | ||
170 | |||
171 | S = "${WORKDIR}/${PN}-${PV}" | ||
172 | |||
173 | FILES_${PN} += "/opt" | ||
174 | FILES_${PN}-dev = "${includedir}" | ||
175 | FILES_${PN}-dbg = "${libdir}/.debug /opt/viv_samples/*/*/.debug" | ||
176 | |||
177 | FILES_libclc-mx6 = "${libdir}/libCLC${SOLIBS}" | ||
178 | FILES_libclc-mx6-dev = "${includedir}/CL ${libdir}/libCLC${SOLIBSDEV}" | ||
179 | FILES_libclc-mx6-dbg = "${libdir}/.debug/libCLC${SOLIBS}" | ||
180 | |||
181 | # libEGL.so is used by some demo apps from Freescale | ||
182 | INSANE_SKIP_libegl-mx6 += "dev-so" | ||
183 | FILES_libegl-mx6 = "${libdir}/libEGL${REALSOLIBS} ${libdir}/libEGL${SOLIBSDEV} " | ||
184 | FILES_libegl-mx6-dev = "${includedir}/EGL ${includedir}/KHR ${libdir}/pkgconfig/egl.pc" | ||
185 | FILES_libegl-mx6-dbg = "${libdir}/.debug/libEGL${SOLIBS}" | ||
186 | |||
187 | FILES_libgal-mx6 = "${libdir}/libGAL${SOLIBS}" | ||
188 | FILES_libgal-mx6-dev = "${libdir}/libGAL${SOLIBSDEV}" | ||
189 | FILES_libgal-mx6-dbg = "${libdir}/.debug/libGAL${SOLIBS}" | ||
190 | |||
191 | FILES_libgl-mx6 = "${libdir}/libGL${REALSOLIBS}" | ||
192 | FILES_libgl-mx6-dev = "${libdir}/libGL${SOLIBSDEV}" | ||
193 | FILES_libgl-mx6-dbg = "${libdir}/.debug/libGL.${SOLIBS}" | ||
194 | RDEPENDS_libgl-mx6-dev = "libgl-mesa-dev" | ||
195 | |||
196 | # libEGL needs to open libGLESv1.so | ||
197 | INSANE_SKIP_libgles-mx6 += "dev-so" | ||
198 | FILES_libgles-mx6 = "${libdir}/libGLESv1*${REALSOLIBS} ${libdir}/libGLESv1*${SOLIBS} ${libdir}/libGLES_*${SOLIBS}" | ||
199 | FILES_libgles-mx6-dev = "${includedir}/GLES ${libdir}/libGLESv1*${SOLIBS} ${libdir}/libGLES_*${SOLIBSDEV} ${libdir}/pkgconfig/glesv1_cm.pc" | ||
200 | FILES_libgles-mx6-dbg = "${libdir}/.debug/libGLESv1*${SOLIBS} ${libdir}/.debug/libGLES_*${SOLIBS}" | ||
201 | |||
202 | # libEGL needs to open libGLESv2.so | ||
203 | INSANE_SKIP_libgles2-mx6 += "dev-so" | ||
204 | FILES_libgles2-mx6 = "${libdir}/libGLESv2${REALSOLIBS} ${libdir}/libGLESv2${SOLIBS}" | ||
205 | FILES_libgles2-mx6-dev = "${includedir}/GLES2 ${libdir}/libGLESv2${SOLIBSDEV} ${libdir}/pkgconfig/glesv2.pc" | ||
206 | FILES_libgles2-mx6-dbg = "${libdir}/.debug/libGLESv2${SOLIBS}" | ||
207 | RDEPENDS_libgles2-mx6 = "libglslc-mx6" | ||
208 | |||
209 | FILES_libglslc-mx6 = "${libdir}/libGLSLC${SOLIBS}" | ||
210 | FILES_libglslc-mx6-dev = "${includedir}/CL ${libdir}/libGLSLC${SOLIBSDEV}" | ||
211 | FILES_libglslc-mx6-dbg = "${libdir}/.debug/libGLSLC${SOLIBS}" | ||
212 | |||
213 | FILES_libopencl-mx6 = "${libdir}/libOpenCL${SOLIBS}" | ||
214 | FILES_libopencl-mx6-dev = "${includedir}/CL ${libdir}/libOpenCL${SOLIBSDEV}" | ||
215 | FILES_libopencl-mx6-dbg = "${libdir}/.debug/libOpenCL${SOLIBS}" | ||
216 | RDEPENDS_libopencl-mx6 = "libclc-mx6" | ||
217 | |||
218 | FILES_libopenvg-mx6 = "${libdir}/libOpenVG*${SOLIBS}" | ||
219 | FILES_libopenvg-mx6-dev = "${includedir}/VG ${libdir}/libOpenVG*${SOLIBSDEV} ${libdir}/pkgconfig/vg.pc" | ||
220 | FILES_libopenvg-mx6-dbg = "${libdir}/.debug/libOpenVG*${SOLIBS}" | ||
221 | |||
222 | FILES_libvdk-mx6 = "${libdir}/libVDK${SOLIBS}" | ||
223 | FILES_libvdk-mx6-dev = "${includedir}/*vdk.h ${libdir}/libVDK${SOLIBSDEV}" | ||
224 | FILES_libvdk-mx6-dbg = "${libdir}/.debug/libVDK${SOLIBS}" | ||
225 | |||
226 | FILES_libvivante-mx6 = "${libdir}/libVIVANTE${SOLIBS}" | ||
227 | FILES_libvivante-mx6-dev = "${libdir}/libVIVANTE${SOLIBSDEV}" | ||
228 | FILES_libvivante-mx6-dbg = "${libdir}/.debug/libVIVANTE${SOLIBS}" | ||
229 | |||
230 | FILES_libvivante-dri-mx6 = "${libdir}/dri/vivante_dri.so" | ||
231 | |||
232 | FILES_libvivante-dfb-mx6 = "${libdir}/directfb-1.6-0/gfxdrivers/libdirectfb_gal.so" | ||
233 | |||
234 | INSANE_SKIP_libwayland-viv-mx6 += "dev-so" | ||
235 | FILES_libwayland-viv-mx6 = "${libdir}/libwayland-viv${REALSOLIBS} ${libdir}/libwayland-viv${SOLIBS}" | ||
236 | FILES_libwayland-viv-mx6-dev = "${libdir})/libwayland-viv${SOLIBSDEV} ${libdir}/pkgconfig/wayland-viv.pc" | ||
237 | FILES_libwayland-viv-mx6-dbg = "${libdir}/.debug/libwayland-viv${SOLIBS}" | ||
238 | |||
239 | INSANE_SKIP_libgc-wayland-protocol-mx6 += "dev-so" | ||
240 | FILES_libgc-wayland-protocol-mx6 = "${libdir}/libgc_wayland_protocol${REALSOLIBS} ${libdir}/libgc_wayland_protocol${SOLIBS}" | ||
241 | FILES_libgc-wayland-protocol-mx6-dev = "${libdir}/libgc_wayland_protocol${SOLIBSDEV} ${libdir}/pkgconfig/gc_wayland_protocol.pc" | ||
242 | FILES_libgc-wayland-protocol-mx6-dbg = "${libdir}/libgc_wayland_protocol${SOLIBS}" | ||
243 | |||
244 | FILES_libwayland-egl-mx6-dev = "${libdir}/pkgconfig/wayland-egl.pc" | ||
245 | |||
246 | COMPATIBLE_MACHINE = "(mx6)" | ||
diff --git a/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/0001-change-header-path-to-HAL.patch b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/0001-change-header-path-to-HAL.patch new file mode 100644 index 0000000..dc91d7c --- /dev/null +++ b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/0001-change-header-path-to-HAL.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | From 1a4a35678ef70283d1a31835deecd39711a9db86 Mon Sep 17 00:00:00 2001 | ||
2 | From: Jeremy Stashluk <jstashluk@dekaresearch.com> | ||
3 | Date: Wed, 30 Jan 2013 13:16:53 -0500 | ||
4 | Subject: [PATCH] change header path to HAL | ||
5 | |||
6 | The gpu-viv-bin-mx6q package from Freescale puts this header in the HAL | ||
7 | directory under the system. I think this is a problem in the LTIB release as | ||
8 | well. | ||
9 | |||
10 | Upstream-Status: Pending | ||
11 | |||
12 | Signed-off-by: Jeremy Stashluk <jstashluk@dekaresearch.com> | ||
13 | |||
14 | --- | ||
15 | usr/include/gc_vdk_types.h | 2 +- | ||
16 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
17 | |||
18 | Index: gpu-viv-bin-mx6q-1.1.0/usr/include/gc_vdk_types.h | ||
19 | =================================================================== | ||
20 | --- gpu-viv-bin-mx6q-1.1.0.orig/usr/include/gc_vdk_types.h | ||
21 | +++ gpu-viv-bin-mx6q-1.1.0/usr/include/gc_vdk_types.h | ||
22 | @@ -39,7 +39,7 @@ extern "C" { | ||
23 | #endif | ||
24 | |||
25 | #include <EGL/egl.h> | ||
26 | -#include "gc_hal_eglplatform_type.h" | ||
27 | +#include <HAL/gc_hal_eglplatform_type.h> | ||
28 | |||
29 | |||
30 | /******************************************************************************* | ||
diff --git a/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/egl.pc b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/egl.pc new file mode 100644 index 0000000..a21922d --- /dev/null +++ b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/egl.pc | |||
@@ -0,0 +1,12 @@ | |||
1 | prefix=/usr | ||
2 | exec_prefix=${prefix} | ||
3 | libdir=/usr/lib | ||
4 | includedir=/usr/include | ||
5 | |||
6 | Name: egl | ||
7 | Description: Vivante EGL library | ||
8 | Requires.private: | ||
9 | Version: 8.0 | ||
10 | Libs: -L${libdir} -lEGL | ||
11 | Libs.private: -lm -lpthread -ldl | ||
12 | Cflags: -I${includedir} -DLINUX | ||
diff --git a/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/egl_x11.pc b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/egl_x11.pc new file mode 100644 index 0000000..5921583 --- /dev/null +++ b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/egl_x11.pc | |||
@@ -0,0 +1,12 @@ | |||
1 | prefix=/usr | ||
2 | exec_prefix=${prefix} | ||
3 | libdir=/usr/lib | ||
4 | includedir=/usr/include | ||
5 | |||
6 | Name: egl | ||
7 | Description: Vivante EGL library | ||
8 | Requires.private: libdrm x11 xext xdamage xfixes xcb | ||
9 | Version: 8.0 | ||
10 | Libs: -L${libdir} -lEGL | ||
11 | Libs.private: -lm -lpthread -ldl | ||
12 | Cflags: -I${includedir} -DLINUX | ||
diff --git a/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/fix-conflicting-TLS-definition.patch b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/fix-conflicting-TLS-definition.patch new file mode 100644 index 0000000..3eac116 --- /dev/null +++ b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/fix-conflicting-TLS-definition.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | Avoid conflicting types with Xorg newer code | ||
2 | |||
3 | Upstream-Status: Pending | ||
4 | Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> | ||
5 | |||
6 | Index: gpu-viv-bin-mx6q-1.1.0/usr/include/HAL/gc_hal_base.h | ||
7 | =================================================================== | ||
8 | --- gpu-viv-bin-mx6q-1.1.0.orig/usr/include/HAL/gc_hal_base.h | ||
9 | +++ gpu-viv-bin-mx6q-1.1.0/usr/include/HAL/gc_hal_base.h | ||
10 | @@ -101,7 +101,7 @@ extern gcsPLS gcPLS; | ||
11 | typedef struct _gcsTLS * gcsTLS_PTR; | ||
12 | |||
13 | typedef void (* gctTLS_DESTRUCTOR) ( | ||
14 | - gcsTLS_PTR TLS | ||
15 | + gcsTLS_PTR pTLS | ||
16 | ); | ||
17 | |||
18 | typedef struct _gcsTLS | ||
19 | @@ -648,10 +648,10 @@ gcoOS_SetPLSValue( | ||
20 | /* Get access to the thread local storage. */ | ||
21 | gceSTATUS | ||
22 | gcoOS_GetTLS( | ||
23 | - OUT gcsTLS_PTR * TLS | ||
24 | + OUT gcsTLS_PTR * pTLS | ||
25 | ); | ||
26 | |||
27 | - /* Copy the TLS from a source thread. */ | ||
28 | + /* Copy the pTLS from a source thread. */ | ||
29 | gceSTATUS gcoOS_CopyTLS(IN gcsTLS_PTR Source); | ||
30 | |||
31 | /* Destroy the objects associated with the current thread. */ | ||
diff --git a/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/gc_hal_eglplatform-remove-xlib-undefs.patch b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/gc_hal_eglplatform-remove-xlib-undefs.patch new file mode 100644 index 0000000..732a073 --- /dev/null +++ b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/gc_hal_eglplatform-remove-xlib-undefs.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From c59f9640d185759208f9d55a93b6602936dcb5e8 Mon Sep 17 00:00:00 2001 | ||
2 | From: Adrian Alonso <aalonso00@gmail.com> | ||
3 | Date: Sat, 26 Jan 2013 17:52:04 -0600 | ||
4 | Subject: [PATCH 2/2] gc_hal_eglplatform: remove xlib undefs | ||
5 | |||
6 | * Remove header undefs for Always and Status definitions | ||
7 | |||
8 | Signed-off-by: Adrian Alonso <aalonso00@gmail.com> | ||
9 | --- | ||
10 | usr/include/HAL/gc_hal_eglplatform.h | 3 --- | ||
11 | 1 file changed, 3 deletions(-) | ||
12 | |||
13 | diff --git a/usr/include/HAL/gc_hal_eglplatform.h b/usr/include/HAL/gc_hal_eglplatform.h | ||
14 | index a968fe7..e80c65a 100644 | ||
15 | --- a/usr/include/HAL/gc_hal_eglplatform.h | ||
16 | +++ b/usr/include/HAL/gc_hal_eglplatform.h | ||
17 | @@ -341,14 +341,11 @@ typedef Pixmap HALNativePixmapType; | ||
18 | /* Rename some badly named X defines. */ | ||
19 | #ifdef Status | ||
20 | # define XStatus int | ||
21 | -# undef Status | ||
22 | #endif | ||
23 | #ifdef Always | ||
24 | # define XAlways 2 | ||
25 | -# undef Always | ||
26 | #endif | ||
27 | #ifdef CurrentTime | ||
28 | -# undef CurrentTime | ||
29 | # define XCurrentTime 0 | ||
30 | #endif | ||
31 | |||
32 | -- | ||
33 | 1.8.1 | ||
34 | |||
diff --git a/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/gc_wayland_protocol.pc b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/gc_wayland_protocol.pc new file mode 100644 index 0000000..f4610ea --- /dev/null +++ b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/gc_wayland_protocol.pc | |||
@@ -0,0 +1,10 @@ | |||
1 | prefix=/usr | ||
2 | exec_prefix=${prefix} | ||
3 | libdir=${exec_prefix}/lib | ||
4 | includedir=${prefix}/include | ||
5 | |||
6 | Name: gc_wayland_protocol | ||
7 | Description: Vivante Wayland Protocol Extension Library | ||
8 | Version: 0.1 | ||
9 | Cflags: -I${includedir} | ||
10 | Libs: -L${libdir} -lgc_wayland_protocol | ||
diff --git a/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/glesv1_cm.pc b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/glesv1_cm.pc new file mode 100644 index 0000000..d97b067 --- /dev/null +++ b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/glesv1_cm.pc | |||
@@ -0,0 +1,12 @@ | |||
1 | prefix=/usr | ||
2 | exec_prefix=${prefix} | ||
3 | libdir=/usr/lib | ||
4 | includedir=/usr/include | ||
5 | |||
6 | Name: glesv1_cm | ||
7 | Description: Vivante OpenGL ES 1.1 CM library | ||
8 | Requires.private: | ||
9 | Version: 8.0 | ||
10 | Libs: -L${libdir} -lGLESv1_CM -lEGL -lGAL | ||
11 | Libs.private: -lm -lpthread -ldl | ||
12 | Cflags: -I${includedir} | ||
diff --git a/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/glesv1_cm_x11.pc b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/glesv1_cm_x11.pc new file mode 100644 index 0000000..e801633 --- /dev/null +++ b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/glesv1_cm_x11.pc | |||
@@ -0,0 +1,12 @@ | |||
1 | prefix=/usr | ||
2 | exec_prefix=${prefix} | ||
3 | libdir=/usr/lib | ||
4 | includedir=/usr/include | ||
5 | |||
6 | Name: glesv1_cm | ||
7 | Description: Vivante OpenGL ES 1.1 CM library | ||
8 | Requires.private: libdrm x11 xext xdamage xfixes xcb | ||
9 | Version: 8.0 | ||
10 | Libs: -L${libdir} -lGLESv1_CM -lEGL -lGAL | ||
11 | Libs.private: -lm -lpthread -ldl | ||
12 | Cflags: -I${includedir} | ||
diff --git a/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/glesv2.pc b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/glesv2.pc new file mode 100644 index 0000000..9be46f2 --- /dev/null +++ b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/glesv2.pc | |||
@@ -0,0 +1,12 @@ | |||
1 | prefix=/usr | ||
2 | exec_prefix=${prefix} | ||
3 | libdir=/usr/lib | ||
4 | includedir=/usr/include | ||
5 | |||
6 | Name: glesv2 | ||
7 | Description: Vivante OpenGL ES 2.0 library | ||
8 | Requires.private: | ||
9 | Version: 8.0 | ||
10 | Libs: -L${libdir} -lGLESv2 -lEGL -lGAL | ||
11 | Libs.private: -lpthread -lrt | ||
12 | Cflags: -I${includedir} | ||
diff --git a/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/glesv2_x11.pc b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/glesv2_x11.pc new file mode 100644 index 0000000..57ad807 --- /dev/null +++ b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/glesv2_x11.pc | |||
@@ -0,0 +1,12 @@ | |||
1 | prefix=/usr | ||
2 | exec_prefix=${prefix} | ||
3 | libdir=/usr/lib | ||
4 | includedir=/usr/include | ||
5 | |||
6 | Name: glesv2 | ||
7 | Description: Vivante OpenGL ES 2.0 library | ||
8 | Requires.private: libdrm x11 xext xdamage xfixes xcb | ||
9 | Version: 8.0 | ||
10 | Libs: -L${libdir} -lGLESv2 -lEGL -lGAL | ||
11 | Libs.private: -lpthread -lrt | ||
12 | Cflags: -I${includedir} | ||
diff --git a/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/vg.pc b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/vg.pc new file mode 100644 index 0000000..7c00def --- /dev/null +++ b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/vg.pc | |||
@@ -0,0 +1,12 @@ | |||
1 | prefix=/usr | ||
2 | exec_prefix=${prefix} | ||
3 | libdir=/usr/lib | ||
4 | includedir=/usr/include | ||
5 | |||
6 | Name: vg | ||
7 | Description: Vivante OpenVG 1.1 library | ||
8 | Requires.private: | ||
9 | Version: 8.0 | ||
10 | Libs: -L${libdir} -lOpenVG -lEGL -lGAL | ||
11 | Libs.private: -lpthread -lrt | ||
12 | Cflags: -I${includedir} | ||
diff --git a/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/vg_x11.pc b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/vg_x11.pc new file mode 100644 index 0000000..94fb91e --- /dev/null +++ b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/vg_x11.pc | |||
@@ -0,0 +1,12 @@ | |||
1 | prefix=/usr | ||
2 | exec_prefix=${prefix} | ||
3 | libdir=/usr/lib | ||
4 | includedir=/usr/include | ||
5 | |||
6 | Name: vg | ||
7 | Description: Vivante OpenVG 1.1 library | ||
8 | Requires.private: libdrm x11 xext xdamage xfixes xcb | ||
9 | Version: 8.0 | ||
10 | Libs: -L${libdir} -lOpenVG -lEGL -lGAL | ||
11 | Libs.private: -lpthread -lrt | ||
12 | Cflags: -I${includedir} | ||
diff --git a/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/wayland-egl.pc b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/wayland-egl.pc new file mode 100644 index 0000000..ba1b898 --- /dev/null +++ b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/wayland-egl.pc | |||
@@ -0,0 +1,10 @@ | |||
1 | prefix=/usr | ||
2 | exec_prefix=${prefix} | ||
3 | libdir=${exec_prefix}/lib | ||
4 | includedir=${prefix}/include | ||
5 | |||
6 | Name: wayland-egl | ||
7 | Description: Bind the driver EGL to the Wayland API | ||
8 | Version: 1.0.0 | ||
9 | Libs: -L${libdir} -lEGL | ||
10 | Cflags: -I${includedir} | ||
diff --git a/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/wayland-viv.pc b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/wayland-viv.pc new file mode 100644 index 0000000..3fdedd0 --- /dev/null +++ b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/wayland-viv.pc | |||
@@ -0,0 +1,10 @@ | |||
1 | prefix=/usr | ||
2 | exec_prefix=${prefix} | ||
3 | libdir=${exec_prefix}/lib | ||
4 | includedir=${prefix}/include | ||
5 | |||
6 | Name: Wayland Vivante Lib | ||
7 | Description: Wayland server side library for Vivante's EGL driver | ||
8 | Version: 0.1 | ||
9 | Cflags: -I${includedir}/wayland-viv | ||
10 | Libs: -L${libdir} -lwayland-viv | ||
diff --git a/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.10.9-1.0.0-hfp.bb b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.10.9-1.0.0-hfp.bb new file mode 100644 index 0000000..5c7727b --- /dev/null +++ b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.10.9-1.0.0-hfp.bb | |||
@@ -0,0 +1,11 @@ | |||
1 | # Copyright (C) 2013 Freescale Semiconductor | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | require gpu-viv-bin-mx6q.inc | ||
5 | |||
6 | SRC_URI[md5sum] = "52f5ebbb6a9b5d0eafdb952246de584e" | ||
7 | SRC_URI[sha256sum] = "8b0386e13d4a7c770f8bc8e7a6119629c5ed379488dd5ef635bc92353f906003" | ||
8 | |||
9 | PACKAGE_FP_TYPE = "hardfp" | ||
10 | |||
11 | RDEPENDS_libgl-mx6-dev = "" | ||