diff options
-rw-r--r-- | conf/distro/include/emulator.conf | 5 | ||||
-rw-r--r-- | recipes/qtglesstream/qtglesstream-dummy-client.bb | 57 |
2 files changed, 58 insertions, 4 deletions
diff --git a/conf/distro/include/emulator.conf b/conf/distro/include/emulator.conf index dee1df3..8684c28 100644 --- a/conf/distro/include/emulator.conf +++ b/conf/distro/include/emulator.conf | |||
@@ -32,12 +32,9 @@ MACHINE_EXTRA_RRECOMMENDS += "\ | |||
32 | kernel_autoload_snd-intel8x0 = "snd-intel8x0" | 32 | kernel_autoload_snd-intel8x0 = "snd-intel8x0" |
33 | 33 | ||
34 | MACHINE_EXTRA_INSTALL = "\ | 34 | MACHINE_EXTRA_INSTALL = "\ |
35 | libegl-mesa \ | ||
36 | libgles2-mesa \ | ||
37 | mount-vboxsf \ | 35 | mount-vboxsf \ |
38 | " | 36 | " |
39 | 37 | ||
40 | MACHINE_EXTRA_INSTALL_SDK = "\ | 38 | MACHINE_EXTRA_INSTALL_SDK = "\ |
41 | libegl-mesa-dev \ | 39 | qtglesstream-dummy-client-dev \ |
42 | libgles2-mesa-dev \ | ||
43 | " | 40 | " |
diff --git a/recipes/qtglesstream/qtglesstream-dummy-client.bb b/recipes/qtglesstream/qtglesstream-dummy-client.bb new file mode 100644 index 0000000..f474805 --- /dev/null +++ b/recipes/qtglesstream/qtglesstream-dummy-client.bb | |||
@@ -0,0 +1,57 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://qt.digia.com/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | DESCRIPTION = "QtGlesStream dummy client provides headers and a dummy library for EGL/GLES" | ||
24 | SECTION = "devel" | ||
25 | LICENSE = "CLOSED" | ||
26 | |||
27 | SRCREV = "72b9fdd9373a383c8b94afdbeb8cfbbfcde95e6e" | ||
28 | PV = "5.4.0+git${SRCREV}" | ||
29 | |||
30 | PROVIDES = "virtual/libgles2 virtual/libgles3 virtual/egl" | ||
31 | |||
32 | SRC_URI = "git://qt-gerrit.it.local/QtRD-15810/qtglesstream.git;protocol=ssh;branch=dev" | ||
33 | |||
34 | S = "${WORKDIR}/git" | ||
35 | |||
36 | ALLOW_EMPTY_${PN} = "1" | ||
37 | |||
38 | do_compile() { | ||
39 | ${CC} -DQGS_BUILD_CLIENT_DLL -fPIC -shared -Iheaders -o libQtGlesStreamClient.so src/client-dummy/*.cpp | ||
40 | } | ||
41 | |||
42 | do_install() { | ||
43 | install -m 0755 -d ${D}${includedir}/EGL | ||
44 | install -m 0755 ${WORKDIR}/git/headers/EGL/* ${D}${includedir}/EGL | ||
45 | |||
46 | install -m 0755 -d ${D}${includedir}/GLES2 | ||
47 | install -m 0755 ${WORKDIR}/git/headers/GLES2/* ${D}${includedir}/GLES2 | ||
48 | |||
49 | install -m 0755 -d ${D}${includedir}/GLES3 | ||
50 | install -m 0755 ${WORKDIR}/git/headers/GLES3/* ${D}${includedir}/GLES3 | ||
51 | |||
52 | install -m 0755 -d ${D}${includedir}/KHR | ||
53 | install -m 0755 ${WORKDIR}/git/headers/KHR/* ${D}${includedir}/KHR | ||
54 | |||
55 | install -m 0755 -d ${D}${libdir} | ||
56 | install -m 0755 ${WORKDIR}/git/libQtGlesStreamClient.so ${D}${libdir} | ||
57 | } | ||