diff options
-rw-r--r-- | conf/distro/include/emulator.conf | 2 | ||||
-rw-r--r-- | recipes-qt/b2qt-addons/b2qt-emulator-proxy.bb | 49 | ||||
-rwxr-xr-x | recipes-qt/b2qt-addons/b2qt-emulator-proxy/emulatorproxyd.sh | 42 | ||||
-rw-r--r-- | recipes-qt/b2qt-addons/b2qt-emulator-vinput.bb | 40 | ||||
-rw-r--r-- | recipes-qt/qt5-addons/qtsimulator_1.0.bb | 39 | ||||
-rw-r--r-- | recipes-qt/qt5/qtlocation_%.bbappend | 3 | ||||
-rw-r--r-- | recipes-qt/qt5/qtsensors_%.bbappend | 24 | ||||
-rw-r--r-- | recipes-qt/qt5/qtsystems_%.bbappend | 24 |
8 files changed, 223 insertions, 0 deletions
diff --git a/conf/distro/include/emulator.conf b/conf/distro/include/emulator.conf index d7afc52..79ebd07 100644 --- a/conf/distro/include/emulator.conf +++ b/conf/distro/include/emulator.conf | |||
@@ -44,6 +44,8 @@ MACHINE_EXTRA_INSTALL_SDK = "\ | |||
44 | " | 44 | " |
45 | MACHINE_EXTRA_INSTALL_QT = "\ | 45 | MACHINE_EXTRA_INSTALL_QT = "\ |
46 | qtglesstream \ | 46 | qtglesstream \ |
47 | b2qt-emulator-proxy \ | ||
48 | b2qt-emulator-vinput \ | ||
47 | " | 49 | " |
48 | MACHINE_EXTRA_INSTALL_QT_SDK = "\ | 50 | MACHINE_EXTRA_INSTALL_QT_SDK = "\ |
49 | qtglesstream-dev \ | 51 | qtglesstream-dev \ |
diff --git a/recipes-qt/b2qt-addons/b2qt-emulator-proxy.bb b/recipes-qt/b2qt-addons/b2qt-emulator-proxy.bb new file mode 100644 index 0000000..da6d7bd --- /dev/null +++ b/recipes-qt/b2qt-addons/b2qt-emulator-proxy.bb | |||
@@ -0,0 +1,49 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | DESCRIPTION = "Proxy daemon for QtSimulator" | ||
24 | LICENSE = "QtEnterprise" | ||
25 | LIC_FILES_CHKSUM = "file://proxy.h;md5=ba04e32af7257890758a149b0c14d11a;beginline=1;endline=17" | ||
26 | |||
27 | inherit qt5-module | ||
28 | |||
29 | SRC_URI = " \ | ||
30 | git://qt-gerrit.ci.local/QtRD-15810/b2qt-emulator.git;branch=${BRANCH};protocol=ssh \ | ||
31 | file://emulatorproxyd.sh \ | ||
32 | " | ||
33 | |||
34 | SRCREV = "1d001910d45349ae2a44fa01516baaa7ff4c9eda" | ||
35 | BRANCH = "master" | ||
36 | |||
37 | S = "${WORKDIR}/git/src/helperlibs/proxy" | ||
38 | |||
39 | DEPENDS = "qtbase qtsimulator" | ||
40 | |||
41 | do_install_append() { | ||
42 | install -m 0755 -d ${D}${sysconfdir}/init.d | ||
43 | install -m 0755 ${WORKDIR}/emulatorproxyd.sh ${D}${sysconfdir}/init.d/ | ||
44 | } | ||
45 | |||
46 | INITSCRIPT_NAME = "emulatorproxyd.sh" | ||
47 | INITSCRIPT_PARAMS = "defaults 97 10" | ||
48 | |||
49 | inherit update-rc.d | ||
diff --git a/recipes-qt/b2qt-addons/b2qt-emulator-proxy/emulatorproxyd.sh b/recipes-qt/b2qt-addons/b2qt-emulator-proxy/emulatorproxyd.sh new file mode 100755 index 0000000..48177fa --- /dev/null +++ b/recipes-qt/b2qt-addons/b2qt-emulator-proxy/emulatorproxyd.sh | |||
@@ -0,0 +1,42 @@ | |||
1 | #!/bin/sh | ||
2 | ############################################################################# | ||
3 | ## | ||
4 | ## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies). | ||
5 | ## | ||
6 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
7 | ## framework. | ||
8 | ## | ||
9 | ## $QT_BEGIN_LICENSE$ | ||
10 | ## Commercial License Usage Only | ||
11 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
12 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
13 | ## may use this file in accordance with the terms contained in said license | ||
14 | ## agreement. | ||
15 | ## | ||
16 | ## For further information use the contact form at | ||
17 | ## http://www.qt.io/contact-us. | ||
18 | ## | ||
19 | ## | ||
20 | ## $QT_END_LICENSE$ | ||
21 | ## | ||
22 | ############################################################################# | ||
23 | |||
24 | DAEMON=/usr/bin/emulatorproxyd | ||
25 | |||
26 | case "$1" in | ||
27 | start) | ||
28 | start-stop-daemon --start --quiet --exec $DAEMON & | ||
29 | ;; | ||
30 | stop) | ||
31 | start-stop-daemon --stop --quiet --exec $DAEMON | ||
32 | ;; | ||
33 | restart) | ||
34 | start-stop-daemon --stop --quiet --exec $DAEMON | ||
35 | sleep 1 | ||
36 | start-stop-daemon --start --quiet --exec $DAEMON & | ||
37 | ;; | ||
38 | *) | ||
39 | echo "Usage: $0 {start|stop|restart}" | ||
40 | exit 1 | ||
41 | esac | ||
42 | exit 0 | ||
diff --git a/recipes-qt/b2qt-addons/b2qt-emulator-vinput.bb b/recipes-qt/b2qt-addons/b2qt-emulator-vinput.bb new file mode 100644 index 0000000..b344395 --- /dev/null +++ b/recipes-qt/b2qt-addons/b2qt-emulator-vinput.bb | |||
@@ -0,0 +1,40 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | DESCRIPTION = "Virtual input plugin for QtSimulator" | ||
24 | LICENSE = "QtEnterprise" | ||
25 | LIC_FILES_CHKSUM = "file://qvinput.h;md5=ba04e32af7257890758a149b0c14d11a;beginline=1;endline=17" | ||
26 | |||
27 | inherit qt5-module | ||
28 | |||
29 | SRC_URI = " \ | ||
30 | git://qt-gerrit.ci.local/QtRD-15810/b2qt-emulator.git;branch=${BRANCH};protocol=ssh \ | ||
31 | " | ||
32 | |||
33 | SRCREV = "1d001910d45349ae2a44fa01516baaa7ff4c9eda" | ||
34 | BRANCH = "master" | ||
35 | |||
36 | EXTRA_QMAKEVARS_PRE += "CONFIG+=force_independent" | ||
37 | |||
38 | S = "${WORKDIR}/git/src/helperlibs/vinput" | ||
39 | |||
40 | DEPENDS = "qtbase qtsimulator" | ||
diff --git a/recipes-qt/qt5-addons/qtsimulator_1.0.bb b/recipes-qt/qt5-addons/qtsimulator_1.0.bb new file mode 100644 index 0000000..5f0c761 --- /dev/null +++ b/recipes-qt/qt5-addons/qtsimulator_1.0.bb | |||
@@ -0,0 +1,39 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | DESCRIPTION = "QtSimulator" | ||
24 | LICENSE = "QtEnterprise" | ||
25 | LIC_FILES_CHKSUM = "file://src/simulator/version.h;md5=ba04e32af7257890758a149b0c14d11a;beginline=1;endline=17" | ||
26 | |||
27 | inherit qt5-module | ||
28 | |||
29 | SRC_URI = " \ | ||
30 | git://qt-gerrit.ci.local/QtRD-15810/b2qt-qtsimulator.git;branch=${BRANCH};protocol=ssh \ | ||
31 | " | ||
32 | |||
33 | # v1.0.8 | ||
34 | SRCREV = "faf8ea5cee8a4105b97c3f2ba4a4c828f03a70ab" | ||
35 | BRANCH = "master" | ||
36 | |||
37 | S = "${WORKDIR}/git" | ||
38 | |||
39 | DEPENDS = "qtbase" | ||
diff --git a/recipes-qt/qt5/qtlocation_%.bbappend b/recipes-qt/qt5/qtlocation_%.bbappend index c068600..facd006 100644 --- a/recipes-qt/qt5/qtlocation_%.bbappend +++ b/recipes-qt/qt5/qtlocation_%.bbappend | |||
@@ -21,3 +21,6 @@ | |||
21 | ############################################################################# | 21 | ############################################################################# |
22 | 22 | ||
23 | PACKAGECONFIG += "gypsy" | 23 | PACKAGECONFIG += "gypsy" |
24 | |||
25 | EXTRA_QMAKEVARS_PRE_emulator += "CONFIG+=simulator" | ||
26 | DEPENDS_emulator += "qtsimulator" | ||
diff --git a/recipes-qt/qt5/qtsensors_%.bbappend b/recipes-qt/qt5/qtsensors_%.bbappend new file mode 100644 index 0000000..a388c6f --- /dev/null +++ b/recipes-qt/qt5/qtsensors_%.bbappend | |||
@@ -0,0 +1,24 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | EXTRA_QMAKEVARS_PRE_emulator += "SENSORS_PLUGINS=simulator" | ||
24 | DEPENDS_emulator += "qtsimulator" | ||
diff --git a/recipes-qt/qt5/qtsystems_%.bbappend b/recipes-qt/qt5/qtsystems_%.bbappend new file mode 100644 index 0000000..af270e5 --- /dev/null +++ b/recipes-qt/qt5/qtsystems_%.bbappend | |||
@@ -0,0 +1,24 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | EXTRA_QMAKEVARS_PRE_emulator += "CONFIG+=simulator" | ||
24 | DEPENDS_emulator += "qtsimulator" | ||