diff options
-rw-r--r-- | recipes/e2fsprogs/e2fsprogs_%.bbappend | 1 | ||||
-rw-r--r-- | recipes/glib-networking/glib-networking_%.bbappend | 1 | ||||
-rw-r--r-- | recipes/gpgme/gpgme_%.bbappend | 1 | ||||
-rw-r--r-- | recipes/libassuan/libassuan_%.bbappend | 1 | ||||
-rw-r--r-- | recipes/libgpg-error/libgpg-error_%.bbappend | 1 | ||||
-rw-r--r-- | recipes/libgsystem/libgsystem.bb | 2 | ||||
-rw-r--r-- | recipes/libsoup/libsoup-%.bbappend | 2 | ||||
-rw-r--r-- | recipes/ostree/ostree.bb | 2 | ||||
-rw-r--r-- | recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb | 1 |
9 files changed, 12 insertions, 0 deletions
diff --git a/recipes/e2fsprogs/e2fsprogs_%.bbappend b/recipes/e2fsprogs/e2fsprogs_%.bbappend new file mode 100644 index 0000000..608377e --- /dev/null +++ b/recipes/e2fsprogs/e2fsprogs_%.bbappend | |||
@@ -0,0 +1 @@ | |||
BBCLASSEXTEND = "native nativesdk" | |||
diff --git a/recipes/glib-networking/glib-networking_%.bbappend b/recipes/glib-networking/glib-networking_%.bbappend new file mode 100644 index 0000000..608377e --- /dev/null +++ b/recipes/glib-networking/glib-networking_%.bbappend | |||
@@ -0,0 +1 @@ | |||
BBCLASSEXTEND = "native nativesdk" | |||
diff --git a/recipes/gpgme/gpgme_%.bbappend b/recipes/gpgme/gpgme_%.bbappend new file mode 100644 index 0000000..608377e --- /dev/null +++ b/recipes/gpgme/gpgme_%.bbappend | |||
@@ -0,0 +1 @@ | |||
BBCLASSEXTEND = "native nativesdk" | |||
diff --git a/recipes/libassuan/libassuan_%.bbappend b/recipes/libassuan/libassuan_%.bbappend new file mode 100644 index 0000000..608377e --- /dev/null +++ b/recipes/libassuan/libassuan_%.bbappend | |||
@@ -0,0 +1 @@ | |||
BBCLASSEXTEND = "native nativesdk" | |||
diff --git a/recipes/libgpg-error/libgpg-error_%.bbappend b/recipes/libgpg-error/libgpg-error_%.bbappend new file mode 100644 index 0000000..2a59083 --- /dev/null +++ b/recipes/libgpg-error/libgpg-error_%.bbappend | |||
@@ -0,0 +1 @@ | |||
BBCLASSEXTEND += "nativesdk" | |||
diff --git a/recipes/libgsystem/libgsystem.bb b/recipes/libgsystem/libgsystem.bb index d2d1a0b..f006a39 100644 --- a/recipes/libgsystem/libgsystem.bb +++ b/recipes/libgsystem/libgsystem.bb | |||
@@ -39,3 +39,5 @@ do_configure_prepend() { | |||
39 | # We get a syntax error since we do not bundle gnome recipes that define this macro. | 39 | # We get a syntax error since we do not bundle gnome recipes that define this macro. |
40 | sed -i '/GTK_DOC_CHECK/d' ${S}/configure.ac | 40 | sed -i '/GTK_DOC_CHECK/d' ${S}/configure.ac |
41 | } | 41 | } |
42 | |||
43 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/recipes/libsoup/libsoup-%.bbappend b/recipes/libsoup/libsoup-%.bbappend new file mode 100644 index 0000000..4a95767 --- /dev/null +++ b/recipes/libsoup/libsoup-%.bbappend | |||
@@ -0,0 +1,2 @@ | |||
1 | DEPENDS += "glib-networking" | ||
2 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/recipes/ostree/ostree.bb b/recipes/ostree/ostree.bb index 1ba1504..4700f08 100644 --- a/recipes/ostree/ostree.bb +++ b/recipes/ostree/ostree.bb | |||
@@ -47,3 +47,5 @@ do_install_append() { | |||
47 | # this of course is a broken configure.ac logic. | 47 | # this of course is a broken configure.ac logic. |
48 | rm -rf ${D}${libdir}/dracut/ | 48 | rm -rf ${D}${libdir}/dracut/ |
49 | } | 49 | } |
50 | |||
51 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb index f64c0ac..7591b6b 100644 --- a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb +++ b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb | |||
@@ -30,6 +30,7 @@ RDEPENDS_${PN} = "\ | |||
30 | nativesdk-python-modules \ | 30 | nativesdk-python-modules \ |
31 | nativesdk-python-misc \ | 31 | nativesdk-python-misc \ |
32 | nativesdk-gperf \ | 32 | nativesdk-gperf \ |
33 | nativesdk-ostree \ | ||
33 | ${@base_contains("DISTRO_FEATURES", "wayland", "nativesdk-wayland", "", d)} \ | 34 | ${@base_contains("DISTRO_FEATURES", "wayland", "nativesdk-wayland", "", d)} \ |
34 | ${MACHINE_EXTRA_INSTALL_SDK_HOST} \ | 35 | ${MACHINE_EXTRA_INSTALL_SDK_HOST} \ |
35 | " | 36 | " |