summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/systemd/systemd/0020-Revert-core-mount-add-dependencies-to-dynamically-mo.patch27
-rw-r--r--recipes/systemd/systemd_%.bbappend11
2 files changed, 38 insertions, 0 deletions
diff --git a/recipes/systemd/systemd/0020-Revert-core-mount-add-dependencies-to-dynamically-mo.patch b/recipes/systemd/systemd/0020-Revert-core-mount-add-dependencies-to-dynamically-mo.patch
new file mode 100644
index 0000000..ed58b50
--- /dev/null
+++ b/recipes/systemd/systemd/0020-Revert-core-mount-add-dependencies-to-dynamically-mo.patch
@@ -0,0 +1,27 @@
1From 6a7105e23d8be76094b90d814eab9135e2cc4b8a Mon Sep 17 00:00:00 2001
2From: Gatis Paeglis <gatis.paeglis@qt.io>
3Date: Tue, 21 Jun 2016 15:26:47 +0200
4Subject: [PATCH] Revert "core/mount: add dependencies to dynamically mounted
5 mounts too"
6
7This reverts commit 06e97888883e2cc12eb6514e80c7f0014295f59b.
8---
9 src/core/mount.c | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12diff --git a/src/core/mount.c b/src/core/mount.c
13index fda4d65..3944232 100644
14--- a/src/core/mount.c
15+++ b/src/core/mount.c
16@@ -337,7 +337,7 @@ static int mount_add_device_links(Mount *m) {
17
18 assert(m);
19
20- p = get_mount_parameters(m);
21+ p = get_mount_parameters_fragment(m);
22 if (!p)
23 return 0;
24
25--
262.7.4
27
diff --git a/recipes/systemd/systemd_%.bbappend b/recipes/systemd/systemd_%.bbappend
index 5594a3d..0877135 100644
--- a/recipes/systemd/systemd_%.bbappend
+++ b/recipes/systemd/systemd_%.bbappend
@@ -27,7 +27,18 @@
27## 27##
28############################################################################ 28############################################################################
29 29
30FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
31SRC_URI += "file://0020-Revert-core-mount-add-dependencies-to-dynamically-mo.patch"
32
30do_install_append() { 33do_install_append() {
31 # remove login from tty1 34 # remove login from tty1
32 rm -f ${D}${sysconfdir}/systemd/system/getty.target.wants/getty@tty1.service 35 rm -f ${D}${sysconfdir}/systemd/system/getty.target.wants/getty@tty1.service
33} 36}
37
38do_verify_patch_required() {
39 if [ -n "$(cat ${S}/NEWS | grep "CHANGES WITH 229")" ]; then
40 bbwarn "systemd: The 0020-Revert-core-mount-add-dependencies-to-dynamically-mo.patch patch is not required anymore."
41 fi
42}
43
44addtask do_verify_patch_required after do_fetch before do_configure