diff options
-rwxr-xr-x | b2qt-init-build-env | 2 | ||||
-rw-r--r-- | conf/distro/include/colibri-imx7.conf | 37 | ||||
-rw-r--r-- | conf/distro/include/toradex.inc | 2 | ||||
-rw-r--r-- | meta-toradex-extras/recipes/linux/linux-toradex_4.%.bbappend | 6 | ||||
-rw-r--r-- | meta-toradex-extras/recipes/linux/linux-toradex_git.bbappend (renamed from meta-toradex-extras/recipes/linux/linux-toradex-fsl_git.bbappend) | 0 | ||||
-rw-r--r-- | meta-toradex-extras/recipes/u-boot/u-boot-toradex/0001-Update-default-args-for-apalis-imx6.patch (renamed from meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-Update-default-args-for-apalis-imx6.patch) | 0 | ||||
-rw-r--r-- | meta-toradex-extras/recipes/u-boot/u-boot-toradex/0001-colibri-imx6-enable-sdboot-by-default.patch (renamed from meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-colibri-imx6-enable-sdboot-by-default.patch) | 0 | ||||
-rw-r--r-- | meta-toradex-extras/recipes/u-boot/u-boot-toradex_git.bbappend (renamed from meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl_git.bbappend) | 0 | ||||
-rw-r--r-- | scripts/manifest.xml | 2 | ||||
-rwxr-xr-x | scripts/setup-environment.sh | 2 |
10 files changed, 41 insertions, 10 deletions
diff --git a/b2qt-init-build-env b/b2qt-init-build-env index 469042c..87d05f4 100755 --- a/b2qt-init-build-env +++ b/b2qt-init-build-env | |||
@@ -106,7 +106,7 @@ get_groups() { | |||
106 | all) | 106 | all) |
107 | PROJECT_GROUPS="external" | 107 | PROJECT_GROUPS="external" |
108 | ;; | 108 | ;; |
109 | apalis-imx6|colibri-imx6|colibri-vf) | 109 | apalis-imx6|colibri-imx6|colibri-vf|colibri-imx7) |
110 | PROJECT_GROUPS="toradex" | 110 | PROJECT_GROUPS="toradex" |
111 | ;; | 111 | ;; |
112 | imx6qsabresd|imx6dlsabresd|nitrogen6x|imx7dsabresd) | 112 | imx6qsabresd|imx6dlsabresd|nitrogen6x|imx7dsabresd) |
diff --git a/conf/distro/include/colibri-imx7.conf b/conf/distro/include/colibri-imx7.conf new file mode 100644 index 0000000..310a6a0 --- /dev/null +++ b/conf/distro/include/colibri-imx7.conf | |||
@@ -0,0 +1,37 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | include conf/distro/include/toradex.inc | ||
24 | |||
25 | DEPLOY_CONF_NAME = "Toradex Colibri iMX7" | ||
26 | |||
27 | IMAGE_FSTYPES += "ext3 sdcard" | ||
28 | |||
29 | BOOTFS_CONTENT = "\ | ||
30 | ${KERNEL_IMAGETYPE}:${KERNEL_IMAGETYPE} \ | ||
31 | ${KERNEL_IMAGETYPE}-imx7d-colibri-eval-v3.dtb:imx7d-colibri-eval-v3.dtb \ | ||
32 | ${KERNEL_IMAGETYPE}-imx7s-colibri-eval-v3.dtb:imx7s-colibri-eval-v3.dtb \ | ||
33 | u-boot-${MACHINE}.imx:u-boot.imx \ | ||
34 | " | ||
35 | BOOTFS_DEPENDS = "u-boot:do_deploy virtual/kernel:do_deploy" | ||
36 | |||
37 | DISTRO_FEATURES_remove = "webengine" | ||
diff --git a/conf/distro/include/toradex.inc b/conf/distro/include/toradex.inc index 95a2352..9408c73 100644 --- a/conf/distro/include/toradex.inc +++ b/conf/distro/include/toradex.inc | |||
@@ -28,4 +28,4 @@ | |||
28 | ############################################################################ | 28 | ############################################################################ |
29 | 29 | ||
30 | BBMASK ?= " " | 30 | BBMASK ?= " " |
31 | BBMASK .= "|meta-toradex/recipes-mozilla|meta-toradex/recipes-browser|meta-toradex/recipes-lxde|meta-toradex/recipes-connectivity|meta-toradex/recipes-gnome|meta-toradex/recipes/trdx-config|meta-toradex/recipes-multimedia/webm|meta-toradex/recipes-qt|meta-toradex/recipes-core/psplash|meta-toradex/recipes-support/florence|meta-toradex/recipes-core/systemd|meta-toradex/recipes-efl|meta-toradex/recipes-core/dropbear|meta-toradex/recipes-support/icu|meta-toradex/recipes-support/i2c-tools|meta-toradex/recipes-benchmark|meta-toradex/recipes-core/udev|meta-toradex/recipes-support/gnutls|meta-toradex/recipes-graphics/gpu-viv-bin-mx6q|meta-toradex/recipes-multimedia/gstreamer|meta-toradex/recipes-fsl/packagegroups|meta-toradex/recipes-core/glibc|meta-toradex/recipes-sato/webkit" | 31 | BBMASK .= "|meta-toradex/recipes-mozilla|meta-toradex/recipes-browser|meta-toradex/recipes-lxde|meta-toradex/recipes-connectivity|meta-toradex/recipes-gnome|meta-toradex/recipes/trdx-config|meta-toradex/recipes-multimedia/webm|meta-toradex/recipes-qt|meta-toradex/recipes-core/psplash|meta-toradex/recipes-support/florence|meta-toradex/recipes-core/systemd|meta-toradex/recipes-efl|meta-toradex/recipes-core/dropbear|meta-toradex/recipes-support/icu|meta-toradex/recipes-support/i2c-tools|meta-toradex/recipes-benchmark|meta-toradex/recipes-core/udev|meta-toradex/recipes-support/gnutls|meta-toradex/recipes-graphics/gpu-viv-bin-mx6q|meta-toradex/recipes-multimedia/gstreamer|meta-toradex/recipes-fsl/packagegroups|meta-toradex/recipes-core/glibc|meta-toradex/recipes-sato/webkit|meta-toradex/recipes-bsp/binary-drivers/cudatoolkit6.5|meta-toradex/recipes-bsp/binary-drivers/opencv4tegra" |
diff --git a/meta-toradex-extras/recipes/linux/linux-toradex_4.%.bbappend b/meta-toradex-extras/recipes/linux/linux-toradex_4.%.bbappend index c2e2fc6..77ce484 100644 --- a/meta-toradex-extras/recipes/linux/linux-toradex_4.%.bbappend +++ b/meta-toradex-extras/recipes/linux/linux-toradex_4.%.bbappend | |||
@@ -27,12 +27,6 @@ | |||
27 | ## | 27 | ## |
28 | ############################################################################ | 28 | ############################################################################ |
29 | 29 | ||
30 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" | ||
31 | |||
32 | SRC_URI += " \ | ||
33 | file://0001-Enable-Fusion-7-and-10-multi-touch-controller.patch \ | ||
34 | " | ||
35 | |||
36 | do_configure_prepend () { | 30 | do_configure_prepend () { |
37 | # FunctionFS for adb | 31 | # FunctionFS for adb |
38 | echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig | 32 | echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig |
diff --git a/meta-toradex-extras/recipes/linux/linux-toradex-fsl_git.bbappend b/meta-toradex-extras/recipes/linux/linux-toradex_git.bbappend index 5352ed7..5352ed7 100644 --- a/meta-toradex-extras/recipes/linux/linux-toradex-fsl_git.bbappend +++ b/meta-toradex-extras/recipes/linux/linux-toradex_git.bbappend | |||
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-Update-default-args-for-apalis-imx6.patch b/meta-toradex-extras/recipes/u-boot/u-boot-toradex/0001-Update-default-args-for-apalis-imx6.patch index b7c7d63..b7c7d63 100644 --- a/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-Update-default-args-for-apalis-imx6.patch +++ b/meta-toradex-extras/recipes/u-boot/u-boot-toradex/0001-Update-default-args-for-apalis-imx6.patch | |||
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-colibri-imx6-enable-sdboot-by-default.patch b/meta-toradex-extras/recipes/u-boot/u-boot-toradex/0001-colibri-imx6-enable-sdboot-by-default.patch index 0743128..0743128 100644 --- a/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-colibri-imx6-enable-sdboot-by-default.patch +++ b/meta-toradex-extras/recipes/u-boot/u-boot-toradex/0001-colibri-imx6-enable-sdboot-by-default.patch | |||
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl_git.bbappend b/meta-toradex-extras/recipes/u-boot/u-boot-toradex_git.bbappend index 45b5fd3..45b5fd3 100644 --- a/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl_git.bbappend +++ b/meta-toradex-extras/recipes/u-boot/u-boot-toradex_git.bbappend | |||
diff --git a/scripts/manifest.xml b/scripts/manifest.xml index 663d257..9d6effc 100644 --- a/scripts/manifest.xml +++ b/scripts/manifest.xml | |||
@@ -59,7 +59,7 @@ | |||
59 | groups="notdefault,external,bbb"/> | 59 | groups="notdefault,external,bbb"/> |
60 | <project name="meta-toradex" | 60 | <project name="meta-toradex" |
61 | remote="toradex" | 61 | remote="toradex" |
62 | revision="eca5937408c75a997b160bd1b92e1496b07421cf" | 62 | revision="485643678b2d39d37b1cc9d1aa2200bb934b08de" |
63 | path="sources/meta-toradex" | 63 | path="sources/meta-toradex" |
64 | groups="notdefault,external,toradex"/> | 64 | groups="notdefault,external,toradex"/> |
65 | <project name="meta-tibidabo" | 65 | <project name="meta-tibidabo" |
diff --git a/scripts/setup-environment.sh b/scripts/setup-environment.sh index f370032..5ee1ad0 100755 --- a/scripts/setup-environment.sh +++ b/scripts/setup-environment.sh | |||
@@ -56,7 +56,7 @@ BUILDDIRECTORY=${BUILDDIRECTORY:-build-${MACHINE}} | |||
56 | 56 | ||
57 | if [ ! -f ${PWD}/${BUILDDIRECTORY}/conf/bblayers.conf ]; then | 57 | if [ ! -f ${PWD}/${BUILDDIRECTORY}/conf/bblayers.conf ]; then |
58 | case ${MACHINE} in | 58 | case ${MACHINE} in |
59 | apalis-imx6|colibri-imx6|colibri-vf) | 59 | apalis-imx6|colibri-imx6|colibri-vf|colibri-imx7) |
60 | LAYERSCONF="bblayers.conf.toradex.sample" | 60 | LAYERSCONF="bblayers.conf.toradex.sample" |
61 | ;; | 61 | ;; |
62 | imx6qsabresd|imx6dlsabresd|nitrogen6x|imx7dsabresd) | 62 | imx6qsabresd|imx6dlsabresd|nitrogen6x|imx7dsabresd) |