diff options
-rw-r--r-- | classes/populate_b2qt_qt5_sdk.bbclass (renamed from recipes-qt/meta/b2qt-sdk.inc) | 23 | ||||
-rw-r--r-- | recipes-qt/meta/files/qmake.conf | 12 | ||||
-rw-r--r-- | recipes-qt/meta/files/qplatformdefs.h | 2 | ||||
-rw-r--r-- | recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb | 5 | ||||
-rw-r--r-- | recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk.bb | 5 |
5 files changed, 19 insertions, 28 deletions
diff --git a/recipes-qt/meta/b2qt-sdk.inc b/classes/populate_b2qt_qt5_sdk.bbclass index 4a3a00b..78ad457 100644 --- a/recipes-qt/meta/b2qt-sdk.inc +++ b/classes/populate_b2qt_qt5_sdk.bbclass | |||
@@ -20,27 +20,26 @@ | |||
20 | ## | 20 | ## |
21 | ############################################################################# | 21 | ############################################################################# |
22 | 22 | ||
23 | LICENSE = "QtEnterprise" | ||
24 | LIC_FILES_CHKSUM = "file://${QT_LICENCE};md5=7bc9c54e450006250a60e96604c186c9" | ||
25 | |||
26 | inherit populate_b2qt_sdk populate_sdk_qt5_base | 23 | inherit populate_b2qt_sdk populate_sdk_qt5_base |
27 | 24 | ||
28 | SRC_URI = " \ | ||
29 | file://qmake.conf \ | ||
30 | file://qplatformdefs.h \ | ||
31 | " | ||
32 | S = "${WORKDIR}" | ||
33 | |||
34 | SDK_MKSPEC_DIR = "${SDK_OUTPUT}${SDKTARGETSYSROOT}${libdir}/${QT_DIR_NAME}/mkspecs" | 25 | SDK_MKSPEC_DIR = "${SDK_OUTPUT}${SDKTARGETSYSROOT}${libdir}/${QT_DIR_NAME}/mkspecs" |
35 | SDK_MKSPEC = "devices/linux-oe-generic-g++" | 26 | SDK_MKSPEC = "devices/linux-oe-generic-g++" |
36 | SDK_DEVICE_PRI = "${SDK_MKSPEC_DIR}/qdevice.pri" | 27 | SDK_DEVICE_PRI = "${SDK_MKSPEC_DIR}/qdevice.pri" |
37 | SDK_DYNAMIC_FLAGS = "-O. -pipe -g" | 28 | SDK_DYNAMIC_FLAGS = "-O. -pipe -g" |
38 | 29 | ||
39 | create_sdk_files_append () { | 30 | create_sdk_files_append () { |
40 | # Install the toolchain user's generic device mkspec | 31 | # Create the toolchain user's generic device mkspec |
41 | install -d ${SDK_MKSPEC_DIR}/${SDK_MKSPEC} | 32 | install -d ${SDK_MKSPEC_DIR}/${SDK_MKSPEC} |
42 | install -m 0644 ${WORKDIR}/qmake.conf ${SDK_MKSPEC_DIR}/${SDK_MKSPEC} | 33 | cat > ${SDK_MKSPEC_DIR}/${SDK_MKSPEC}/qmake.conf <<EOF |
43 | install -m 0644 ${WORKDIR}/qplatformdefs.h ${SDK_MKSPEC_DIR}/${SDK_MKSPEC} | 34 | include(../common/linux_device_pre.conf) |
35 | exists(../../oe-device-extra.pri):include(../../oe-device-extra.pri) | ||
36 | include(../common/linux_device_post.conf) | ||
37 | load(qt_config) | ||
38 | EOF | ||
39 | |||
40 | cat > ${SDK_MKSPEC_DIR}/${SDK_MKSPEC}/qplatformdefs.h <<EOF | ||
41 | #include "../../linux-g++/qplatformdefs.h" | ||
42 | EOF | ||
44 | 43 | ||
45 | # Fill in the qdevice.pri file which will be used by the device mksspec | 44 | # Fill in the qdevice.pri file which will be used by the device mksspec |
46 | static_cflags="${TARGET_CFLAGS}" | 45 | static_cflags="${TARGET_CFLAGS}" |
diff --git a/recipes-qt/meta/files/qmake.conf b/recipes-qt/meta/files/qmake.conf deleted file mode 100644 index b5962dc..0000000 --- a/recipes-qt/meta/files/qmake.conf +++ /dev/null | |||
@@ -1,12 +0,0 @@ | |||
1 | # | ||
2 | # qmake configuration for using yocto-built b2qt toolchain | ||
3 | # | ||
4 | |||
5 | include(../common/linux_device_pre.conf) | ||
6 | |||
7 | # Load device-specific qmake.conf part, if any | ||
8 | exists(../../oe-device-extra.pri):include(../../oe-device-extra.pri) | ||
9 | |||
10 | include(../common/linux_device_post.conf) | ||
11 | |||
12 | load(qt_config) | ||
diff --git a/recipes-qt/meta/files/qplatformdefs.h b/recipes-qt/meta/files/qplatformdefs.h deleted file mode 100644 index e10ebcf..0000000 --- a/recipes-qt/meta/files/qplatformdefs.h +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | |||
2 | #include "../../linux-g++/qplatformdefs.h" | ||
diff --git a/recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb b/recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb index 6b95276..124adbe 100644 --- a/recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb +++ b/recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb | |||
@@ -22,7 +22,10 @@ | |||
22 | 22 | ||
23 | DESCRIPTION = "B2Qt embedded Qt5 SDK toolchain" | 23 | DESCRIPTION = "B2Qt embedded Qt5 SDK toolchain" |
24 | 24 | ||
25 | require b2qt-sdk.inc | 25 | LICENSE = "QtEnterprise" |
26 | LIC_FILES_CHKSUM = "file://${QT_LICENCE};md5=7bc9c54e450006250a60e96604c186c9" | ||
27 | |||
28 | inherit populate_b2qt_qt5_sdk | ||
26 | 29 | ||
27 | TOOLCHAIN_HOST_TASK += "nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host" | 30 | TOOLCHAIN_HOST_TASK += "nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host" |
28 | TOOLCHAIN_TARGET_TASK += "packagegroup-b2qt-embedded-qt5-toolchain-target \ | 31 | TOOLCHAIN_TARGET_TASK += "packagegroup-b2qt-embedded-qt5-toolchain-target \ |
diff --git a/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk.bb b/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk.bb index 43f29b3..eb114cd 100644 --- a/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk.bb +++ b/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk.bb | |||
@@ -22,7 +22,10 @@ | |||
22 | 22 | ||
23 | DESCRIPTION = "B2Qt embedded Qt5 SDK toolchain" | 23 | DESCRIPTION = "B2Qt embedded Qt5 SDK toolchain" |
24 | 24 | ||
25 | require b2qt-sdk.inc | 25 | LICENSE = "QtEnterprise" |
26 | LIC_FILES_CHKSUM = "file://${QT_LICENCE};md5=7bc9c54e450006250a60e96604c186c9" | ||
27 | |||
28 | inherit populate_b2qt_qt5_sdk | ||
26 | 29 | ||
27 | TOOLCHAIN_HOST_TASK += "nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host" | 30 | TOOLCHAIN_HOST_TASK += "nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host" |
28 | TOOLCHAIN_TARGET_TASK += "packagegroup-b2qt-embedded-qt5-toolchain-target" | 31 | TOOLCHAIN_TARGET_TASK += "packagegroup-b2qt-embedded-qt5-toolchain-target" |