diff options
-rw-r--r-- | recipes/gnutls/files/check_SYS_getrandom.patch | 36 | ||||
-rw-r--r-- | recipes/gnutls/gnutls_3.%.bbappend | 32 | ||||
-rw-r--r-- | scripts/manifest.xml | 4 |
3 files changed, 2 insertions, 70 deletions
diff --git a/recipes/gnutls/files/check_SYS_getrandom.patch b/recipes/gnutls/files/check_SYS_getrandom.patch deleted file mode 100644 index 50693bf..0000000 --- a/recipes/gnutls/files/check_SYS_getrandom.patch +++ /dev/null | |||
@@ -1,36 +0,0 @@ | |||
1 | From f26c3979ab0325edb2e410d287bc501cf00e0ac0 Mon Sep 17 00:00:00 2001 | ||
2 | From: Nikos Mavrogiannopoulos <nmav@redhat.com> | ||
3 | Date: Mon, 22 Aug 2016 16:32:34 +0200 | ||
4 | Subject: [PATCH] rnd-linux: added check for SYS_getrandom being defined | ||
5 | |||
6 | This allows to compile the getrandom() code in old Linux systems | ||
7 | which do not have the system call defined. | ||
8 | --- | ||
9 | |||
10 | Upstream-Status: Backport | ||
11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
12 | |||
13 | lib/nettle/rnd-linux.c | 6 +++++- | ||
14 | 1 file changed, 5 insertions(+), 1 deletion(-) | ||
15 | |||
16 | diff --git a/lib/nettle/rnd-linux.c b/lib/nettle/rnd-linux.c | ||
17 | index d7f07a6..7a24d05 100644 | ||
18 | --- a/lib/nettle/rnd-linux.c | ||
19 | +++ b/lib/nettle/rnd-linux.c | ||
20 | @@ -56,7 +56,11 @@ static dev_t _gnutls_urandom_fd_rdev = 0; | ||
21 | # else | ||
22 | # include <sys/syscall.h> | ||
23 | # undef getrandom | ||
24 | -# define getrandom(dst,s,flags) syscall(SYS_getrandom, (void*)dst, (size_t)s, (unsigned int)flags) | ||
25 | +# if defined(SYS_getrandom) | ||
26 | +# define getrandom(dst,s,flags) syscall(SYS_getrandom, (void*)dst, (size_t)s, (unsigned int)flags) | ||
27 | +# else | ||
28 | +# define getrandom(dst,s,flags) -1 | ||
29 | +# endif | ||
30 | # endif | ||
31 | |||
32 | static unsigned have_getrandom(void) | ||
33 | -- | ||
34 | libgit2 0.24.0 | ||
35 | |||
36 | |||
diff --git a/recipes/gnutls/gnutls_3.%.bbappend b/recipes/gnutls/gnutls_3.%.bbappend deleted file mode 100644 index 8d91bb0..0000000 --- a/recipes/gnutls/gnutls_3.%.bbappend +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2017 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | FILESEXTRAPATHS_prepend := "${THISDIR}/files:" | ||
31 | |||
32 | SRC_URI += "file://check_SYS_getrandom.patch" | ||
diff --git a/scripts/manifest.xml b/scripts/manifest.xml index fb900be..27bc0f6 100644 --- a/scripts/manifest.xml +++ b/scripts/manifest.xml | |||
@@ -16,7 +16,7 @@ | |||
16 | 16 | ||
17 | <project name="poky" | 17 | <project name="poky" |
18 | remote="yocto" | 18 | remote="yocto" |
19 | revision="4f6027c30ae2b07a238e7fec63f69169e6a70cf9" | 19 | revision="0e730770a9529f2a0b3219efcc1de7e8842105e8" |
20 | path="sources/poky"/> | 20 | path="sources/poky"/> |
21 | <project name="meta-openembedded" | 21 | <project name="meta-openembedded" |
22 | remote="oe-mirror" | 22 | remote="oe-mirror" |
@@ -29,7 +29,7 @@ | |||
29 | <project name="meta-mingw" | 29 | <project name="meta-mingw" |
30 | remote="qtyocto" | 30 | remote="qtyocto" |
31 | path="sources/meta-mingw" | 31 | path="sources/meta-mingw" |
32 | revision="4a621def8529c3a55c6fcaef72e3b1832a9327b3"/> | 32 | revision="1c2e155111dce94423cc227ea69f7f50f316c78e"/> |
33 | 33 | ||
34 | <project name="meta-freescale" | 34 | <project name="meta-freescale" |
35 | remote="freescale" | 35 | remote="freescale" |