diff options
-rw-r--r-- | meta-boot2qt-distro/recipes-devtools/gcc/gcc-cross-canadian_%.bbappend (renamed from meta-fsl-extras/recipes/qt5/qtbase_git.bbappend) | 10 | ||||
-rw-r--r-- | meta-boot2qt/recipes-qt/automotive/gammaray_git.bb | 2 | ||||
-rw-r--r-- | meta-fsl-extras/recipes/qt5/qtbase/0001-egl_viv-cast-EGLNative-types-from-vivante-functions.patch | 57 | ||||
-rw-r--r-- | meta-intel-extras/recipes/images/core-image-minimal-initramfs.bbappend | 10 | ||||
-rw-r--r-- | meta-intel-extras/recipes/initrdscripts/initramfs-framework/network | 47 | ||||
-rwxr-xr-x | meta-intel-extras/recipes/initrdscripts/initramfs-framework/rootfs | 79 | ||||
-rw-r--r-- | meta-intel-extras/recipes/initrdscripts/initramfs-framework_1.0.bbappend | 17 |
7 files changed, 154 insertions, 68 deletions
diff --git a/meta-fsl-extras/recipes/qt5/qtbase_git.bbappend b/meta-boot2qt-distro/recipes-devtools/gcc/gcc-cross-canadian_%.bbappend index 373e614..66e79ec 100644 --- a/meta-fsl-extras/recipes/qt5/qtbase_git.bbappend +++ b/meta-boot2qt-distro/recipes-devtools/gcc/gcc-cross-canadian_%.bbappend | |||
@@ -1,6 +1,6 @@ | |||
1 | ############################################################################ | 1 | ############################################################################ |
2 | ## | 2 | ## |
3 | ## Copyright (C) 2018 The Qt Company Ltd. | 3 | ## Copyright (C) 2019 The Qt Company Ltd. |
4 | ## Contact: https://www.qt.io/licensing/ | 4 | ## Contact: https://www.qt.io/licensing/ |
5 | ## | 5 | ## |
6 | ## This file is part of the Boot to Qt meta layer. | 6 | ## This file is part of the Boot to Qt meta layer. |
@@ -27,7 +27,7 @@ | |||
27 | ## | 27 | ## |
28 | ############################################################################ | 28 | ############################################################################ |
29 | 29 | ||
30 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | 30 | do_install_append () { |
31 | SRC_URI += " \ | 31 | # remove real-ld symlink |
32 | file://0001-egl_viv-cast-EGLNative-types-from-vivante-functions.patch \ | 32 | rm ${D}${libexecdir}/gcc/${TARGET_SYS}/${BINV}/real-ld${EXEEXT} |
33 | " | 33 | } |
diff --git a/meta-boot2qt/recipes-qt/automotive/gammaray_git.bb b/meta-boot2qt/recipes-qt/automotive/gammaray_git.bb index 0a84a7c..e92f00c 100644 --- a/meta-boot2qt/recipes-qt/automotive/gammaray_git.bb +++ b/meta-boot2qt/recipes-qt/automotive/gammaray_git.bb | |||
@@ -9,7 +9,7 @@ inherit cmake_qt5 | |||
9 | SRC_URI = "git://github.com/KDAB/GammaRay;branch=${BRANCH}" | 9 | SRC_URI = "git://github.com/KDAB/GammaRay;branch=${BRANCH}" |
10 | 10 | ||
11 | BRANCH = "5.12" | 11 | BRANCH = "5.12" |
12 | SRCREV = "cd00ba76ea9399131d28e275432c7d101e634951" | 12 | SRCREV = "6279cbaa86c2a66e15a5d1cc9df071912b44090c" |
13 | PV = "${BRANCH}+git${SRCPV}" | 13 | PV = "${BRANCH}+git${SRCPV}" |
14 | 14 | ||
15 | DEPENDS = "qtdeclarative qtlocation qtsvg qttools qtconnectivity qt3d qtivi qtscxml qtscxml-native \ | 15 | DEPENDS = "qtdeclarative qtlocation qtsvg qttools qtconnectivity qt3d qtivi qtscxml qtscxml-native \ |
diff --git a/meta-fsl-extras/recipes/qt5/qtbase/0001-egl_viv-cast-EGLNative-types-from-vivante-functions.patch b/meta-fsl-extras/recipes/qt5/qtbase/0001-egl_viv-cast-EGLNative-types-from-vivante-functions.patch deleted file mode 100644 index dc56cfc..0000000 --- a/meta-fsl-extras/recipes/qt5/qtbase/0001-egl_viv-cast-EGLNative-types-from-vivante-functions.patch +++ /dev/null | |||
@@ -1,57 +0,0 @@ | |||
1 | From 40e76307c1ee1ebe4e0142d623071d0f768f2450 Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuli Piippo <samuli.piippo@qt.io> | ||
3 | Date: Wed, 9 Jan 2019 13:01:01 +0000 | ||
4 | Subject: [PATCH] egl_viv: cast EGLNative types from vivante functions | ||
5 | |||
6 | All vivante functions return void* even when the actual native type | ||
7 | (EGLNativeDisplayType, EGLNativeWindowType, etc.) might be typedef'ed | ||
8 | as something else, as they do when the CFLAGS from egl.pc are now used. | ||
9 | --- | ||
10 | .../deviceintegration/eglfs_viv/qeglfsvivintegration.cpp | 4 ++-- | ||
11 | .../deviceintegration/eglfs_viv_wl/qeglfsvivwlintegration.cpp | 4 ++-- | ||
12 | 2 files changed, 4 insertions(+), 4 deletions(-) | ||
13 | |||
14 | diff --git a/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv/qeglfsvivintegration.cpp b/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv/qeglfsvivintegration.cpp | ||
15 | index 763a4a462b..2fc076ad0c 100644 | ||
16 | --- a/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv/qeglfsvivintegration.cpp | ||
17 | +++ b/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv/qeglfsvivintegration.cpp | ||
18 | @@ -65,7 +65,7 @@ void QEglFSVivIntegration::platformInit() | ||
19 | VivanteInit(); | ||
20 | mNativeDisplay = fbGetDisplay(); | ||
21 | #else | ||
22 | - mNativeDisplay = fbGetDisplayByIndex(framebufferIndex()); | ||
23 | + mNativeDisplay = static_cast<EGLNativeDisplayType>(fbGetDisplayByIndex(framebufferIndex())); | ||
24 | #endif | ||
25 | |||
26 | fbGetDisplayGeometry(mNativeDisplay, &width, &height); | ||
27 | @@ -88,7 +88,7 @@ EGLNativeWindowType QEglFSVivIntegration::createNativeWindow(QPlatformWindow *wi | ||
28 | Q_UNUSED(window) | ||
29 | Q_UNUSED(format) | ||
30 | |||
31 | - EGLNativeWindowType eglWindow = fbCreateWindow(mNativeDisplay, 0, 0, size.width(), size.height()); | ||
32 | + EGLNativeWindowType eglWindow = static_cast<EGLNativeWindowType>(fbCreateWindow(mNativeDisplay, 0, 0, size.width(), size.height())); | ||
33 | return eglWindow; | ||
34 | } | ||
35 | |||
36 | diff --git a/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv_wl/qeglfsvivwlintegration.cpp b/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv_wl/qeglfsvivwlintegration.cpp | ||
37 | index 61e2f17766..3bdae239cd 100644 | ||
38 | --- a/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv_wl/qeglfsvivwlintegration.cpp | ||
39 | +++ b/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv_wl/qeglfsvivwlintegration.cpp | ||
40 | @@ -60,7 +60,7 @@ void QEglFSVivWaylandIntegration::platformInit() | ||
41 | } | ||
42 | |||
43 | mWaylandDisplay = wl_display_create(); | ||
44 | - mNativeDisplay = fbGetDisplay(mWaylandDisplay); | ||
45 | + mNativeDisplay = static_cast<EGLNativeDisplayType>(fbGetDisplay(mWaylandDisplay)); | ||
46 | fbGetDisplayGeometry(mNativeDisplay, &width, &height); | ||
47 | mScreenSize.setHeight(height); | ||
48 | mScreenSize.setWidth(width); | ||
49 | @@ -81,7 +81,7 @@ EGLNativeWindowType QEglFSVivWaylandIntegration::createNativeWindow(QPlatformWin | ||
50 | Q_UNUSED(window) | ||
51 | Q_UNUSED(format) | ||
52 | |||
53 | - EGLNativeWindowType eglWindow = fbCreateWindow(mNativeDisplay, 0, 0, size.width(), size.height()); | ||
54 | + EGLNativeWindowType eglWindow = static_cast<EGLNativeWindowType>(fbCreateWindow(mNativeDisplay, 0, 0, size.width(), size.height())); | ||
55 | return eglWindow; | ||
56 | } | ||
57 | |||
diff --git a/meta-intel-extras/recipes/images/core-image-minimal-initramfs.bbappend b/meta-intel-extras/recipes/images/core-image-minimal-initramfs.bbappend index c1918ba..fd7559a 100644 --- a/meta-intel-extras/recipes/images/core-image-minimal-initramfs.bbappend +++ b/meta-intel-extras/recipes/images/core-image-minimal-initramfs.bbappend | |||
@@ -27,5 +27,11 @@ | |||
27 | ## | 27 | ## |
28 | ############################################################################ | 28 | ############################################################################ |
29 | 29 | ||
30 | INITRAMFS_SCRIPTS += "initramfs-module-rtsx-pci-sdmmc" | 30 | INITRAMFS_SCRIPTS += "\ |
31 | PACKAGE_INSTALL += "kernel-module-rtsx-pci-sdmmc" | 31 | initramfs-module-rtsx-pci-sdmmc \ |
32 | initramfs-module-r8169 \ | ||
33 | " | ||
34 | PACKAGE_INSTALL += "\ | ||
35 | kernel-module-rtsx-pci-sdmmc \ | ||
36 | kernel-module-r8169 \ | ||
37 | " | ||
diff --git a/meta-intel-extras/recipes/initrdscripts/initramfs-framework/network b/meta-intel-extras/recipes/initrdscripts/initramfs-framework/network new file mode 100644 index 0000000..134a70a --- /dev/null +++ b/meta-intel-extras/recipes/initrdscripts/initramfs-framework/network | |||
@@ -0,0 +1,47 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | ############################################################################ | ||
4 | ## | ||
5 | ## Copyright (C) 2019 The Qt Company Ltd. | ||
6 | ## Contact: https://www.qt.io/licensing/ | ||
7 | ## | ||
8 | ## This file is part of the Boot to Qt meta layer. | ||
9 | ## | ||
10 | ## $QT_BEGIN_LICENSE:GPL$ | ||
11 | ## Commercial License Usage | ||
12 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
13 | ## accordance with the commercial license agreement provided with the | ||
14 | ## Software or, alternatively, in accordance with the terms contained in | ||
15 | ## a written agreement between you and The Qt Company. For licensing terms | ||
16 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
17 | ## information use the contact form at https://www.qt.io/contact-us. | ||
18 | ## | ||
19 | ## GNU General Public License Usage | ||
20 | ## Alternatively, this file may be used under the terms of the GNU | ||
21 | ## General Public License version 3 or (at your option) any later version | ||
22 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
23 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
24 | ## included in the packaging of this file. Please review the following | ||
25 | ## information to ensure the GNU General Public License requirements will | ||
26 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
27 | ## | ||
28 | ## $QT_END_LICENSE$ | ||
29 | ## | ||
30 | ############################################################################ | ||
31 | |||
32 | network_enabled() { | ||
33 | return 0 | ||
34 | } | ||
35 | |||
36 | network_run() { | ||
37 | if [ -n "$bootparam_ip" ]; then | ||
38 | load_kernel_module r8169 | ||
39 | if [ "${bootparam_ip}" -ne "dhcp" ]; then | ||
40 | echo "WARN: DHCP only supported at this time." | ||
41 | fi | ||
42 | ip link set dev eth0 up | ||
43 | udhcpc | ||
44 | fi | ||
45 | } | ||
46 | |||
47 | |||
diff --git a/meta-intel-extras/recipes/initrdscripts/initramfs-framework/rootfs b/meta-intel-extras/recipes/initrdscripts/initramfs-framework/rootfs new file mode 100755 index 0000000..c93c9c2 --- /dev/null +++ b/meta-intel-extras/recipes/initrdscripts/initramfs-framework/rootfs | |||
@@ -0,0 +1,79 @@ | |||
1 | #!/bin/sh | ||
2 | # Copyright (C) 2011 O.S. Systems Software LTDA. | ||
3 | # Licensed on MIT | ||
4 | |||
5 | rootfs_enabled() { | ||
6 | return 0 | ||
7 | } | ||
8 | |||
9 | rootfs_run() { | ||
10 | if [ -z "$ROOTFS_DIR" ]; then | ||
11 | return | ||
12 | fi | ||
13 | C=0 | ||
14 | delay=${bootparam_rootdelay:-1} | ||
15 | timeout=${bootparam_roottimeout:-5} | ||
16 | while [ ! -d $ROOTFS_DIR/dev ]; do | ||
17 | if [ $(( $C * $delay )) -gt $timeout ]; then | ||
18 | fatal "root '$bootparam_root' doesn't exist or does not contain a /dev." | ||
19 | fi | ||
20 | |||
21 | if [ -n "$bootparam_root" ]; then | ||
22 | debug "No e2fs compatible filesystem has been mounted, mounting $bootparam_root..." | ||
23 | |||
24 | if [ "`echo ${bootparam_root} | cut -c1-5`" = "UUID=" ]; then | ||
25 | root_uuid=`echo $bootparam_root | cut -c6-` | ||
26 | bootparam_root="/dev/disk/by-uuid/$root_uuid" | ||
27 | fi | ||
28 | |||
29 | if [ "`echo ${bootparam_root} | cut -c1-9`" = "PARTUUID=" ]; then | ||
30 | root_uuid=`echo $bootparam_root | cut -c10-` | ||
31 | bootparam_root="/dev/disk/by-partuuid/$root_uuid" | ||
32 | fi | ||
33 | |||
34 | if [ "`echo ${bootparam_root} | cut -c1-6`" = "LABEL=" ]; then | ||
35 | root_label=`echo $bootparam_root | cut -c7-` | ||
36 | bootparam_root="/dev/disk/by-label/$root_label" | ||
37 | fi | ||
38 | |||
39 | if [ "${bootparam_root}" = "/dev/nfs" ]; then | ||
40 | bootparam_rootfstype="nfs" | ||
41 | bootparam_root=`echo $bootparam_nfsroot | cut -f1 -d","` | ||
42 | bootparam_nfsopts=`echo $bootparam_nfsroot | cut -f2- -d","` | ||
43 | fi | ||
44 | |||
45 | if [ -e "$bootparam_root" ] || [ "${bootparam_rootfstype}" = "nfs" ]; then | ||
46 | flags="" | ||
47 | if [ -n "$bootparam_ro" ] && ! echo "$bootparam_rootflags" | grep -w -q "ro"; then | ||
48 | if [ -n "$bootparam_rootflags" ]; then | ||
49 | bootparam_rootflags="$bootparam_rootflags," | ||
50 | fi | ||
51 | bootparam_rootflags="${bootparam_rootflags}ro" | ||
52 | fi | ||
53 | if [ -n "$bootparam_nfsopts" ]; then | ||
54 | if [ -n "$bootparam_rootflags" ]; then | ||
55 | bootparam_rootflags="$bootparam_rootflags," | ||
56 | fi | ||
57 | bootparam_rootflags="${bootparam_rootflags}${bootparam_nfsopts}" | ||
58 | fi | ||
59 | if [ -n "$bootparam_rootflags" ]; then | ||
60 | flags="$flags -o$bootparam_rootflags" | ||
61 | fi | ||
62 | if [ -n "$bootparam_rootfstype" ]; then | ||
63 | flags="$flags -t$bootparam_rootfstype" | ||
64 | fi | ||
65 | mount $flags $bootparam_root $ROOTFS_DIR | ||
66 | if [ -d $ROOTFS_DIR/dev ]; then | ||
67 | break | ||
68 | else | ||
69 | # It is unlikely to change, but keep trying anyway. | ||
70 | # Perhaps we pick a different device next time. | ||
71 | umount $ROOTFS_DIR | ||
72 | fi | ||
73 | fi | ||
74 | fi | ||
75 | debug "Sleeping for $delay second(s) to wait root to settle..." | ||
76 | sleep $delay | ||
77 | C=$(( $C + 1 )) | ||
78 | done | ||
79 | } | ||
diff --git a/meta-intel-extras/recipes/initrdscripts/initramfs-framework_1.0.bbappend b/meta-intel-extras/recipes/initrdscripts/initramfs-framework_1.0.bbappend index cfd05cd..2a8ac89 100644 --- a/meta-intel-extras/recipes/initrdscripts/initramfs-framework_1.0.bbappend +++ b/meta-intel-extras/recipes/initrdscripts/initramfs-framework_1.0.bbappend | |||
@@ -1,6 +1,6 @@ | |||
1 | ############################################################################ | 1 | ############################################################################ |
2 | ## | 2 | ## |
3 | ## Copyright (C) 2018 The Qt Company Ltd. | 3 | ## Copyright (C) 2019 The Qt Company Ltd. |
4 | ## Contact: https://www.qt.io/licensing/ | 4 | ## Contact: https://www.qt.io/licensing/ |
5 | ## | 5 | ## |
6 | ## This file is part of the Boot to Qt meta layer. | 6 | ## This file is part of the Boot to Qt meta layer. |
@@ -29,14 +29,25 @@ | |||
29 | 29 | ||
30 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | 30 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
31 | 31 | ||
32 | SRC_URI += "file://rtsx_pci_sdmmc" | 32 | SRC_URI += "\ |
33 | file://rtsx_pci_sdmmc \ | ||
34 | file://network \ | ||
35 | " | ||
33 | 36 | ||
34 | do_install_append() { | 37 | do_install_append() { |
35 | install -m 0755 ${WORKDIR}/rtsx_pci_sdmmc ${D}/init.d/20-rtsx_pci_sdmmc | 38 | install -m 0755 ${WORKDIR}/rtsx_pci_sdmmc ${D}/init.d/20-rtsx_pci_sdmmc |
39 | install -m 0755 ${WORKDIR}/network ${D}/init.d/30-network | ||
36 | } | 40 | } |
37 | 41 | ||
38 | PACKAGES += "initramfs-module-rtsx-pci-sdmmc" | 42 | PACKAGES += "\ |
43 | initramfs-module-rtsx-pci-sdmmc \ | ||
44 | initramfs-module-r8169 \ | ||
45 | " | ||
39 | 46 | ||
40 | SUMMARY_initramfs-module-rtsx-pci-sdmmc = "initramfs support for rtsx_pci_sdmmc" | 47 | SUMMARY_initramfs-module-rtsx-pci-sdmmc = "initramfs support for rtsx_pci_sdmmc" |
41 | RDEPENDS_initramfs-module-rtsx-pci-sdmmc = "${PN}-base" | 48 | RDEPENDS_initramfs-module-rtsx-pci-sdmmc = "${PN}-base" |
42 | FILES_initramfs-module-rtsx-pci-sdmmc = "/init.d/20-rtsx_pci_sdmmc" | 49 | FILES_initramfs-module-rtsx-pci-sdmmc = "/init.d/20-rtsx_pci_sdmmc" |
50 | |||
51 | SUMMARY_initramfs-module-r8169 = "initramfs support for Realtek LAN driver" | ||
52 | RDEPENDS_initramfs-module-r8169 = "${PN}-base" | ||
53 | FILES_initramfs-module-r8169 = "/init.d/30-network" | ||