diff options
9 files changed, 1 insertions, 477 deletions
diff --git a/meta-intel-extras/recipes/mesa/files/0001-Simplify-wayland-scanner-lookup.patch b/meta-intel-extras/recipes/mesa/files/0001-Simplify-wayland-scanner-lookup.patch deleted file mode 100644 index a50d2a2..0000000 --- a/meta-intel-extras/recipes/mesa/files/0001-Simplify-wayland-scanner-lookup.patch +++ /dev/null | |||
@@ -1,39 +0,0 @@ | |||
1 | From 7e8e0f8a8ac2425e19a2f340c9e3da9345f25940 Mon Sep 17 00:00:00 2001 | ||
2 | From: Jussi Kukkonen <jussi.kukkonen@intel.com> | ||
3 | Date: Tue, 15 Nov 2016 15:20:49 +0200 | ||
4 | Subject: [PATCH 1/6] Simplify wayland-scanner lookup | ||
5 | Organization: O.S. Systems Software LTDA. | ||
6 | |||
7 | Don't use pkg-config to lookup the path of a binary that's in the path. | ||
8 | |||
9 | Alternatively we'd have to prefix the path returned by pkg-config with | ||
10 | PKG_CONFIG_SYSROOT_DIR. | ||
11 | |||
12 | Upstream-Status: Pending | ||
13 | Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> | ||
14 | Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> | ||
15 | --- | ||
16 | configure.ac | 7 +------ | ||
17 | 1 file changed, 1 insertion(+), 6 deletions(-) | ||
18 | |||
19 | diff --git a/configure.ac b/configure.ac | ||
20 | index 14f1af2b2f..916d0bd207 100644 | ||
21 | --- a/configure.ac | ||
22 | +++ b/configure.ac | ||
23 | @@ -1825,12 +1825,7 @@ for plat in $platforms; do | ||
24 | PKG_CHECK_MODULES([WAYLAND_PROTOCOLS], [wayland-protocols >= $WAYLAND_PROTOCOLS_REQUIRED]) | ||
25 | WAYLAND_PROTOCOLS_DATADIR=`$PKG_CONFIG --variable=pkgdatadir wayland-protocols` | ||
26 | |||
27 | - PKG_CHECK_MODULES([WAYLAND_SCANNER], [wayland-scanner], | ||
28 | - WAYLAND_SCANNER=`$PKG_CONFIG --variable=wayland_scanner wayland-scanner`, | ||
29 | - WAYLAND_SCANNER='') | ||
30 | - if test "x$WAYLAND_SCANNER" = x; then | ||
31 | - AC_PATH_PROG([WAYLAND_SCANNER], [wayland-scanner], [:]) | ||
32 | - fi | ||
33 | + AC_PATH_PROG([WAYLAND_SCANNER], [wayland-scanner], [:]) | ||
34 | |||
35 | if test "x$WAYLAND_SCANNER" = "x:"; then | ||
36 | AC_MSG_ERROR([wayland-scanner is needed to compile the wayland platform]) | ||
37 | -- | ||
38 | 2.18.0 | ||
39 | |||
diff --git a/meta-intel-extras/recipes/mesa/files/0002-winsys-svga-drm-Include-sys-types.h.patch b/meta-intel-extras/recipes/mesa/files/0002-winsys-svga-drm-Include-sys-types.h.patch deleted file mode 100644 index ffb3bf7..0000000 --- a/meta-intel-extras/recipes/mesa/files/0002-winsys-svga-drm-Include-sys-types.h.patch +++ /dev/null | |||
@@ -1,34 +0,0 @@ | |||
1 | From 7792f228991744a0396b8bf811e281dca86165d3 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 16 Aug 2017 18:58:20 -0700 | ||
4 | Subject: [PATCH 2/6] winsys/svga/drm: Include sys/types.h | ||
5 | Organization: O.S. Systems Software LTDA. | ||
6 | |||
7 | vmw_screen.h uses dev_t which is defines in sys/types.h | ||
8 | this header is required to be included for getting dev_t | ||
9 | definition. This issue happens on musl C library, it is hidden | ||
10 | on glibc since sys/types.h is included through another | ||
11 | system headers | ||
12 | |||
13 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
14 | Upstream-Status: Backport [7dfdfbf8c37e52e7b9b09f7d1d434edad3ebc864] | ||
15 | Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> | ||
16 | --- | ||
17 | src/gallium/winsys/svga/drm/vmw_screen.h | 1 + | ||
18 | 1 file changed, 1 insertion(+) | ||
19 | |||
20 | diff --git a/src/gallium/winsys/svga/drm/vmw_screen.h b/src/gallium/winsys/svga/drm/vmw_screen.h | ||
21 | index f21cabb51f..4c972fdaa9 100644 | ||
22 | --- a/src/gallium/winsys/svga/drm/vmw_screen.h | ||
23 | +++ b/src/gallium/winsys/svga/drm/vmw_screen.h | ||
24 | @@ -41,6 +41,7 @@ | ||
25 | #include "svga_winsys.h" | ||
26 | #include "pipebuffer/pb_buffer_fenced.h" | ||
27 | #include <os/os_thread.h> | ||
28 | +#include <sys/types.h> | ||
29 | |||
30 | #define VMW_GMR_POOL_SIZE (16*1024*1024) | ||
31 | #define VMW_QUERY_POOL_SIZE (8192) | ||
32 | -- | ||
33 | 2.18.0 | ||
34 | |||
diff --git a/meta-intel-extras/recipes/mesa/files/0003-Properly-get-LLVM-version-when-using-LLVM-Git-releas.patch b/meta-intel-extras/recipes/mesa/files/0003-Properly-get-LLVM-version-when-using-LLVM-Git-releas.patch deleted file mode 100644 index 5e735ca..0000000 --- a/meta-intel-extras/recipes/mesa/files/0003-Properly-get-LLVM-version-when-using-LLVM-Git-releas.patch +++ /dev/null | |||
@@ -1,44 +0,0 @@ | |||
1 | From 8b42fb47138f91d9378439ab716bac7701e4e326 Mon Sep 17 00:00:00 2001 | ||
2 | From: Otavio Salvador <otavio@ossystems.com.br> | ||
3 | Date: Tue, 5 Jun 2018 11:11:10 -0300 | ||
4 | Subject: [PATCH 3/6] Properly get LLVM version when using LLVM Git releases | ||
5 | Organization: O.S. Systems Software LTDA. | ||
6 | |||
7 | $ llvm-config-host --version | ||
8 | 5.0.0git-9a5c333388c | ||
9 | |||
10 | We need to ignore everything after 5.0.0 which is what the cut cmd is | ||
11 | doing | ||
12 | |||
13 | Upstream-Status: Pending | ||
14 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
15 | Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> | ||
16 | --- | ||
17 | configure.ac | 4 ++-- | ||
18 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
19 | |||
20 | diff --git a/configure.ac b/configure.ac | ||
21 | index 916d0bd207..dd172f1ebe 100644 | ||
22 | --- a/configure.ac | ||
23 | +++ b/configure.ac | ||
24 | @@ -1090,7 +1090,7 @@ strip_unwanted_llvm_flags() { | ||
25 | |||
26 | llvm_set_environment_variables() { | ||
27 | if test "x$LLVM_CONFIG" != xno; then | ||
28 | - LLVM_VERSION=`$LLVM_CONFIG --version | egrep -o '^[[0-9.]]+'` | ||
29 | + LLVM_VERSION=`$LLVM_CONFIG --version | cut -c1-5` | ||
30 | LLVM_CPPFLAGS=`strip_unwanted_llvm_flags "$LLVM_CONFIG --cppflags"` | ||
31 | LLVM_INCLUDEDIR=`$LLVM_CONFIG --includedir` | ||
32 | LLVM_LIBDIR=`$LLVM_CONFIG --libdir` | ||
33 | @@ -2808,7 +2808,7 @@ detect_old_buggy_llvm() { | ||
34 | dnl ourselves. | ||
35 | dnl (See https://llvm.org/bugs/show_bug.cgi?id=6823) | ||
36 | dnl We can't use $LLVM_VERSION because it has 'svn' stripped out, | ||
37 | - LLVM_SO_NAME=LLVM-`$LLVM_CONFIG --version` | ||
38 | + LLVM_SO_NAME=LLVM-`$LLVM_CONFIG --version | cut -c1-5` | ||
39 | AS_IF([test -f "$LLVM_LIBDIR/lib$LLVM_SO_NAME.$IMP_LIB_EXT"], [llvm_have_one_so=yes]) | ||
40 | |||
41 | if test "x$llvm_have_one_so" = xyes; then | ||
42 | -- | ||
43 | 2.18.0 | ||
44 | |||
diff --git a/meta-intel-extras/recipes/mesa/files/0004-Use-Python-3-to-execute-the-scripts.patch b/meta-intel-extras/recipes/mesa/files/0004-Use-Python-3-to-execute-the-scripts.patch deleted file mode 100644 index 8953c4a..0000000 --- a/meta-intel-extras/recipes/mesa/files/0004-Use-Python-3-to-execute-the-scripts.patch +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | From ebe6077a1d74e56b28249f71e8760295fa846ed2 Mon Sep 17 00:00:00 2001 | ||
2 | From: Otavio Salvador <otavio@ossystems.com.br> | ||
3 | Date: Fri, 29 Dec 2017 10:27:59 -0200 | ||
4 | Subject: [PATCH 4/6] Use Python 3 to execute the scripts | ||
5 | Organization: O.S. Systems Software LTDA. | ||
6 | |||
7 | The MESA build system uses Python 2 but as OE-Core has moved away from | ||
8 | it, we change it to use Python 3 instead. | ||
9 | |||
10 | Upstream-Status: Inappropriate [ configuration ] | ||
11 | |||
12 | Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> | ||
13 | --- | ||
14 | configure.ac | 2 +- | ||
15 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
16 | |||
17 | diff --git a/configure.ac b/configure.ac | ||
18 | index dd172f1ebe..40cac36ac2 100644 | ||
19 | --- a/configure.ac | ||
20 | +++ b/configure.ac | ||
21 | @@ -122,7 +122,7 @@ AM_PROG_CC_C_O | ||
22 | AC_PROG_NM | ||
23 | AM_PROG_AS | ||
24 | AX_CHECK_GNU_MAKE | ||
25 | -AC_CHECK_PROGS([PYTHON2], [python2.7 python2 python]) | ||
26 | +AC_CHECK_PROGS([PYTHON2], [python3.5 python3 python]) | ||
27 | AC_PROG_SED | ||
28 | AC_PROG_MKDIR_P | ||
29 | |||
30 | -- | ||
31 | 2.18.0 | ||
32 | |||
diff --git a/meta-intel-extras/recipes/mesa/files/0005-dri-i965-Add-missing-time.h-include.patch b/meta-intel-extras/recipes/mesa/files/0005-dri-i965-Add-missing-time.h-include.patch deleted file mode 100644 index d40e7b5..0000000 --- a/meta-intel-extras/recipes/mesa/files/0005-dri-i965-Add-missing-time.h-include.patch +++ /dev/null | |||
@@ -1,36 +0,0 @@ | |||
1 | From 9e0368af471af3a36e0eb526453f892598120065 Mon Sep 17 00:00:00 2001 | ||
2 | From: Otavio Salvador <otavio@ossystems.com.br> | ||
3 | Date: Wed, 6 Jun 2018 09:50:35 -0300 | ||
4 | Subject: [PATCH 5/6] dri: i965: Add missing time.h include | ||
5 | Organization: O.S. Systems Software LTDA. | ||
6 | |||
7 | This fixes a build error when using musl: | ||
8 | |||
9 | ,---- | ||
10 | | In file included from .../src/mesa/drivers/dri/i965/intel_upload.c:33:0: | ||
11 | | .../src/mesa/drivers/dri/i965/brw_bufmgr.h:132:4: error: unknown type name 'time_t' | ||
12 | | time_t free_time; | ||
13 | | ^~~~~~ | ||
14 | `---- | ||
15 | |||
16 | Upstream-Status: Backport [3c288da5eec81ee58b85927df18d9194ead8f5c2] | ||
17 | Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> | ||
18 | --- | ||
19 | src/mesa/drivers/dri/i965/brw_bufmgr.h | 1 + | ||
20 | 1 file changed, 1 insertion(+) | ||
21 | |||
22 | diff --git a/src/mesa/drivers/dri/i965/brw_bufmgr.h b/src/mesa/drivers/dri/i965/brw_bufmgr.h | ||
23 | index 68f5e0c2c8..5b60a23763 100644 | ||
24 | --- a/src/mesa/drivers/dri/i965/brw_bufmgr.h | ||
25 | +++ b/src/mesa/drivers/dri/i965/brw_bufmgr.h | ||
26 | @@ -37,6 +37,7 @@ | ||
27 | #include <stdbool.h> | ||
28 | #include <stdint.h> | ||
29 | #include <stdio.h> | ||
30 | +#include <time.h> | ||
31 | #include "util/u_atomic.h" | ||
32 | #include "util/list.h" | ||
33 | |||
34 | -- | ||
35 | 2.18.0 | ||
36 | |||
diff --git a/meta-intel-extras/recipes/mesa/files/0006-use-PKG_CHECK_VAR-for-defining-WAYLAND_PROTOCOLS_DAT.patch b/meta-intel-extras/recipes/mesa/files/0006-use-PKG_CHECK_VAR-for-defining-WAYLAND_PROTOCOLS_DAT.patch deleted file mode 100644 index 0212922..0000000 --- a/meta-intel-extras/recipes/mesa/files/0006-use-PKG_CHECK_VAR-for-defining-WAYLAND_PROTOCOLS_DAT.patch +++ /dev/null | |||
@@ -1,37 +0,0 @@ | |||
1 | From 754ccf89a732fc3da6e9bc62ebd6b28686ff3d26 Mon Sep 17 00:00:00 2001 | ||
2 | From: Otavio Salvador <otavio@ossystems.com.br> | ||
3 | Date: Wed, 29 Aug 2018 22:10:30 -0300 | ||
4 | Subject: [PATCH 6/6] use PKG_CHECK_VAR for defining WAYLAND_PROTOCOLS_DATADIR | ||
5 | Organization: O.S. Systems Software LTDA. | ||
6 | |||
7 | This allows to override the wayland-protocols pkgdatadir with the | ||
8 | WAYLAND_PROTOCOLS_DATADIR from environment. | ||
9 | |||
10 | pkgconfig would return an absolute path in | ||
11 | /usr/share/wayland-protocols | ||
12 | for the pkgdatadir value, which is not suitable for cross-compiling. | ||
13 | |||
14 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
15 | Upstream-Status: Pending | ||
16 | |||
17 | Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> | ||
18 | --- | ||
19 | configure.ac | 2 +- | ||
20 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
21 | |||
22 | diff --git a/configure.ac b/configure.ac | ||
23 | index 40cac36ac2..728bbdcbc4 100644 | ||
24 | --- a/configure.ac | ||
25 | +++ b/configure.ac | ||
26 | @@ -1823,7 +1823,7 @@ for plat in $platforms; do | ||
27 | PKG_CHECK_MODULES([WAYLAND_CLIENT], [wayland-client >= $WAYLAND_REQUIRED]) | ||
28 | PKG_CHECK_MODULES([WAYLAND_SERVER], [wayland-server >= $WAYLAND_REQUIRED]) | ||
29 | PKG_CHECK_MODULES([WAYLAND_PROTOCOLS], [wayland-protocols >= $WAYLAND_PROTOCOLS_REQUIRED]) | ||
30 | - WAYLAND_PROTOCOLS_DATADIR=`$PKG_CONFIG --variable=pkgdatadir wayland-protocols` | ||
31 | + PKG_CHECK_VAR([WAYLAND_PROTOCOLS_DATADIR], [wayland-protocols >= $WAYLAND_PROTOCOLS_REQUIRED], pkgdatadir) | ||
32 | |||
33 | AC_PATH_PROG([WAYLAND_SCANNER], [wayland-scanner], [:]) | ||
34 | |||
35 | -- | ||
36 | 2.18.0 | ||
37 | |||
diff --git a/meta-intel-extras/recipes/mesa/mesa.inc b/meta-intel-extras/recipes/mesa/mesa.inc deleted file mode 100644 index 0219ded..0000000 --- a/meta-intel-extras/recipes/mesa/mesa.inc +++ /dev/null | |||
@@ -1,233 +0,0 @@ | |||
1 | SUMMARY = "A free implementation of the OpenGL API" | ||
2 | DESCRIPTION = "Mesa is an open-source implementation of the OpenGL specification - \ | ||
3 | a system for rendering interactive 3D graphics. \ | ||
4 | A variety of device drivers allows Mesa to be used in many different environments \ | ||
5 | ranging from software emulation to complete hardware acceleration for modern GPUs. \ | ||
6 | Mesa is used as part of the overall Direct Rendering Infrastructure and X.org \ | ||
7 | environment." | ||
8 | |||
9 | HOMEPAGE = "http://mesa3d.org" | ||
10 | BUGTRACKER = "https://bugs.freedesktop.org" | ||
11 | SECTION = "x11" | ||
12 | LICENSE = "MIT" | ||
13 | LIC_FILES_CHKSUM = "file://docs/license.html;md5=725f991a1cc322aa7a0cd3a2016621c4" | ||
14 | |||
15 | PE = "2" | ||
16 | |||
17 | DEPENDS = "expat makedepend-native flex-native bison-native libxml2-native zlib chrpath-replacement-native" | ||
18 | EXTRANATIVEPATH += "chrpath-native" | ||
19 | PROVIDES = " \ | ||
20 | ${@bb.utils.contains('PACKAGECONFIG', 'opengl', 'virtual/libgl', '', d)} \ | ||
21 | ${@bb.utils.contains('PACKAGECONFIG', 'gles', 'virtual/libgles1 virtual/libgles2', '', d)} \ | ||
22 | ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'virtual/egl', '', d)} \ | ||
23 | ${@bb.utils.contains('PACKAGECONFIG', 'gbm', 'virtual/libgbm', '', d)} \ | ||
24 | virtual/mesa \ | ||
25 | " | ||
26 | |||
27 | inherit autotools pkgconfig python3native gettext distro_features_check | ||
28 | |||
29 | ANY_OF_DISTRO_FEATURES = "opengl vulkan" | ||
30 | |||
31 | PLATFORMS ??= "${@bb.utils.filter('PACKAGECONFIG', 'x11 wayland', d)} \ | ||
32 | ${@bb.utils.contains('PACKAGECONFIG', 'gbm', 'drm', '', d)} \ | ||
33 | surfaceless" | ||
34 | |||
35 | export LLVM_CONFIG = "${STAGING_BINDIR_NATIVE}/llvm-config${MESA_LLVM_RELEASE}" | ||
36 | export YOCTO_ALTERNATE_EXE_PATH = "${STAGING_LIBDIR}/llvm${MESA_LLVM_RELEASE}/llvm-config" | ||
37 | export YOCTO_ALTERNATE_MULTILIB_NAME = "${base_libdir}" | ||
38 | EXTRA_OECONF = "--enable-shared-glapi \ | ||
39 | --disable-opencl \ | ||
40 | --enable-glx-read-only-text \ | ||
41 | PYTHON2=python2 \ | ||
42 | --with-llvm-prefix=${STAGING_LIBDIR}/llvm${MESA_LLVM_RELEASE} \ | ||
43 | --with-platforms='${PLATFORMS}'" | ||
44 | |||
45 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland vulkan', d)} \ | ||
46 | ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'opengl egl gles gbm dri', '', d)} \ | ||
47 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'x11 dri3', '', d)} \ | ||
48 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11 vulkan', 'dri3', '', d)} \ | ||
49 | " | ||
50 | |||
51 | # "gbm" requires "dri", "opengl" | ||
52 | PACKAGECONFIG[gbm] = "--enable-gbm,--disable-gbm" | ||
53 | |||
54 | X11_DEPS = "xf86driproto glproto virtual/libx11 libxext libxxf86vm libxdamage libxfixes" | ||
55 | # "x11" requires "opengl" | ||
56 | PACKAGECONFIG[x11] = "--enable-glx-tls,--disable-glx,${X11_DEPS}" | ||
57 | PACKAGECONFIG[xvmc] = "--enable-xvmc,--disable-xvmc,libxvmc" | ||
58 | PACKAGECONFIG[wayland] = ",,wayland-native wayland libdrm wayland-protocols" | ||
59 | |||
60 | DRIDRIVERS = "swrast" | ||
61 | DRIDRIVERS_append_x86 = ",radeon,r200,nouveau,i965,i915" | ||
62 | DRIDRIVERS_append_x86-64 = ",radeon,r200,nouveau,i965,i915" | ||
63 | # "dri" requires "opengl" | ||
64 | PACKAGECONFIG[dri] = "--enable-dri --with-dri-drivers=${DRIDRIVERS}, --disable-dri, dri2proto libdrm" | ||
65 | PACKAGECONFIG[dri3] = "--enable-dri3, --disable-dri3, dri3proto presentproto libxshmfence" | ||
66 | |||
67 | # Vulkan drivers need dri3 enabled | ||
68 | # radeon could be enabled as well but requires gallium-llvm with llvm >= 3.9 | ||
69 | VULKAN_DRIVERS = "" | ||
70 | VULKAN_DRIVERS_append_x86 = ",intel" | ||
71 | VULKAN_DRIVERS_append_x86-64 = ",intel" | ||
72 | PACKAGECONFIG[vulkan] = "--with-vulkan-drivers=${VULKAN_DRIVERS}, --without-vulkan-drivers, python3-mako-native" | ||
73 | |||
74 | PACKAGECONFIG[opengl] = "--enable-opengl, --disable-opengl" | ||
75 | |||
76 | # "gles" requires "opengl" | ||
77 | PACKAGECONFIG[gles] = "--enable-gles1 --enable-gles2, --disable-gles1 --disable-gles2" | ||
78 | |||
79 | # "egl" requires "dri", "opengl" | ||
80 | PACKAGECONFIG[egl] = "--enable-egl, --disable-egl" | ||
81 | |||
82 | PACKAGECONFIG[etnaviv] = "" | ||
83 | PACKAGECONFIG[imx] = "" | ||
84 | |||
85 | GALLIUMDRIVERS = "swrast" | ||
86 | GALLIUMDRIVERS_append ="${@bb.utils.contains('PACKAGECONFIG', 'etnaviv', ',etnaviv', '', d)}" | ||
87 | GALLIUMDRIVERS_append ="${@bb.utils.contains('PACKAGECONFIG', 'imx', ',imx', '', d)}" | ||
88 | GALLIUMDRIVERS_LLVM33 = "${@bb.utils.contains('PACKAGECONFIG', 'r600', 'radeonsi,r600', '', d)}" | ||
89 | PACKAGECONFIG[r600] = "" | ||
90 | GALLIUMDRIVERS_LLVM33_ENABLED = "${@oe.utils.version_less_or_equal('MESA_LLVM_RELEASE', '3.2', False, len('${GALLIUMDRIVERS_LLVM33}') > 0, d)}" | ||
91 | GALLIUMDRIVERS_LLVM = "r300,svga,nouveau${@',${GALLIUMDRIVERS_LLVM33}' if ${GALLIUMDRIVERS_LLVM33_ENABLED} else ''}" | ||
92 | GALLIUMDRIVERS_append_x86 = "${@bb.utils.contains('PACKAGECONFIG', 'gallium-llvm', ',${GALLIUMDRIVERS_LLVM}', '', d)}" | ||
93 | GALLIUMDRIVERS_append_x86-64 = "${@bb.utils.contains('PACKAGECONFIG', 'gallium-llvm', ',${GALLIUMDRIVERS_LLVM}', '', d)}" | ||
94 | GALLIUMDRIVERS_append_qemux86 = ",virgl" | ||
95 | GALLIUMDRIVERS_append_qemux86-64 = ",virgl" | ||
96 | # keep --with-gallium-drivers separate, because when only one of gallium versions is enabled, other 2 were adding --without-gallium-drivers | ||
97 | PACKAGECONFIG[gallium] = "--enable-texture-float --with-gallium-drivers=${GALLIUMDRIVERS}, --without-gallium-drivers" | ||
98 | MESA_LLVM_RELEASE ?= "6.0" | ||
99 | PACKAGECONFIG[gallium-llvm] = "--enable-llvm --enable-llvm-shared-libs, --disable-llvm, llvm${MESA_LLVM_RELEASE} llvm-native \ | ||
100 | ${@'elfutils' if ${GALLIUMDRIVERS_LLVM33_ENABLED} else ''}" | ||
101 | export WANT_LLVM_RELEASE = "${MESA_LLVM_RELEASE}" | ||
102 | PACKAGECONFIG[xa] = "--enable-xa, --disable-xa" | ||
103 | |||
104 | OSMESA = "${@bb.utils.contains('PACKAGECONFIG', 'gallium', 'gallium-osmesa', 'osmesa', d)}" | ||
105 | PACKAGECONFIG[osmesa] = "--enable-${OSMESA},--disable-${OSMESA}" | ||
106 | |||
107 | PACKAGECONFIG[unwind] = "--enable-libunwind,--disable-libunwind,libunwind" | ||
108 | |||
109 | EXTRA_OECONF_remove_libc-musl = "--enable-glx-tls" | ||
110 | EXTRA_OECONF_append_libc-musl = " --disable-glx-tls" | ||
111 | EXTRA_OECONF_append_libc-musl_x86 = " --disable-asm" | ||
112 | |||
113 | # llvmpipe is slow if compiled with -fomit-frame-pointer (e.g. -O2) | ||
114 | FULL_OPTIMIZATION_append = " -fno-omit-frame-pointer" | ||
115 | |||
116 | CFLAGS_append_armv5 = " -DMISSING_64BIT_ATOMICS" | ||
117 | EXTRA_OEMAKE += "WAYLAND_PROTOCOLS_DATADIR=${STAGING_DATADIR}/wayland-protocols" | ||
118 | |||
119 | # Remove the mesa dependency on mesa-dev, as mesa is empty | ||
120 | RDEPENDS_${PN}-dev = "" | ||
121 | |||
122 | # Add dependency so that GLES3 header don't need to be added manually | ||
123 | RDEPENDS_libgles2-mesa-dev += "libgles3-mesa-dev" | ||
124 | |||
125 | PACKAGES =+ "libegl-mesa libegl-mesa-dev \ | ||
126 | libosmesa libosmesa-dev \ | ||
127 | libgl-mesa libgl-mesa-dev \ | ||
128 | libglapi libglapi-dev \ | ||
129 | libgbm libgbm-dev \ | ||
130 | libgles1-mesa libgles1-mesa-dev \ | ||
131 | libgles2-mesa libgles2-mesa-dev \ | ||
132 | libgles3-mesa libgles3-mesa-dev \ | ||
133 | libwayland-egl libwayland-egl-dev \ | ||
134 | libxatracker libxatracker-dev \ | ||
135 | mesa-megadriver mesa-vulkan-drivers \ | ||
136 | " | ||
137 | |||
138 | do_install_append () { | ||
139 | # Drivers never need libtool .la files | ||
140 | rm -f ${D}${libdir}/dri/*.la | ||
141 | rm -f ${D}${libdir}/egl/*.la | ||
142 | rm -f ${D}${libdir}/gallium-pipe/*.la | ||
143 | rm -f ${D}${libdir}/gbm/*.la | ||
144 | |||
145 | # it was packaged in libdricore9.1.3-1 and preventing upgrades when debian.bbclass was used | ||
146 | rm -f ${D}${sysconfdir}/drirc | ||
147 | chrpath --delete ${D}${libdir}/dri/*_dri.so || true | ||
148 | } | ||
149 | |||
150 | # For the packages that make up the OpenGL interfaces, inject variables so that | ||
151 | # they don't get Debian-renamed (which would remove the -mesa suffix), and | ||
152 | # RPROVIDEs/RCONFLICTs on the generic libgl name. | ||
153 | python __anonymous() { | ||
154 | pkgconfig = (d.getVar('PACKAGECONFIG') or "").split() | ||
155 | for p in (("egl", "libegl", "libegl1"), | ||
156 | ("dri", "libgl", "libgl1"), | ||
157 | ("gles", "libgles1", "libglesv1-cm1"), | ||
158 | ("gles", "libgles2", "libglesv2-2"), | ||
159 | ("gles", "libgles3",)): | ||
160 | if not p[0] in pkgconfig: | ||
161 | continue | ||
162 | fullp = p[1] + "-mesa" | ||
163 | pkgs = " ".join(p[1:]) | ||
164 | d.setVar("DEBIAN_NOAUTONAME_" + fullp, "1") | ||
165 | d.appendVar("RREPLACES_" + fullp, pkgs) | ||
166 | d.appendVar("RPROVIDES_" + fullp, pkgs) | ||
167 | d.appendVar("RCONFLICTS_" + fullp, pkgs) | ||
168 | |||
169 | d.appendVar("RRECOMMENDS_" + fullp, " mesa-megadriver") | ||
170 | |||
171 | # For -dev, the first element is both the Debian and original name | ||
172 | fullp += "-dev" | ||
173 | pkgs = p[1] + "-dev" | ||
174 | d.setVar("DEBIAN_NOAUTONAME_" + fullp, "1") | ||
175 | d.appendVar("RREPLACES_" + fullp, pkgs) | ||
176 | d.appendVar("RPROVIDES_" + fullp, pkgs) | ||
177 | d.appendVar("RCONFLICTS_" + fullp, pkgs) | ||
178 | } | ||
179 | |||
180 | python mesa_populate_packages() { | ||
181 | pkgs = ['mesa', 'mesa-dev', 'mesa-dbg'] | ||
182 | for pkg in pkgs: | ||
183 | d.setVar("RPROVIDES_%s" % pkg, pkg.replace("mesa", "mesa-dri", 1)) | ||
184 | d.setVar("RCONFLICTS_%s" % pkg, pkg.replace("mesa", "mesa-dri", 1)) | ||
185 | d.setVar("RREPLACES_%s" % pkg, pkg.replace("mesa", "mesa-dri", 1)) | ||
186 | |||
187 | import re | ||
188 | dri_drivers_root = oe.path.join(d.getVar('PKGD'), d.getVar('libdir'), "dri") | ||
189 | if os.path.isdir(dri_drivers_root): | ||
190 | dri_pkgs = os.listdir(dri_drivers_root) | ||
191 | lib_name = d.expand("${MLPREFIX}mesa-megadriver") | ||
192 | for p in dri_pkgs: | ||
193 | m = re.match('^(.*)_dri\.so$', p) | ||
194 | if m: | ||
195 | pkg_name = " ${MLPREFIX}mesa-driver-%s" % legitimize_package_name(m.group(1)) | ||
196 | d.appendVar("RPROVIDES_%s" % lib_name, pkg_name) | ||
197 | d.appendVar("RCONFLICTS_%s" % lib_name, pkg_name) | ||
198 | d.appendVar("RREPLACES_%s" % lib_name, pkg_name) | ||
199 | |||
200 | pipe_drivers_root = os.path.join(d.getVar('libdir'), "gallium-pipe") | ||
201 | do_split_packages(d, pipe_drivers_root, '^pipe_(.*)\.so$', 'mesa-driver-pipe-%s', 'Mesa %s pipe driver', extra_depends='') | ||
202 | } | ||
203 | |||
204 | PACKAGESPLITFUNCS_prepend = "mesa_populate_packages " | ||
205 | |||
206 | PACKAGES_DYNAMIC += "^mesa-driver-.*" | ||
207 | |||
208 | FILES_${PN} += "${sysconfdir}/drirc" | ||
209 | FILES_mesa-megadriver = "${libdir}/dri/*" | ||
210 | FILES_mesa-vulkan-drivers = "${libdir}/libvulkan_*.so ${datadir}/vulkan" | ||
211 | FILES_libegl-mesa = "${libdir}/libEGL.so.*" | ||
212 | FILES_libgbm = "${libdir}/libgbm.so.*" | ||
213 | FILES_libgles1-mesa = "${libdir}/libGLESv1*.so.*" | ||
214 | FILES_libgles2-mesa = "${libdir}/libGLESv2.so.*" | ||
215 | FILES_libgl-mesa = "${libdir}/libGL.so.*" | ||
216 | FILES_libglapi = "${libdir}/libglapi.so.*" | ||
217 | FILES_libosmesa = "${libdir}/libOSMesa.so.*" | ||
218 | FILES_libwayland-egl = "${libdir}/libwayland-egl.so.*" | ||
219 | FILES_libxatracker = "${libdir}/libxatracker.so.*" | ||
220 | |||
221 | FILES_${PN}-dev = "${libdir}/pkgconfig/dri.pc ${includedir}/vulkan" | ||
222 | FILES_libegl-mesa-dev = "${libdir}/libEGL.* ${includedir}/EGL ${includedir}/KHR ${libdir}/pkgconfig/egl.pc" | ||
223 | FILES_libgbm-dev = "${libdir}/libgbm.* ${libdir}/pkgconfig/gbm.pc ${includedir}/gbm.h" | ||
224 | FILES_libgl-mesa-dev = "${libdir}/libGL.* ${includedir}/GL ${libdir}/pkgconfig/gl.pc" | ||
225 | FILES_libglapi-dev = "${libdir}/libglapi.*" | ||
226 | FILES_libgles1-mesa-dev = "${libdir}/libGLESv1*.* ${includedir}/GLES ${libdir}/pkgconfig/glesv1*.pc" | ||
227 | FILES_libgles2-mesa-dev = "${libdir}/libGLESv2.* ${includedir}/GLES2 ${libdir}/pkgconfig/glesv2.pc" | ||
228 | FILES_libgles3-mesa-dev = "${includedir}/GLES3" | ||
229 | FILES_libosmesa-dev = "${libdir}/libOSMesa.* ${includedir}/GL/osmesa.h ${libdir}/pkgconfig/osmesa.pc" | ||
230 | FILES_libwayland-egl-dev = "${libdir}/pkgconfig/wayland-egl.pc ${libdir}/libwayland-egl.*" | ||
231 | FILES_libxatracker-dev = "${libdir}/libxatracker.so ${libdir}/libxatracker.la \ | ||
232 | ${includedir}/xa_tracker.h ${includedir}/xa_composite.h ${includedir}/xa_context.h \ | ||
233 | ${libdir}/pkgconfig/xatracker.pc" | ||
diff --git a/meta-intel-extras/recipes/mesa/mesa_18.1.9.bb b/meta-intel-extras/recipes/mesa/mesa_18.1.9.bb deleted file mode 100644 index 86d6a6b..0000000 --- a/meta-intel-extras/recipes/mesa/mesa_18.1.9.bb +++ /dev/null | |||
@@ -1,21 +0,0 @@ | |||
1 | require ${BPN}.inc | ||
2 | |||
3 | SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \ | ||
4 | file://0001-Simplify-wayland-scanner-lookup.patch \ | ||
5 | file://0002-winsys-svga-drm-Include-sys-types.h.patch \ | ||
6 | file://0003-Properly-get-LLVM-version-when-using-LLVM-Git-releas.patch \ | ||
7 | file://0004-Use-Python-3-to-execute-the-scripts.patch \ | ||
8 | file://0005-dri-i965-Add-missing-time.h-include.patch \ | ||
9 | file://0006-use-PKG_CHECK_VAR-for-defining-WAYLAND_PROTOCOLS_DAT.patch \ | ||
10 | " | ||
11 | |||
12 | SRC_URI[md5sum] = "2f8d2098ab478bc3907e42130577b54a" | ||
13 | SRC_URI[sha256sum] = "55f5778d58a710a63d6635f000535768faf7db9e8144dc0f4fd1989f936c1a83" | ||
14 | |||
15 | #because we cannot rely on the fact that all apps will use pkgconfig, | ||
16 | #make eglplatform.h independent of MESA_EGL_NO_X11_HEADER | ||
17 | do_install_append() { | ||
18 | if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then | ||
19 | sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h | ||
20 | fi | ||
21 | } | ||
diff --git a/scripts/manifest.xml b/scripts/manifest.xml index b39cba4..c467714 100644 --- a/scripts/manifest.xml +++ b/scripts/manifest.xml | |||
@@ -50,7 +50,7 @@ | |||
50 | groups="notdefault,external,rpi"/> | 50 | groups="notdefault,external,rpi"/> |
51 | <project name="meta-intel" | 51 | <project name="meta-intel" |
52 | remote="intel" | 52 | remote="intel" |
53 | revision="90af97d23fb2a56187c2fe2a3f4f4190d7cc2605" | 53 | revision="7ea89b9ddcdd3de1629bae1465425c8077c5aa06" |
54 | path="sources/meta-intel" | 54 | path="sources/meta-intel" |
55 | groups="notdefault,external,intel"/> | 55 | groups="notdefault,external,intel"/> |
56 | <project name="meta-tegra" | 56 | <project name="meta-tegra" |