diff options
-rw-r--r-- | recipes/udev/0001-support-multitouch-screens.patch | 28 | ||||
-rw-r--r-- | recipes/udev/udev_182.bbappend | 4 |
2 files changed, 32 insertions, 0 deletions
diff --git a/recipes/udev/0001-support-multitouch-screens.patch b/recipes/udev/0001-support-multitouch-screens.patch new file mode 100644 index 0000000..aacb8e0 --- /dev/null +++ b/recipes/udev/0001-support-multitouch-screens.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From 51a9f15b10357a4ad1d8b2e50ec14031f68c0d48 Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuli Piippo <samuli.piippo@digia.com> | ||
3 | Date: Fri, 12 Apr 2013 09:41:41 +0300 | ||
4 | Subject: [PATCH] support multitouch screens | ||
5 | |||
6 | --- | ||
7 | src/udev-builtin-input_id.c | 5 +++-- | ||
8 | 1 file changed, 3 insertions(+), 2 deletions(-) | ||
9 | |||
10 | diff --git a/src/udev-builtin-input_id.c b/src/udev-builtin-input_id.c | ||
11 | index a062ef7..0c5358e 100644 | ||
12 | --- a/src/udev-builtin-input_id.c | ||
13 | +++ b/src/udev-builtin-input_id.c | ||
14 | @@ -108,8 +108,9 @@ static void test_pointers (struct udev_device *dev, | ||
15 | return; | ||
16 | } | ||
17 | |||
18 | - if (test_bit (EV_ABS, bitmask_ev) && | ||
19 | - test_bit (ABS_X, bitmask_abs) && test_bit (ABS_Y, bitmask_abs)) { | ||
20 | + if (test_bit (EV_ABS, bitmask_ev) && ( | ||
21 | + (test_bit (ABS_X, bitmask_abs) && test_bit (ABS_Y, bitmask_abs)) || | ||
22 | + (test_bit (ABS_MT_POSITION_X, bitmask_abs) && test_bit (ABS_MT_POSITION_Y, bitmask_abs)))) { | ||
23 | if (test_bit (BTN_STYLUS, bitmask_key) || test_bit (BTN_TOOL_PEN, bitmask_key)) | ||
24 | udev_builtin_add_property(dev, test, "ID_INPUT_TABLET", "1"); | ||
25 | else if (test_bit (BTN_TOOL_FINGER, bitmask_key) && !test_bit (BTN_TOOL_PEN, bitmask_key)) | ||
26 | -- | ||
27 | 1.7.10.4 | ||
28 | |||
diff --git a/recipes/udev/udev_182.bbappend b/recipes/udev/udev_182.bbappend new file mode 100644 index 0000000..564d9a1 --- /dev/null +++ b/recipes/udev/udev_182.bbappend | |||
@@ -0,0 +1,4 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}:" | ||
2 | |||
3 | SRC_URI += "file://0001-support-multitouch-screens.patch" | ||
4 | |||