diff options
4 files changed, 61 insertions, 0 deletions
diff --git a/meta-ti-extras/recipes/libgles/ti-sgx-ddk-um/99-fb.rules b/meta-ti-extras/recipes/libgles/ti-sgx-ddk-um/99-fb.rules new file mode 100644 index 0000000..ca5ebc8 --- /dev/null +++ b/meta-ti-extras/recipes/libgles/ti-sgx-ddk-um/99-fb.rules | |||
@@ -0,0 +1 @@ | |||
KERNEL=="fb0", TAG+="systemd" | |||
diff --git a/meta-ti-extras/recipes/libgles/ti-sgx-ddk-um_%.bbappend b/meta-ti-extras/recipes/libgles/ti-sgx-ddk-um_%.bbappend new file mode 100644 index 0000000..15fe3ce --- /dev/null +++ b/meta-ti-extras/recipes/libgles/ti-sgx-ddk-um_%.bbappend | |||
@@ -0,0 +1,38 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" | ||
31 | SRC_URI += "file://99-fb.rules" | ||
32 | |||
33 | do_install_append() { | ||
34 | install -d ${D}${base_libdir}/udev/rules.d | ||
35 | install -m 0644 ${WORKDIR}/99-fb.rules ${D}${base_libdir}/udev/rules.d | ||
36 | } | ||
37 | |||
38 | FILES_${PN} += "${base_libdir}/udev/rules.d/*.rules" | ||
diff --git a/recipes-qt/b2qt-addons/b2qt-launcher/beaglebone/b2qt.service b/recipes-qt/b2qt-addons/b2qt-launcher/beaglebone/b2qt.service new file mode 100644 index 0000000..cdf6480 --- /dev/null +++ b/recipes-qt/b2qt-addons/b2qt-launcher/beaglebone/b2qt.service | |||
@@ -0,0 +1,11 @@ | |||
1 | [Unit] | ||
2 | Description=B2Qt user application | ||
3 | BindsTo=dev-fb0.device | ||
4 | After=dev-fb0.device | ||
5 | ConditionPathExists=/usr/bin/b2qt | ||
6 | |||
7 | [Service] | ||
8 | ExecStart=-/usr/bin/appcontroller /usr/bin/b2qt | ||
9 | |||
10 | [Install] | ||
11 | WantedBy=multi-user.target | ||
diff --git a/recipes-qt/b2qt-addons/b2qt-launcher/beaglebone/qtlauncher.service b/recipes-qt/b2qt-addons/b2qt-launcher/beaglebone/qtlauncher.service new file mode 100644 index 0000000..1094675 --- /dev/null +++ b/recipes-qt/b2qt-addons/b2qt-launcher/beaglebone/qtlauncher.service | |||
@@ -0,0 +1,11 @@ | |||
1 | [Unit] | ||
2 | Description=B2Qt Launcher Demo | ||
3 | BindsTo=dev-fb0.device | ||
4 | After=dev-fb0.device | ||
5 | ConditionPathExists=!/usr/bin/b2qt | ||
6 | |||
7 | [Service] | ||
8 | ExecStart=-/usr/bin/appcontroller /usr/bin/qtlauncher --applications-root /data/user/qt | ||
9 | |||
10 | [Install] | ||
11 | WantedBy=multi-user.target | ||