diff options
-rw-r--r-- | conf/distro/include/beagleboard.conf | 4 | ||||
-rw-r--r-- | conf/distro/include/colibri-vf.conf | 4 | ||||
-rw-r--r-- | conf/distro/include/emulator.conf | 4 | ||||
-rw-r--r-- | conf/distro/include/imx7dsabresd.conf | 4 | ||||
-rw-r--r-- | conf/distro/include/intel-corei7-64.conf | 4 | ||||
-rw-r--r-- | conf/distro/include/nitrogen6x.conf | 2 | ||||
-rw-r--r-- | conf/distro/include/raspberrypi.inc | 4 | ||||
-rw-r--r-- | conf/distro/include/rcar-gen2.inc | 2 | ||||
-rw-r--r-- | conf/distro/include/smarc-samx6i.conf | 2 | ||||
-rw-r--r-- | conf/distro/include/tegra-t18x.conf | 2 | ||||
-rw-r--r-- | recipes-qt/automotive/neptune-ui/neptune.service | 4 | ||||
-rw-r--r-- | recipes/connman/connman_%.bbappend | 24 | ||||
-rw-r--r-- | recipes/connman/files/0001-disable-connman-when-booting-over-nfs.patch | 21 | ||||
-rw-r--r-- | recipes/dbus/dbus/dbus-session.init | 13 | ||||
-rw-r--r-- | recipes/dbus/dbus/dbus-session.service | 13 | ||||
-rw-r--r-- | recipes/dbus/dbus_%.bbappend | 24 |
16 files changed, 108 insertions, 23 deletions
diff --git a/conf/distro/include/beagleboard.conf b/conf/distro/include/beagleboard.conf index bde997c..7f42acf 100644 --- a/conf/distro/include/beagleboard.conf +++ b/conf/distro/include/beagleboard.conf | |||
@@ -43,12 +43,12 @@ PREFERRED_PROVIDER_virtual/libgles2 = "libgles-omap3" | |||
43 | PREFERRED_VERSION_libgles-omap3 = "4.09.00.01" | 43 | PREFERRED_VERSION_libgles-omap3 = "4.09.00.01" |
44 | PREFERRED_VERSION_omap3-sgx-modules = "4.09.00.01" | 44 | PREFERRED_VERSION_omap3-sgx-modules = "4.09.00.01" |
45 | 45 | ||
46 | MACHINE_EXTRA_INSTALL = "\ | 46 | MACHINE_EXTRA_INSTALL += "\ |
47 | libgles-omap3 \ | 47 | libgles-omap3 \ |
48 | libgles-omap3-rawdemos \ | 48 | libgles-omap3-rawdemos \ |
49 | " | 49 | " |
50 | 50 | ||
51 | MACHINE_EXTRA_INSTALL_SDK = "\ | 51 | MACHINE_EXTRA_INSTALL_SDK += "\ |
52 | libgles-omap3-dev \ | 52 | libgles-omap3-dev \ |
53 | " | 53 | " |
54 | 54 | ||
diff --git a/conf/distro/include/colibri-vf.conf b/conf/distro/include/colibri-vf.conf index 845e2ff..1e8a5ac 100644 --- a/conf/distro/include/colibri-vf.conf +++ b/conf/distro/include/colibri-vf.conf | |||
@@ -48,10 +48,10 @@ PREFERRED_PROVIDER_virtual/libgles2 = "opengldummy" | |||
48 | 48 | ||
49 | DISTRO_FEATURES_remove = "webengine" | 49 | DISTRO_FEATURES_remove = "webengine" |
50 | 50 | ||
51 | MACHINE_EXTRA_INSTALL = "\ | 51 | MACHINE_EXTRA_INSTALL += "\ |
52 | opengldummy \ | 52 | opengldummy \ |
53 | " | 53 | " |
54 | 54 | ||
55 | MACHINE_EXTRA_INSTALL_SDK = "\ | 55 | MACHINE_EXTRA_INSTALL_SDK += "\ |
56 | opengldummy-dev \ | 56 | opengldummy-dev \ |
57 | " | 57 | " |
diff --git a/conf/distro/include/emulator.conf b/conf/distro/include/emulator.conf index a8dcc84..cd3a80a 100644 --- a/conf/distro/include/emulator.conf +++ b/conf/distro/include/emulator.conf | |||
@@ -43,10 +43,10 @@ KERNEL_MODULE_AUTOLOAD += "snd-intel8x0 vboxguest vboxsf" | |||
43 | 43 | ||
44 | DISTRO_FEATURES_remove = "webengine opengl" | 44 | DISTRO_FEATURES_remove = "webengine opengl" |
45 | 45 | ||
46 | MACHINE_EXTRA_INSTALL = "\ | 46 | MACHINE_EXTRA_INSTALL += "\ |
47 | mount-vboxsf \ | 47 | mount-vboxsf \ |
48 | " | 48 | " |
49 | MACHINE_EXTRA_INSTALL_SDK = "\ | 49 | MACHINE_EXTRA_INSTALL_SDK += "\ |
50 | qtglesstream-dummy-client-dev \ | 50 | qtglesstream-dummy-client-dev \ |
51 | " | 51 | " |
52 | MACHINE_EXTRA_INSTALL_QT = "\ | 52 | MACHINE_EXTRA_INSTALL_QT = "\ |
diff --git a/conf/distro/include/imx7dsabresd.conf b/conf/distro/include/imx7dsabresd.conf index 66d2b4c..b21e5b1 100644 --- a/conf/distro/include/imx7dsabresd.conf +++ b/conf/distro/include/imx7dsabresd.conf | |||
@@ -50,9 +50,9 @@ BOOTFS_DEPENDS = "u-boot:do_deploy virtual/kernel:do_deploy" | |||
50 | 50 | ||
51 | DISTRO_FEATURES_remove = "webengine" | 51 | DISTRO_FEATURES_remove = "webengine" |
52 | 52 | ||
53 | MACHINE_EXTRA_INSTALL = "\ | 53 | MACHINE_EXTRA_INSTALL += "\ |
54 | " | 54 | " |
55 | 55 | ||
56 | MACHINE_EXTRA_INSTALL_SDK = "\ | 56 | MACHINE_EXTRA_INSTALL_SDK += "\ |
57 | " | 57 | " |
58 | 58 | ||
diff --git a/conf/distro/include/intel-corei7-64.conf b/conf/distro/include/intel-corei7-64.conf index 395a631..d350c0e 100644 --- a/conf/distro/include/intel-corei7-64.conf +++ b/conf/distro/include/intel-corei7-64.conf | |||
@@ -40,13 +40,13 @@ INITRAMFS_IMAGE = "initramfs-basic" | |||
40 | 40 | ||
41 | SYSVINIT_ENABLED_GETTYS = "1" | 41 | SYSVINIT_ENABLED_GETTYS = "1" |
42 | 42 | ||
43 | MACHINE_EXTRA_INSTALL = "\ | 43 | MACHINE_EXTRA_INSTALL += "\ |
44 | wayland \ | 44 | wayland \ |
45 | mesa-megadriver \ | 45 | mesa-megadriver \ |
46 | grub-efi-config \ | 46 | grub-efi-config \ |
47 | " | 47 | " |
48 | 48 | ||
49 | MACHINE_EXTRA_INSTALL_SDK = " \ | 49 | MACHINE_EXTRA_INSTALL_SDK += " \ |
50 | mesa-dev \ | 50 | mesa-dev \ |
51 | " | 51 | " |
52 | 52 | ||
diff --git a/conf/distro/include/nitrogen6x.conf b/conf/distro/include/nitrogen6x.conf index 07647f8..751c264 100644 --- a/conf/distro/include/nitrogen6x.conf +++ b/conf/distro/include/nitrogen6x.conf | |||
@@ -97,7 +97,7 @@ KERNEL_DEVICETREE += "\ | |||
97 | 97 | ||
98 | DISTRO_FEATURES_DEFAULT += "wayland" | 98 | DISTRO_FEATURES_DEFAULT += "wayland" |
99 | 99 | ||
100 | MACHINE_EXTRA_INSTALL = "\ | 100 | MACHINE_EXTRA_INSTALL += "\ |
101 | bcm4330-nvram-config \ | 101 | bcm4330-nvram-config \ |
102 | " | 102 | " |
103 | 103 | ||
diff --git a/conf/distro/include/raspberrypi.inc b/conf/distro/include/raspberrypi.inc index 802a673..fb56934 100644 --- a/conf/distro/include/raspberrypi.inc +++ b/conf/distro/include/raspberrypi.inc | |||
@@ -36,11 +36,11 @@ BOOTFS_CONTENT = "\ | |||
36 | 36 | ||
37 | BOOTFS_DEPENDS = "bcm2835-bootfiles:do_deploy virtual/kernel:do_deploy" | 37 | BOOTFS_DEPENDS = "bcm2835-bootfiles:do_deploy virtual/kernel:do_deploy" |
38 | 38 | ||
39 | MACHINE_EXTRA_INSTALL_SDK = " \ | 39 | MACHINE_EXTRA_INSTALL_SDK += " \ |
40 | userland-dev \ | 40 | userland-dev \ |
41 | " | 41 | " |
42 | 42 | ||
43 | MACHINE_EXTRA_INSTALL = "\ | 43 | MACHINE_EXTRA_INSTALL += "\ |
44 | userland \ | 44 | userland \ |
45 | omxplayer \ | 45 | omxplayer \ |
46 | " | 46 | " |
diff --git a/conf/distro/include/rcar-gen2.inc b/conf/distro/include/rcar-gen2.inc index 490bc0f..9a33319 100644 --- a/conf/distro/include/rcar-gen2.inc +++ b/conf/distro/include/rcar-gen2.inc | |||
@@ -106,7 +106,7 @@ RENESAS_WORKAROUNGS = " \ | |||
106 | libdrm-tests \ | 106 | libdrm-tests \ |
107 | " | 107 | " |
108 | 108 | ||
109 | MACHINE_EXTRA_INSTALL = " \ | 109 | MACHINE_EXTRA_INSTALL += " \ |
110 | kernel-devicetree \ | 110 | kernel-devicetree \ |
111 | libdrm-kms \ | 111 | libdrm-kms \ |
112 | libegl \ | 112 | libegl \ |
diff --git a/conf/distro/include/smarc-samx6i.conf b/conf/distro/include/smarc-samx6i.conf index 5695b1c..1089f83 100644 --- a/conf/distro/include/smarc-samx6i.conf +++ b/conf/distro/include/smarc-samx6i.conf | |||
@@ -36,7 +36,7 @@ KERNEL_IMAGETYPE = "uImage" | |||
36 | 36 | ||
37 | BOOTFS_CONTENT = " " | 37 | BOOTFS_CONTENT = " " |
38 | 38 | ||
39 | MACHINE_EXTRA_INSTALL = "\ | 39 | MACHINE_EXTRA_INSTALL += "\ |
40 | kernel-devicetree \ | 40 | kernel-devicetree \ |
41 | " | 41 | " |
42 | 42 | ||
diff --git a/conf/distro/include/tegra-t18x.conf b/conf/distro/include/tegra-t18x.conf index f317ca9..34d23a9 100644 --- a/conf/distro/include/tegra-t18x.conf +++ b/conf/distro/include/tegra-t18x.conf | |||
@@ -29,7 +29,7 @@ KERN_DIR ?= '${@os.path.normpath("${TOPDIR}/../sources/vibrante-t186/kernel")}' | |||
29 | PLATFORM_TOPDIR ?= '${@os.path.normpath("${TOPDIR}/../sources/vibrante-t186")}' | 29 | PLATFORM_TOPDIR ?= '${@os.path.normpath("${TOPDIR}/../sources/vibrante-t186")}' |
30 | NVLAYER_DIR ?= "${TOPDIR}/../sources/nvidia-layer" | 30 | NVLAYER_DIR ?= "${TOPDIR}/../sources/nvidia-layer" |
31 | 31 | ||
32 | MACHINE_EXTRA_INSTALL = "\ | 32 | MACHINE_EXTRA_INSTALL += "\ |
33 | tegra-firmware-fecs \ | 33 | tegra-firmware-fecs \ |
34 | tegra-firmware-gmicrocode \ | 34 | tegra-firmware-gmicrocode \ |
35 | tegra-firmware-gpccs \ | 35 | tegra-firmware-gpccs \ |
diff --git a/recipes-qt/automotive/neptune-ui/neptune.service b/recipes-qt/automotive/neptune-ui/neptune.service index 32e3243..e9f3793 100644 --- a/recipes-qt/automotive/neptune-ui/neptune.service +++ b/recipes-qt/automotive/neptune-ui/neptune.service | |||
@@ -1,9 +1,9 @@ | |||
1 | [Unit] | 1 | [Unit] |
2 | Description=Neptune | 2 | Description=Neptune |
3 | After=systemd-user-sessions.service | 3 | After=dbus.service dbus-session.service systemd-user-sessions.service |
4 | 4 | ||
5 | [Service] | 5 | [Service] |
6 | ExecStart=/usr/bin/appcontroller /usr/bin/appman -r -c /opt/am/config.yaml -c am-config.yaml --dbus none Main.qml | 6 | ExecStart=/usr/bin/appcontroller /usr/bin/appman -r -c /opt/am/config.yaml --dbus session -c am-config.yaml Main.qml |
7 | Restart=on-failure | 7 | Restart=on-failure |
8 | WorkingDirectory=/opt/neptune | 8 | WorkingDirectory=/opt/neptune |
9 | 9 | ||
diff --git a/recipes/connman/connman_%.bbappend b/recipes/connman/connman_%.bbappend new file mode 100644 index 0000000..0b03755 --- /dev/null +++ b/recipes/connman/connman_%.bbappend | |||
@@ -0,0 +1,24 @@ | |||
1 | ############################################################################## | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: http://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:COMM$ | ||
9 | ## | ||
10 | ## Commercial License Usage | ||
11 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
12 | ## accordance with the commercial license agreement provided with the | ||
13 | ## Software or, alternatively, in accordance with the terms contained in | ||
14 | ## a written agreement between you and The Qt Company. For licensing terms | ||
15 | ## and conditions see http://www.qt.io/terms-conditions. For further | ||
16 | ## information use the contact form at http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## $QT_END_LICENSE$ | ||
19 | ## | ||
20 | ############################################################################## | ||
21 | |||
22 | FILESEXTRAPATHS_prepend := "${THISDIR}/files:" | ||
23 | |||
24 | SRC_URI += "file://0001-disable-connman-when-booting-over-nfs.patch" | ||
diff --git a/recipes/connman/files/0001-disable-connman-when-booting-over-nfs.patch b/recipes/connman/files/0001-disable-connman-when-booting-over-nfs.patch new file mode 100644 index 0000000..f893746 --- /dev/null +++ b/recipes/connman/files/0001-disable-connman-when-booting-over-nfs.patch | |||
@@ -0,0 +1,21 @@ | |||
1 | From df70770f33280a915abb413678088a078d82341a Mon Sep 17 00:00:00 2001 | ||
2 | From: Mikko Gronoff <mikko.gronoff@qt.io> | ||
3 | Date: Tue, 20 Sep 2016 11:02:50 +0300 | ||
4 | Subject: [PATCH] Disable connman when booting over NFS | ||
5 | |||
6 | --- | ||
7 | src/connman.service.in | 1 + | ||
8 | 1 file changed, 1 insertion(+) | ||
9 | |||
10 | diff --git a/src/connman.service.in b/src/connman.service.in | ||
11 | index 09dfec9..4132cf7 100644 | ||
12 | --- a/src/connman.service.in | ||
13 | +++ b/src/connman.service.in | ||
14 | @@ -6,6 +6,7 @@ RequiresMountsFor=@localstatedir@/lib/connman | ||
15 | After=dbus.service network-pre.target systemd-sysusers.service | ||
16 | Before=network.target multi-user.target shutdown.target | ||
17 | Wants=network.target | ||
18 | +ConditionKernelCommandLine=!root=/dev/nfs | ||
19 | |||
20 | [Service] | ||
21 | Type=dbus | ||
diff --git a/recipes/dbus/dbus/dbus-session.init b/recipes/dbus/dbus/dbus-session.init index 11a6757..0690511 100644 --- a/recipes/dbus/dbus/dbus-session.init +++ b/recipes/dbus/dbus/dbus-session.init | |||
@@ -1,4 +1,4 @@ | |||
1 | #! /bin/sh | 1 | #!/bin/sh |
2 | ### BEGIN INIT INFO | 2 | ### BEGIN INIT INFO |
3 | # Provides: dbus | 3 | # Provides: dbus |
4 | # Required-Start: $remote_fs $syslog | 4 | # Required-Start: $remote_fs $syslog |
@@ -17,13 +17,16 @@ | |||
17 | # set -e | 17 | # set -e |
18 | 18 | ||
19 | # Source function library. | 19 | # Source function library. |
20 | . /etc/init.d/functions | 20 | #. /etc/init.d/functions |
21 | 21 | ||
22 | DAEMON=@bindir@/dbus-launch | 22 | DAEMON=@bindir@/dbus-launch |
23 | NAME=dbus-session | 23 | NAME=dbus-session |
24 | ADDRESSFILE=/var/run/dbus/session_bus_address | 24 | ADDRESSFILE=/var/run/dbus/session_bus_address |
25 | UUIDDIR=/var/lib/dbus | 25 | UUIDDIR=/var/lib/dbus |
26 | DESC="session message bus" | 26 | DESC="session message bus" |
27 | APPCONTROLLERPATH="/tmp/b2qt/appcontroller.conf.d" | ||
28 | APPCONTROLLERADDRESSFILE="session_bus_address" | ||
29 | |||
27 | 30 | ||
28 | test -x $DAEMON || exit 0 | 31 | test -x $DAEMON || exit 0 |
29 | 32 | ||
@@ -38,12 +41,18 @@ if [ -e $ADDRESSFILE ]; then | |||
38 | . $ADDRESSFILE | 41 | . $ADDRESSFILE |
39 | fi | 42 | fi |
40 | 43 | ||
44 | if [ ! -d $APPCONTROLLERPATH ]; then | ||
45 | mkdir -p $APPCONTROLLERPATH | ||
46 | fi | ||
47 | |||
41 | test "$ENABLED" != "0" || exit 0 | 48 | test "$ENABLED" != "0" || exit 0 |
42 | 49 | ||
43 | start_it_up() | 50 | start_it_up() |
44 | { | 51 | { |
45 | echo -n "Starting $DESC: " | 52 | echo -n "Starting $DESC: " |
46 | $DAEMON --auto-syntax > $ADDRESSFILE | 53 | $DAEMON --auto-syntax > $ADDRESSFILE |
54 | ADDR=`cat $ADDRESSFILE|grep -i DBUS_SESSION_BUS_ADDRESS=` | ||
55 | echo "env=${ADDR%?}" |tr -d \' > ${APPCONTROLLERPATH}/${APPCONTROLLERADDRESSFILE} | ||
47 | echo "$NAME." | 56 | echo "$NAME." |
48 | } | 57 | } |
49 | 58 | ||
diff --git a/recipes/dbus/dbus/dbus-session.service b/recipes/dbus/dbus/dbus-session.service new file mode 100644 index 0000000..dbd6fcd --- /dev/null +++ b/recipes/dbus/dbus/dbus-session.service | |||
@@ -0,0 +1,13 @@ | |||
1 | [Unit] | ||
2 | Description=D-BUS Session Message Bus. | ||
3 | After=dbus.service | ||
4 | |||
5 | [Service] | ||
6 | Type=forking | ||
7 | ExecStart=/usr/bin/dbus-session.init start | ||
8 | ExecStop=/usr/bin/dbus-session.init stop | ||
9 | Environment=HOME=/home/root | ||
10 | |||
11 | [Install] | ||
12 | WantedBy=multi-user.target | ||
13 | |||
diff --git a/recipes/dbus/dbus_%.bbappend b/recipes/dbus/dbus_%.bbappend index b7fff89..f9f1345 100644 --- a/recipes/dbus/dbus_%.bbappend +++ b/recipes/dbus/dbus_%.bbappend | |||
@@ -27,28 +27,46 @@ | |||
27 | ## | 27 | ## |
28 | ############################################################################ | 28 | ############################################################################ |
29 | 29 | ||
30 | inherit systemd | ||
31 | |||
30 | FILESEXTRAPATHS_append := ":${THISDIR}/${PN}" | 32 | FILESEXTRAPATHS_append := ":${THISDIR}/${PN}" |
31 | SRC_URI += " \ | 33 | SRC_URI += " \ |
32 | file://dbus-session.init \ | 34 | file://dbus-session.init \ |
35 | file://dbus-session.service \ | ||
33 | file://dbus-session-address \ | 36 | file://dbus-session-address \ |
34 | " | 37 | " |
35 | |||
36 | INITSCRIPT_PACKAGES = "${PN} ${PN}-session-init" | 38 | INITSCRIPT_PACKAGES = "${PN} ${PN}-session-init" |
37 | INITSCRIPT_NAME_${PN}-session-init = "dbus-session" | 39 | INITSCRIPT_NAME_${PN}-session-init = "dbus-session" |
38 | INITSCRIPT_PARAMS_${PN}-session-init = "start 20 5 3 2 . stop 10 0 1 6 ." | 40 | INITSCRIPT_PARAMS_${PN}-session-init = "start 20 5 3 2 . stop 10 0 1 6 ." |
39 | 41 | ||
40 | PACKAGES =+ "${PN}-session-init" | 42 | PACKAGES =+ "${PN}-session-init" |
43 | SYSTEMD_PACKAGES =+ "${PN}-session-init" | ||
44 | |||
41 | FILES_${PN}-session-init = " \ | 45 | FILES_${PN}-session-init = " \ |
42 | ${sysconfdir}/init.d/dbus-session \ | 46 | ${sysconfdir}/init.d/dbus-session \ |
43 | ${sysconfdir}/profile.d/dbus-session-address \ | 47 | ${sysconfdir}/profile.d/dbus-session-address \ |
48 | ${bindir}/dbus-session.init \ | ||
49 | ${systemd_unitdir}/system/dbus-session.service \ | ||
44 | " | 50 | " |
45 | 51 | ||
46 | do_install_append_class-target() { | 52 | do_install_append_class-target() { |
53 | sed 's:@bindir@:${bindir}:' < ${WORKDIR}/dbus-session.init >${WORKDIR}/dbus-session.init | ||
54 | |||
47 | if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then | 55 | if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then |
48 | install -d ${D}${sysconfdir}/init.d | 56 | install -d ${D}${sysconfdir}/init.d |
49 | sed 's:@bindir@:${bindir}:' < ${WORKDIR}/dbus-session.init >${WORKDIR}/dbus-session.init.sh | 57 | install -m 0755 ${WORKDIR}/dbus-session.init ${D}${sysconfdir}/init.d/dbus-session |
50 | install -m 0755 ${WORKDIR}/dbus-session.init.sh ${D}${sysconfdir}/init.d/dbus-session | ||
51 | fi | 58 | fi |
59 | |||
60 | if ${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then | ||
61 | install -m 0755 -d ${D}${bindir}/ | ||
62 | install -m 0755 ${WORKDIR}/dbus-session.init ${D}${bindir}/ | ||
63 | |||
64 | install -m 0755 -d ${D}${systemd_unitdir}/system | ||
65 | install -m 0644 ${WORKDIR}/dbus-session.service ${D}${systemd_unitdir}/system/ | ||
66 | fi | ||
67 | |||
52 | install -d ${D}${sysconfdir}/profile.d | 68 | install -d ${D}${sysconfdir}/profile.d |
53 | install -m 0755 ${WORKDIR}/dbus-session-address ${D}${sysconfdir}/profile.d/ | 69 | install -m 0755 ${WORKDIR}/dbus-session-address ${D}${sysconfdir}/profile.d/ |
54 | } | 70 | } |
71 | |||
72 | SYSTEMD_SERVICE_${PN}-session-init = "dbus-session.service" | ||