summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/consistent_timestamps.bbclass27
-rw-r--r--recipes-qt/images/b2qt-automotive-qt5-image.bb1
-rw-r--r--recipes-qt/images/b2qt-embedded-qt5-image.bb1
3 files changed, 29 insertions, 0 deletions
diff --git a/classes/consistent_timestamps.bbclass b/classes/consistent_timestamps.bbclass
new file mode 100644
index 0000000..e82f77c
--- /dev/null
+++ b/classes/consistent_timestamps.bbclass
@@ -0,0 +1,27 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22update_file_timestaps() {
23 # Update file timestamp to 0 seconds since Epoch time.
24 TZ=UTC find ${IMAGE_ROOTFS} -exec touch -h -m -t '197001010000' {} \;
25}
26
27ROOTFS_POSTINSTALL_COMMAND += "update_file_timestaps; "
diff --git a/recipes-qt/images/b2qt-automotive-qt5-image.bb b/recipes-qt/images/b2qt-automotive-qt5-image.bb
index 004c2e8..bbcb82d 100644
--- a/recipes-qt/images/b2qt-automotive-qt5-image.bb
+++ b/recipes-qt/images/b2qt-automotive-qt5-image.bb
@@ -36,6 +36,7 @@ IMAGE_FEATURES += "\
36 36
37inherit core-image 37inherit core-image
38inherit bootfs-image 38inherit bootfs-image
39inherit consistent_timestamps
39 40
40MACHINE_EXTRA_INSTALL_QT ?= "" 41MACHINE_EXTRA_INSTALL_QT ?= ""
41 42
diff --git a/recipes-qt/images/b2qt-embedded-qt5-image.bb b/recipes-qt/images/b2qt-embedded-qt5-image.bb
index 2909e38..6f82a8b 100644
--- a/recipes-qt/images/b2qt-embedded-qt5-image.bb
+++ b/recipes-qt/images/b2qt-embedded-qt5-image.bb
@@ -36,6 +36,7 @@ IMAGE_FEATURES += "\
36 36
37inherit core-image 37inherit core-image
38inherit bootfs-image 38inherit bootfs-image
39inherit consistent_timestamps
39 40
40MACHINE_EXTRA_INSTALL_QT ?= "" 41MACHINE_EXTRA_INSTALL_QT ?= ""
41 42