diff options
-rw-r--r-- | classes/qbsp.bbclass | 2 | ||||
-rw-r--r-- | recipes-qt/meta/meta-b2qt-automotive-qbsp.bb | 2 | ||||
-rw-r--r-- | recipes-qt/meta/meta-b2qt-embedded-qbsp.bb | 2 |
3 files changed, 3 insertions, 3 deletions
diff --git a/classes/qbsp.bbclass b/classes/qbsp.bbclass index b3f4521..db70fc9 100644 --- a/classes/qbsp.bbclass +++ b/classes/qbsp.bbclass | |||
@@ -57,7 +57,7 @@ QBSP_LICENSE_NAME ?= "" | |||
57 | QBSP_LICENSE_FILE_imx = "NXP-EULA" | 57 | QBSP_LICENSE_FILE_imx = "NXP-EULA" |
58 | QBSP_LICENSE_NAME_imx = "NXP Semiconductors Software License Agreement" | 58 | QBSP_LICENSE_NAME_imx = "NXP Semiconductors Software License Agreement" |
59 | 59 | ||
60 | VERSION_AUTO_INCREMENT = "-0-${DATETIME}" | 60 | VERSION_AUTO_INCREMENT = "-${DATETIME}" |
61 | VERSION_AUTO_INCREMENT[vardepsexclude] = "DATETIME" | 61 | VERSION_AUTO_INCREMENT[vardepsexclude] = "DATETIME" |
62 | 62 | ||
63 | DEPLOY_CONF_NAME ?= "${MACHINE}" | 63 | DEPLOY_CONF_NAME ?= "${MACHINE}" |
diff --git a/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb b/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb index a9da456..9b5c615 100644 --- a/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb +++ b/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb | |||
@@ -38,7 +38,7 @@ S = "${WORKDIR}" | |||
38 | 38 | ||
39 | inherit qbsp | 39 | inherit qbsp |
40 | 40 | ||
41 | PV := "${@d.getVar('PV', True)[0:5]}" | 41 | PV := "${@d.getVar('PV', True).split('+')[0]}" |
42 | 42 | ||
43 | QBSP_NAME = "Qt Automotive" | 43 | QBSP_NAME = "Qt Automotive" |
44 | QBSP_MACHINE = "${@d.getVar('MACHINE', True).replace('-','')}" | 44 | QBSP_MACHINE = "${@d.getVar('MACHINE', True).replace('-','')}" |
diff --git a/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb b/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb index d6def0f..c531633 100644 --- a/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb +++ b/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb | |||
@@ -38,7 +38,7 @@ S = "${WORKDIR}" | |||
38 | 38 | ||
39 | inherit qbsp | 39 | inherit qbsp |
40 | 40 | ||
41 | PV := "${@d.getVar('PV', True)[0:5]}" | 41 | PV := "${@d.getVar('PV', True).split('+')[0]}" |
42 | 42 | ||
43 | VERSION_SHORT = "${@d.getVar('PV', True).replace('.','')}" | 43 | VERSION_SHORT = "${@d.getVar('PV', True).replace('.','')}" |
44 | QBSP_NAME = "Boot to Qt" | 44 | QBSP_NAME = "Boot to Qt" |