diff options
5 files changed, 97 insertions, 1 deletions
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb index 2af00da..83b075b 100644 --- a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb +++ b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb | |||
@@ -75,3 +75,7 @@ RDEPENDS_${PN} += " \ | |||
75 | qtwebchannel-dev \ | 75 | qtwebchannel-dev \ |
76 | qtxmlpatterns-dev \ | 76 | qtxmlpatterns-dev \ |
77 | " | 77 | " |
78 | |||
79 | RDEPENDS_${PN} += "\ | ||
80 | ${@ "qtquicktimeline-dev" if (d.getVar("QT_INTERNAL_BUILD")) else "" } \ | ||
81 | " | ||
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb index a79d596..1cdf831 100644 --- a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb +++ b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb | |||
@@ -77,3 +77,7 @@ RDEPENDS_${PN} += " \ | |||
77 | qtxmlpatterns \ | 77 | qtxmlpatterns \ |
78 | qtvirtualkeyboard \ | 78 | qtvirtualkeyboard \ |
79 | " | 79 | " |
80 | |||
81 | RDEPENDS_${PN} += "\ | ||
82 | ${@ "qtquicktimeline qmlpreview" if (d.getVar("QT_INTERNAL_BUILD")) else "" } \ | ||
83 | " | ||
diff --git a/meta-boot2qt/classes/internal-build.bbclass b/meta-boot2qt/classes/internal-build.bbclass index 64c07bf..d842dcb 100644 --- a/meta-boot2qt/classes/internal-build.bbclass +++ b/meta-boot2qt/classes/internal-build.bbclass | |||
@@ -34,7 +34,7 @@ python enable_internal_build () { | |||
34 | except: | 34 | except: |
35 | return | 35 | return |
36 | 36 | ||
37 | e.data.setVar('ENABLE_QTQUICKCOMPILER', "1") | 37 | e.data.setVar('QT_INTERNAL_BUILD', "1") |
38 | e.data.prependVar('SSTATE_MIRRORS', "file://.* http://yocto-cache.intra.qt.io/sstate-caches/${DISTRO_CODENAME}/PATH") | 38 | e.data.prependVar('SSTATE_MIRRORS', "file://.* http://yocto-cache.intra.qt.io/sstate-caches/${DISTRO_CODENAME}/PATH") |
39 | e.data.prependVar('PREMIRRORS', "\ | 39 | e.data.prependVar('PREMIRRORS', "\ |
40 | ftp://.*/.* http://yocto-cache.intra.qt.io/sources/ \n \ | 40 | ftp://.*/.* http://yocto-cache.intra.qt.io/sources/ \n \ |
diff --git a/meta-boot2qt/recipes-qt/qt5/qmlpreview_git.bb b/meta-boot2qt/recipes-qt/qt5/qmlpreview_git.bb new file mode 100644 index 0000000..d22e1d0 --- /dev/null +++ b/meta-boot2qt/recipes-qt/qt5/qmlpreview_git.bb | |||
@@ -0,0 +1,44 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2018 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | DESCRIPTION = "QML Live Preview debug service" | ||
31 | LICENSE = "The-Qt-Company-DCLA-2.1" | ||
32 | LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b" | ||
33 | |||
34 | inherit qt5-module | ||
35 | require recipes-qt/qt5/qt5-git.inc | ||
36 | |||
37 | SRCREV = "6ae4a9da17e53bbb7c1729c24f58141a33bbcb9b" | ||
38 | BRANCH = "master" | ||
39 | |||
40 | SRC_URI = " \ | ||
41 | git://codereview.qt-project.org/qt/tqtc-qmlpreview;branch=${BRANCH};protocol=ssh \ | ||
42 | " | ||
43 | |||
44 | DEPENDS = "qtbase qtdeclarative" | ||
diff --git a/meta-boot2qt/recipes-qt/qt5/qtquicktimeline_git.bb b/meta-boot2qt/recipes-qt/qt5/qtquicktimeline_git.bb new file mode 100644 index 0000000..9e6b051 --- /dev/null +++ b/meta-boot2qt/recipes-qt/qt5/qtquicktimeline_git.bb | |||
@@ -0,0 +1,44 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2018 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | DESCRIPTION = "Qt Quick Timeline" | ||
31 | LICENSE = "The-Qt-Company-DCLA-2.1" | ||
32 | LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b" | ||
33 | |||
34 | inherit qt5-module | ||
35 | require recipes-qt/qt5/qt5-git.inc | ||
36 | |||
37 | SRCREV = "7ee1adca536b422623de1fe8da44135aeee6e9cf" | ||
38 | BRANCH = "dev" | ||
39 | |||
40 | SRC_URI = " \ | ||
41 | git://codereview.qt-project.org/qt/tqtc-qtquicktimeline;branch=${BRANCH};protocol=ssh \ | ||
42 | " | ||
43 | |||
44 | DEPENDS = "qtbase qtdeclarative" | ||