summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/systemd/systemd_%.bbappend9
1 files changed, 9 insertions, 0 deletions
diff --git a/recipes/systemd/systemd_%.bbappend b/recipes/systemd/systemd_%.bbappend
index 1ba27fe..96b8910 100644
--- a/recipes/systemd/systemd_%.bbappend
+++ b/recipes/systemd/systemd_%.bbappend
@@ -34,6 +34,15 @@ SRC_URI += " \
34 34
35PACKAGECONFIG_append = " networkd" 35PACKAGECONFIG_append = " networkd"
36 36
37# By default sytemd uses it's build time as epoch. This causes problems when
38# using yocto cache since systemd build time might be more than day older than
39# the actual image build time. If that kind of image is booted with a device
40# that does not have backup battery for RTC, the first fsck interprets successful
41# result as failure because last mount time is in the future. This can be worked
42# around by setting TIME_EPOCH to 0, which causes fsck to detect the system time as
43# insane and ignore the mount time error.
44EXTRA_OECONF_append = " --with-time-epoch=0"
45
37do_install_append() { 46do_install_append() {
38 # remove login from tty1 47 # remove login from tty1
39 rm -f ${D}${sysconfdir}/systemd/system/getty.target.wants/getty@tty1.service 48 rm -f ${D}${sysconfdir}/systemd/system/getty.target.wants/getty@tty1.service