diff options
Diffstat (limited to 'meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend')
-rw-r--r-- | meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend | 64 |
1 files changed, 64 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend b/meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend new file mode 100644 index 0000000..e7c7adf --- /dev/null +++ b/meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend | |||
@@ -0,0 +1,64 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | PACKAGECONFIG_GL = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 eglfs', 'no-opengl', d)}" | ||
31 | |||
32 | # emulator is exception due to qtglesstream | ||
33 | PACKAGECONFIG_GL_emulator = "gles2 eglfs" | ||
34 | |||
35 | PACKAGECONFIG += " \ | ||
36 | accessibility \ | ||
37 | cups \ | ||
38 | fontconfig \ | ||
39 | freetype \ | ||
40 | gif \ | ||
41 | glib \ | ||
42 | ico \ | ||
43 | icu \ | ||
44 | libinput \ | ||
45 | linuxfb \ | ||
46 | sql-sqlite \ | ||
47 | tslib \ | ||
48 | xkbcommon-evdev \ | ||
49 | " | ||
50 | |||
51 | PACKAGECONFIG_remove = "tests" | ||
52 | |||
53 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
54 | |||
55 | SRC_URI += " \ | ||
56 | file://oe-device-extra.pri \ | ||
57 | file://0001-Add-win32-g-oe-mkspec-that-uses-the-OE_-environment.patch \ | ||
58 | " | ||
59 | do_configure_prepend() { | ||
60 | install -m 0644 ${WORKDIR}/oe-device-extra.pri ${S}/mkspecs | ||
61 | } | ||
62 | |||
63 | # make other libgbm providers possible | ||
64 | PACKAGECONFIG[gbm] = "-gbm,-no-gbm,virtual/libgbm" | ||