diff options
Diffstat (limited to 'meta-boot2qt-distro')
3 files changed, 18 insertions, 75 deletions
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtbase/0001-Add-win32-g-oe-mkspec-that-uses-the-OE_-environment.patch b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/0001-Add-win32-g-oe-mkspec-that-uses-the-OE_-environment.patch index ac4fe40..7b13555 100644 --- a/meta-boot2qt-distro/recipes-qt/qt5/qtbase/0001-Add-win32-g-oe-mkspec-that-uses-the-OE_-environment.patch +++ b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/0001-Add-win32-g-oe-mkspec-that-uses-the-OE_-environment.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 0386cb5f9a46e56a0a94f2a92e87ed52d41cf4ea Mon Sep 17 00:00:00 2001 | 1 | From 8d720921ddda76fcf77c0f7ebc5ac0b873ab1595 Mon Sep 17 00:00:00 2001 |
2 | From: David Schulz <david.schulz@theqtcompany.com> | 2 | From: David Schulz <david.schulz@theqtcompany.com> |
3 | Date: Fri, 3 Jul 2015 16:06:59 +0200 | 3 | Date: Fri, 3 Jul 2015 16:06:59 +0200 |
4 | Subject: [PATCH] Add win32-g++-oe mkspec that uses the OE_ environment. | 4 | Subject: [PATCH] Add win32-g++-oe mkspec that uses the OE_ environment. |
@@ -8,108 +8,52 @@ Upstream-Status: Inappropriate [embedded specific] | |||
8 | 8 | ||
9 | Change-Id: Ic60b32f88ee6a792b0d8938e40e2d6cb19fb93aa | 9 | Change-Id: Ic60b32f88ee6a792b0d8938e40e2d6cb19fb93aa |
10 | --- | 10 | --- |
11 | mkspecs/win32-g++-oe/qmake.conf | 87 ++++++++++++++++++++++++++++++++++++ | 11 | mkspecs/win32-g++-oe/qmake.conf | 31 ++++++++++++++++++++ |
12 | mkspecs/win32-g++-oe/qplatformdefs.h | 42 +++++++++++++++++ | 12 | mkspecs/win32-g++-oe/qplatformdefs.h | 42 ++++++++++++++++++++++++++++ |
13 | 2 files changed, 129 insertions(+) | 13 | 2 files changed, 73 insertions(+) |
14 | create mode 100644 mkspecs/win32-g++-oe/qmake.conf | 14 | create mode 100644 mkspecs/win32-g++-oe/qmake.conf |
15 | create mode 100644 mkspecs/win32-g++-oe/qplatformdefs.h | 15 | create mode 100644 mkspecs/win32-g++-oe/qplatformdefs.h |
16 | 16 | ||
17 | diff --git a/mkspecs/win32-g++-oe/qmake.conf b/mkspecs/win32-g++-oe/qmake.conf | 17 | diff --git a/mkspecs/win32-g++-oe/qmake.conf b/mkspecs/win32-g++-oe/qmake.conf |
18 | new file mode 100644 | 18 | new file mode 100644 |
19 | index 0000000..76eefe5 | 19 | index 0000000000..ab759e2093 |
20 | --- /dev/null | 20 | --- /dev/null |
21 | +++ b/mkspecs/win32-g++-oe/qmake.conf | 21 | +++ b/mkspecs/win32-g++-oe/qmake.conf |
22 | @@ -0,0 +1,87 @@ | 22 | @@ -0,0 +1,31 @@ |
23 | +# | 23 | +# |
24 | +# qmake configuration for win32-g++ | 24 | +# qmake configuration for win32-g++ |
25 | +# | 25 | +# |
26 | +# Written for MinGW / gcc 4.6 or higher | 26 | +# Written for MinGW-w64 / gcc 5.3 or higher |
27 | +# | 27 | +# |
28 | +# Cross compile example for i686-w64-mingw32-g++: | 28 | +# Cross compile example for i686-w64-mingw32-g++: |
29 | +# configure -xplatform win32-g++ -device-option CROSS_COMPILE=i686-w64-mingw32- | 29 | +# configure -xplatform win32-g++ -device-option CROSS_COMPILE=i686-w64-mingw32- |
30 | +# | 30 | +# |
31 | + | 31 | + |
32 | +load(device_config) | 32 | +include(../common/g++-win32.conf) |
33 | +include(../common/g++-base.conf) | ||
34 | + | 33 | + |
35 | +MAKEFILE_GENERATOR = MINGW | 34 | +# modifications to g++-win32.conf |
36 | +QMAKE_PLATFORM = win32 mingw | ||
37 | +CONFIG += debug_and_release debug_and_release_target precompile_header | ||
38 | +DEFINES += UNICODE | ||
39 | +QMAKE_COMPILER_DEFINES += __GNUC__ WIN32 | ||
40 | + | ||
41 | +QMAKE_EXT_OBJ = .o | ||
42 | +QMAKE_EXT_RES = _res.o | ||
43 | + | ||
44 | +QMAKE_COMPILER = $$(OE_QMAKE_COMPILER) | ||
45 | + | 35 | + |
46 | +QMAKE_CC = $$(OE_QMAKE_CC) | 36 | +QMAKE_CC = $$(OE_QMAKE_CC) |
47 | +QMAKE_LEX = flex | ||
48 | +QMAKE_LEXFLAGS = | ||
49 | +QMAKE_YACC = bison -y | ||
50 | +QMAKE_YACCFLAGS = -d | ||
51 | +QMAKE_CFLAGS += -fno-keep-inline-dllexport $$(OE_QMAKE_CFLAGS) | 37 | +QMAKE_CFLAGS += -fno-keep-inline-dllexport $$(OE_QMAKE_CFLAGS) |
52 | +QMAKE_CFLAGS_WARN_ON += -Wextra | 38 | +QMAKE_CFLAGS_WARN_ON += -Wextra |
53 | +QMAKE_CFLAGS_SSE2 += -mstackrealign | ||
54 | + | 39 | + |
55 | +QMAKE_CXX = $$(OE_QMAKE_CXX) | 40 | +QMAKE_CXX = $$(OE_QMAKE_CXX) |
56 | +QMAKE_CXXFLAGS_THREAD = $$QMAKE_CFLAGS_THREAD | 41 | +QMAKE_CXXFLAGS += -fno-keep-inline-dllexport |
57 | +QMAKE_CXXFLAGS_RTTI_ON = -frtti | 42 | +QMAKE_CXXFLAGS_WARN_ON = $$QMAKE_CFLAGS_WARN_ON |
58 | +QMAKE_CXXFLAGS_RTTI_OFF = -fno-rtti | ||
59 | +QMAKE_CXXFLAGS_EXCEPTIONS_ON = -fexceptions -mthreads | ||
60 | + | ||
61 | +QMAKE_INCDIR = | ||
62 | + | ||
63 | +QMAKE_RUN_CC = $(CC) -c $(CFLAGS) $(INCPATH) -o $obj $src | ||
64 | +QMAKE_RUN_CC_IMP = $(CC) -c $(CFLAGS) $(INCPATH) -o $@ $< | ||
65 | +QMAKE_RUN_CXX = $(CXX) -c $(CXXFLAGS) $(INCPATH) -o $obj $src | ||
66 | +QMAKE_RUN_CXX_IMP = $(CXX) -c $(CXXFLAGS) $(INCPATH) -o $@ $< | ||
67 | + | 43 | + |
68 | +QMAKE_LINK = $$(OE_QMAKE_LINK) | 44 | +QMAKE_LINK = $$(OE_QMAKE_LINK) |
69 | +QMAKE_LINK_C = $$(OE_QMAKE_LINK) | 45 | +QMAKE_LINK_C = $$(OE_QMAKE_CC) |
70 | +QMAKE_LFLAGS = $$(OE_QMAKE_LDFLAGS) | 46 | +QMAKE_LFLAGS = $$(OE_QMAKE_LDFLAGS) |
71 | +QMAKE_LFLAGS_EXCEPTIONS_ON = -mthreads | ||
72 | +QMAKE_LFLAGS_RELEASE = -Wl,-s | ||
73 | +QMAKE_LFLAGS_CONSOLE = -Wl,-subsystem,console | ||
74 | +QMAKE_LFLAGS_WINDOWS = -Wl,-subsystem,windows | ||
75 | +QMAKE_LFLAGS_DLL = -shared | ||
76 | +QMAKE_LFLAGS_GCSECTIONS = -Wl,--gc-sections | ||
77 | +QMAKE_LINK_OBJECT_MAX = 10 | ||
78 | +QMAKE_LINK_OBJECT_SCRIPT = object_script | ||
79 | +QMAKE_PREFIX_SHLIB = | ||
80 | +QMAKE_EXTENSION_SHLIB = dll | ||
81 | +QMAKE_PREFIX_STATICLIB = lib | ||
82 | +QMAKE_EXTENSION_STATICLIB = a | ||
83 | +QMAKE_LIB_EXTENSIONS = a dll.a | ||
84 | + | 47 | + |
85 | +QMAKE_LIBS = | ||
86 | +QMAKE_LIBS_CORE = -lole32 -luuid -lws2_32 -ladvapi32 -lshell32 -luser32 -lkernel32 | ||
87 | +QMAKE_LIBS_GUI = -lgdi32 -lcomdlg32 -loleaut32 -limm32 -lwinmm -lws2_32 -lole32 -luuid -luser32 -ladvapi32 | ||
88 | +QMAKE_LIBS_NETWORK = -lws2_32 | ||
89 | +QMAKE_LIBS_OPENGL = -lglu32 -lopengl32 -lgdi32 -luser32 | ||
90 | +QMAKE_LIBS_OPENGL_ES2 = -lgdi32 -luser32 | ||
91 | +QMAKE_LIBS_OPENGL_ES2_DEBUG = -lgdi32 -luser32 | ||
92 | +QMAKE_LIBS_COMPAT = -ladvapi32 -lshell32 -lcomdlg32 -luser32 -lgdi32 -lws2_32 | ||
93 | +QMAKE_LIBS_QT_ENTRY = -lmingw32 -lqtmain | ||
94 | + | ||
95 | +QMAKE_IDL = midl | ||
96 | +QMAKE_LIB = $$(OE_QMAKE_AR) -rc | 48 | +QMAKE_LIB = $$(OE_QMAKE_AR) -rc |
97 | +QMAKE_RC = $$(RC) | 49 | +QMAKE_RC = $$(RC) |
98 | + | 50 | + |
99 | +QMAKE_STRIP = $$(OE_QMAKE_STRIP) | 51 | +QMAKE_STRIP = $$(OE_QMAKE_STRIP) |
100 | +QMAKE_STRIPFLAGS_LIB += --strip-unneeded | ||
101 | +QMAKE_OBJCOPY = $${CROSS_COMPILE}objcopy | ||
102 | +QMAKE_NM = $${CROSS_COMPILE}nm -P | ||
103 | + | ||
104 | +isEmpty(QMAKE_QT_CONFIG):QMAKE_QT_CONFIG = $$(OE_QMAKE_QT_CONFIG) | ||
105 | + | ||
106 | +include(../common/angle.conf) | ||
107 | +include(../common/gcc-base.conf) | ||
108 | + | 52 | + |
109 | +load(qt_config) | 53 | +load(qt_config) |
110 | diff --git a/mkspecs/win32-g++-oe/qplatformdefs.h b/mkspecs/win32-g++-oe/qplatformdefs.h | 54 | diff --git a/mkspecs/win32-g++-oe/qplatformdefs.h b/mkspecs/win32-g++-oe/qplatformdefs.h |
111 | new file mode 100644 | 55 | new file mode 100644 |
112 | index 0000000..9d63527 | 56 | index 0000000000..9d63527955 |
113 | --- /dev/null | 57 | --- /dev/null |
114 | +++ b/mkspecs/win32-g++-oe/qplatformdefs.h | 58 | +++ b/mkspecs/win32-g++-oe/qplatformdefs.h |
115 | @@ -0,0 +1,42 @@ | 59 | @@ -0,0 +1,42 @@ |
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend b/meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend index bd86b68..95ca956 100644 --- a/meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend +++ b/meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend | |||
@@ -47,7 +47,7 @@ PACKAGECONFIG += " \ | |||
47 | ltcg \ | 47 | ltcg \ |
48 | sql-sqlite \ | 48 | sql-sqlite \ |
49 | tslib \ | 49 | tslib \ |
50 | xkbcommon-evdev \ | 50 | xkbcommon \ |
51 | " | 51 | " |
52 | 52 | ||
53 | PACKAGECONFIG_remove = "tests" | 53 | PACKAGECONFIG_remove = "tests" |
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtlocation/0001-location-disable-simulator-content-under-plugins.patch b/meta-boot2qt-distro/recipes-qt/qt5/qtlocation/0001-location-disable-simulator-content-under-plugins.patch index b90d2f8..c5e9fbf 100644 --- a/meta-boot2qt-distro/recipes-qt/qt5/qtlocation/0001-location-disable-simulator-content-under-plugins.patch +++ b/meta-boot2qt-distro/recipes-qt/qt5/qtlocation/0001-location-disable-simulator-content-under-plugins.patch | |||
@@ -1,20 +1,19 @@ | |||
1 | From 5a68ac7a0121eff661a448e2fcbe5c02981c50a1 Mon Sep 17 00:00:00 2001 | 1 | From 1362ec91854e9d56be56dc3556a9991eb3b17a5c Mon Sep 17 00:00:00 2001 |
2 | From: Mikko Gronoff <mikko.gronoff@qt.io> | 2 | From: Mikko Gronoff <mikko.gronoff@qt.io> |
3 | Date: Wed, 25 Oct 2017 13:22:16 +0300 | 3 | Date: Wed, 25 Oct 2017 13:22:16 +0300 |
4 | Subject: [PATCH] location: disable simulator content under plugins | 4 | Subject: [PATCH] location: disable simulator content under plugins |
5 | 5 | ||
6 | Does not build against more recent simulator | 6 | Does not build against more recent simulator |
7 | |||
8 | --- | 7 | --- |
9 | src/plugins/position/position.pro | 2 +- | 8 | src/plugins/position/position.pro | 2 +- |
10 | 1 file changed, 1 insertion(+), 1 deletion(-) | 9 | 1 file changed, 1 insertion(+), 1 deletion(-) |
11 | 10 | ||
12 | diff --git a/src/plugins/position/position.pro b/src/plugins/position/position.pro | 11 | diff --git a/src/plugins/position/position.pro b/src/plugins/position/position.pro |
13 | index 4453b8a3..c36a1b58 100644 | 12 | index 6800d5a3..a6d3edba 100644 |
14 | --- a/src/plugins/position/position.pro | 13 | --- a/src/plugins/position/position.pro |
15 | +++ b/src/plugins/position/position.pro | 14 | +++ b/src/plugins/position/position.pro |
16 | @@ -6,7 +6,7 @@ qtHaveModule(dbus):SUBDIRS += geoclue | 15 | @@ -6,7 +6,7 @@ linux:qtHaveModule(dbus):SUBDIRS += geoclue |
17 | qtHaveModule(dbus):SUBDIRS += geoclue2 | 16 | linux:qtHaveModule(dbus):SUBDIRS += geoclue2 |
18 | qtConfig(gypsy):SUBDIRS += gypsy | 17 | qtConfig(gypsy):SUBDIRS += gypsy |
19 | qtConfig(winrt_geolocation):SUBDIRS += winrt | 18 | qtConfig(winrt_geolocation):SUBDIRS += winrt |
20 | -qtHaveModule(simulator):SUBDIRS += simulator | 19 | -qtHaveModule(simulator):SUBDIRS += simulator |