diff options
Diffstat (limited to 'meta-boot2qt/recipes-qt/automotive/multiscreen-demo_git.bb')
-rw-r--r-- | meta-boot2qt/recipes-qt/automotive/multiscreen-demo_git.bb | 67 |
1 files changed, 67 insertions, 0 deletions
diff --git a/meta-boot2qt/recipes-qt/automotive/multiscreen-demo_git.bb b/meta-boot2qt/recipes-qt/automotive/multiscreen-demo_git.bb new file mode 100644 index 0000000..c81adee --- /dev/null +++ b/meta-boot2qt/recipes-qt/automotive/multiscreen-demo_git.bb | |||
@@ -0,0 +1,67 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2018 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | DESCRIPTION = "Multiscreen Demo" | ||
31 | LICENSE = "GPLv3 | The-Qt-Company-DCLA-2.1" | ||
32 | LIC_FILES_CHKSUM = "file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073" | ||
33 | |||
34 | inherit qt5-module systemd | ||
35 | require recipes-qt/qt5/qt5-git.inc | ||
36 | |||
37 | QT_GIT_PROJECT = "qt-apps" | ||
38 | QT_MODULE_BRANCH = "master" | ||
39 | |||
40 | SRC_URI += "\ | ||
41 | git://github.com/qtproject/qt-apps-demo-assets;protocol=git;name=assets;destsuffix=git/demo-assets \ | ||
42 | file://automotivedemo.service \ | ||
43 | " | ||
44 | |||
45 | SRCREV_multiscreen-demo = "6d02e36c4280cee5b0c31323016ae666c73afef4" | ||
46 | SRCREV_assets = "0d47d21f082d6c9e355a55809ebd38a31ea02264" | ||
47 | |||
48 | SRCREV_FORMAT = "multiscreen-demo_assets" | ||
49 | |||
50 | DEPENDS = "qtbase qtdeclarative qt3d" | ||
51 | RDEPENDS_${PN} = "qtapplicationmanager qtivi qtvirtualkeyboard" | ||
52 | |||
53 | EXTRA_QMAKEVARS_PRE += "INSTALL_PREFIX=/opt" | ||
54 | |||
55 | do_install_append() { | ||
56 | rm ${D}/opt/automotivedemo/start.sh | ||
57 | |||
58 | install -d ${D}${systemd_system_unitdir} | ||
59 | install -m 0644 ${WORKDIR}/automotivedemo.service ${D}${systemd_system_unitdir}/ | ||
60 | } | ||
61 | |||
62 | FILES_${PN} += "\ | ||
63 | /opt/automotivedemo \ | ||
64 | " | ||
65 | |||
66 | SYSTEMD_SERVICE_${PN} = "automotivedemo.service" | ||
67 | SYSTEMD_AUTO_ENABLE = "disable" | ||