summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb')
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb70
1 files changed, 70 insertions, 0 deletions
diff --git a/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb b/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb
new file mode 100644
index 0000000..ae66e8a
--- /dev/null
+++ b/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb
@@ -0,0 +1,70 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Qt component for application lifecycle management"
31LICENSE = "(GFDL-1.3 & The-Qt-Company-GPL-Exception-1.0 & (LGPL-3.0 | GPL-2.0+)) | The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=ff238b33ff354a0d8d79851a9c061717"
33
34inherit qt5-module
35require recipes-qt/qt5/qt5-git.inc
36
37SRCREV = "5581e400c95a1ff736c55c9d93bd451302970c11"
38
39DEPENDS = "qtbase qtdeclarative libyaml libarchive \
40 ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
41
42RDEPENDS_${PN} = "libcrypto ${PN}-tools"
43RDEPENDS_${PN}_remove_mingw32 = "libcrypto"
44
45EXTRA_QMAKEVARS_PRE += "\
46 ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "-config force-multiprocess", "-config force-singleprocess", d)} \
47 -config install-prefix=/usr \
48 -config systemd-workaround \
49 -config hardware-id=neptune \
50 "
51
52do_install_append() {
53 install -m 0755 -d ${D}/opt/am/
54 install -m 0644 ${S}/template-opt/am/config.yaml ${D}/opt/am/
55}
56
57FILES_${PN} += "\
58 /opt/am \
59 "
60
61BBCLASSEXTEND += "nativesdk"
62
63# nativesdk-qtdeclarative is added only to make build deterministic, can be removed once
64# there is a configure option to disable its usage.
65DEPENDS_class-nativesdk = "qtbase nativesdk-qtdeclarative nativesdk-glibc-locale nativesdk-libarchive"
66DEPENDS_class-nativesdk_remove_mingw32 = "nativesdk-glibc-locale nativesdk-libarchive"
67
68EXTRA_QMAKEVARS_PRE_class-nativesdk = "\
69 -config tools-only \
70 "