summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt/recipes-qt/boot2qt-addons/qdb_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-boot2qt/recipes-qt/boot2qt-addons/qdb_git.bb')
-rw-r--r--meta-boot2qt/recipes-qt/boot2qt-addons/qdb_git.bb71
1 files changed, 71 insertions, 0 deletions
diff --git a/meta-boot2qt/recipes-qt/boot2qt-addons/qdb_git.bb b/meta-boot2qt/recipes-qt/boot2qt-addons/qdb_git.bb
new file mode 100644
index 0000000..5615473
--- /dev/null
+++ b/meta-boot2qt/recipes-qt/boot2qt-addons/qdb_git.bb
@@ -0,0 +1,71 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Qt Debug Bridge Daemon"
31SECTION = "devel"
32LICENSE = "GPL-3.0 | The-Qt-Company-DCLA-2.1"
33LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504"
34
35inherit distro_features_check
36inherit qmake5
37require recipes-qt/qt5/qt5-git.inc
38
39QT_GIT_PROJECT = "qt-apps"
40QT_MODULE_BRANCH = "5.9"
41
42SRC_URI += "file://b2qt-gadget-network.sh \
43 file://defaults \
44 file://qdbd.service \
45 file://qdbd-init.sh \
46 "
47
48SRCREV = "69f95b6a8d2ca0912a8d502a2b6871109725731e"
49PV = "1.1.0+git${SRCPV}"
50
51REQUIRED_DISTRO_FEATURES = "systemd"
52DEPENDS = "qtbase"
53RRECOMMENDS_${PN} += "kernel-module-usb-f-fs kernel-module-usb-f-rndis"
54
55EXTRA_QMAKEVARS_PRE = "CONFIG+=daemon_only"
56
57do_install_append() {
58 install -m 0755 ${WORKDIR}/b2qt-gadget-network.sh ${D}${bindir}/
59
60 install -m 0755 ${WORKDIR}/qdbd-init.sh ${D}${bindir}/
61
62 install -m 0755 -d ${D}${systemd_unitdir}/system
63 install -m 0644 ${WORKDIR}/qdbd.service ${D}${systemd_unitdir}/system/
64
65 install -m 0755 -d ${D}${sysconfdir}/default
66 install -m 0644 ${WORKDIR}/defaults ${D}${sysconfdir}/default/qdbd
67}
68
69SYSTEMD_SERVICE_${PN} = "qdbd.service"
70
71inherit systemd