summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt/recipes-qt/qt5/qtdeviceutilities_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-boot2qt/recipes-qt/qt5/qtdeviceutilities_git.bb')
-rw-r--r--meta-boot2qt/recipes-qt/qt5/qtdeviceutilities_git.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta-boot2qt/recipes-qt/qt5/qtdeviceutilities_git.bb b/meta-boot2qt/recipes-qt/qt5/qtdeviceutilities_git.bb
new file mode 100644
index 0000000..7405424
--- /dev/null
+++ b/meta-boot2qt/recipes-qt/qt5/qtdeviceutilities_git.bb
@@ -0,0 +1,44 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Qt Device Utilities"
31LICENSE = "GPL-3.0 | The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504"
33
34inherit qt5-module
35require recipes-qt/qt5/qt5-git.inc
36
37PACKAGECONFIG ??= ""
38PACKAGECONFIG[wpasupplicant] = "CONFIG+=wpasupplicant,,wpa-supplicant"
39
40EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
41
42SRCREV = "796fff1debaa161483515779bb68999948d48c59"
43
44DEPENDS = "qtbase qtdeclarative qtconnectivity"