summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt/recipes-qt/qt5/qtglesstream_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-boot2qt/recipes-qt/qt5/qtglesstream_git.bb')
-rw-r--r--meta-boot2qt/recipes-qt/qt5/qtglesstream_git.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/meta-boot2qt/recipes-qt/qt5/qtglesstream_git.bb b/meta-boot2qt/recipes-qt/qt5/qtglesstream_git.bb
new file mode 100644
index 0000000..0f942e7
--- /dev/null
+++ b/meta-boot2qt/recipes-qt/qt5/qtglesstream_git.bb
@@ -0,0 +1,63 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "QtGlesStream"
31LICENSE = "The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://qtglesstream.pro;md5=875f34471470b09977705aed7863e440"
33
34inherit qt5-module
35
36SRC_URI = " \
37 git://codereview.qt-project.org/qt/tqtc-qtglesstream;branch=${BRANCH};protocol=ssh \
38 "
39
40PV = "1.0.0"
41SRCREV = "37f98d4b7123378d1ade7beedf5c5150cd26e178"
42BRANCH = "dev"
43
44S = "${WORKDIR}/git"
45
46DEPENDS = "qtbase"
47
48do_install_append() {
49 install -m 0755 -d ${D}${includedir}/EGL
50 install -m 0755 ${S}/headers/EGL/* ${D}${includedir}/EGL
51
52 install -m 0755 -d ${D}${includedir}/GLES2
53 install -m 0755 ${S}/headers/GLES2/* ${D}${includedir}/GLES2
54
55 install -m 0755 -d ${D}${includedir}/GLES3
56 install -m 0755 ${S}/headers/GLES3/* ${D}${includedir}/GLES3
57
58 install -m 0755 -d ${D}${includedir}/KHR
59 install -m 0755 ${S}/headers/KHR/* ${D}${includedir}/KHR
60}
61
62# no not overwrite files from qtglesstream-dummy-client
63do_populate_sysroot[noexec] = "1"