diff options
Diffstat (limited to 'meta-boot2qt')
-rw-r--r-- | meta-boot2qt/classes/image-hdd.bbclass | 48 | ||||
-rw-r--r-- | meta-boot2qt/classes/image_types_sdcard.bbclass | 10 | ||||
-rw-r--r-- | meta-boot2qt/recipes-devtools/virtualbox/mount-vboxsf_5.2.18.bb (renamed from meta-boot2qt/recipes-devtools/virtualbox/mount-vboxsf_4.3.30.bb) | 8 | ||||
-rw-r--r-- | meta-boot2qt/recipes-devtools/virtualbox/virtualbox-guest-additions_5.2.18.bb (renamed from meta-boot2qt/recipes-devtools/virtualbox/virtualbox-guest-additions_5.1.16.bb) | 10 |
4 files changed, 15 insertions, 61 deletions
diff --git a/meta-boot2qt/classes/image-hdd.bbclass b/meta-boot2qt/classes/image-hdd.bbclass deleted file mode 100644 index bceb1b1..0000000 --- a/meta-boot2qt/classes/image-hdd.bbclass +++ /dev/null | |||
@@ -1,48 +0,0 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | VM_ROOTFS_TYPE = "ext3" | ||
31 | ROOT_VM = "root=/dev/hda2" | ||
32 | LABELS_VM = "boot" | ||
33 | AUTO_SYSLINUXMENU = "0" | ||
34 | SYSLINUX_DEFAULT_CONSOLE = "console=ttyS0,115200" | ||
35 | |||
36 | inherit image_types image-vm | ||
37 | |||
38 | create_hdd_image () { | ||
39 | cd ${IMGDEPLOYDIR} | ||
40 | rm -f ${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.hdd | ||
41 | ln -s ${IMAGE_NAME}.hdddirect ${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.hdd | ||
42 | } | ||
43 | |||
44 | python do_hddimg() { | ||
45 | bb.build.exec_func('create_hdd_image', d) | ||
46 | } | ||
47 | |||
48 | addtask hddimg after do_bootdirectdisk before do_image_complete | ||
diff --git a/meta-boot2qt/classes/image_types_sdcard.bbclass b/meta-boot2qt/classes/image_types_sdcard.bbclass index 3258dbd..4ec38e5 100644 --- a/meta-boot2qt/classes/image_types_sdcard.bbclass +++ b/meta-boot2qt/classes/image_types_sdcard.bbclass | |||
@@ -34,14 +34,14 @@ IMAGE_CMD_wic_append() { | |||
34 | ln -s ${IMAGE_NAME}.rootfs.wic ${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.img | 34 | ln -s ${IMAGE_NAME}.rootfs.wic ${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.img |
35 | } | 35 | } |
36 | 36 | ||
37 | IMAGE_CMD_rpi-sdimg_append() { | 37 | IMAGE_CMD_wic_append_emulator() { |
38 | rm -f ${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.img | 38 | rm -f ${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.hdd |
39 | ln -s ${IMAGE_NAME}.rootfs.rpi-sdimg ${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.img | 39 | ln -s ${IMAGE_NAME}.rootfs.wic ${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.hdd |
40 | } | 40 | } |
41 | 41 | ||
42 | build_hddimg_append() { | 42 | IMAGE_CMD_rpi-sdimg_append() { |
43 | rm -f ${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.img | 43 | rm -f ${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.img |
44 | ln -s ${IMAGE_NAME}.hddimg ${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.img | 44 | ln -s ${IMAGE_NAME}.rootfs.rpi-sdimg ${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.img |
45 | } | 45 | } |
46 | 46 | ||
47 | do_image_tegraflash[depends] += "parted-native:do_populate_sysroot" | 47 | do_image_tegraflash[depends] += "parted-native:do_populate_sysroot" |
diff --git a/meta-boot2qt/recipes-devtools/virtualbox/mount-vboxsf_4.3.30.bb b/meta-boot2qt/recipes-devtools/virtualbox/mount-vboxsf_5.2.18.bb index 1eb2652..6dba661 100644 --- a/meta-boot2qt/recipes-devtools/virtualbox/mount-vboxsf_4.3.30.bb +++ b/meta-boot2qt/recipes-devtools/virtualbox/mount-vboxsf_5.2.18.bb | |||
@@ -1,6 +1,6 @@ | |||
1 | ############################################################################ | 1 | ############################################################################ |
2 | ## | 2 | ## |
3 | ## Copyright (C) 2016 The Qt Company Ltd. | 3 | ## Copyright (C) 2018 The Qt Company Ltd. |
4 | ## Contact: https://www.qt.io/licensing/ | 4 | ## Contact: https://www.qt.io/licensing/ |
5 | ## | 5 | ## |
6 | ## This file is part of the Boot to Qt meta layer. | 6 | ## This file is part of the Boot to Qt meta layer. |
@@ -36,13 +36,13 @@ SRC_URI = "http://download.virtualbox.org/virtualbox/${PV}/VirtualBox-${PV}.tar. | |||
36 | file://mount-vboxsf.service \ | 36 | file://mount-vboxsf.service \ |
37 | " | 37 | " |
38 | 38 | ||
39 | SRC_URI[md5sum] = "cc053340f88922a11ad9d4fab56557bd" | 39 | SRC_URI[md5sum] = "d8e291525b84569356773eef507c49ce" |
40 | SRC_URI[sha256sum] = "ea9569ec16cd6202ee61bcadb2506d31ac12fd343adb91565773a05eaaea9a36" | 40 | SRC_URI[sha256sum] = "ed0a7efd56c7f39fae79c7ec3321473da412ef0d7914457b66f42679d513efcf" |
41 | 41 | ||
42 | S = "${WORKDIR}/VirtualBox-${PV}/src/VBox/Additions/linux/sharedfolders" | 42 | S = "${WORKDIR}/VirtualBox-${PV}/src/VBox/Additions/linux/sharedfolders" |
43 | 43 | ||
44 | do_compile() { | 44 | do_compile() { |
45 | ${CC} ${LDFLAGS} mount.vboxsf.c vbsfmount.c -o mount.vboxsf | 45 | ${CC} ${LDFLAGS} -I../../../../../include -DIN_RING3 mount.vboxsf.c vbsfmount.c -o mount.vboxsf |
46 | } | 46 | } |
47 | 47 | ||
48 | do_install() { | 48 | do_install() { |
diff --git a/meta-boot2qt/recipes-devtools/virtualbox/virtualbox-guest-additions_5.1.16.bb b/meta-boot2qt/recipes-devtools/virtualbox/virtualbox-guest-additions_5.2.18.bb index 752d8cb..a727c6f 100644 --- a/meta-boot2qt/recipes-devtools/virtualbox/virtualbox-guest-additions_5.1.16.bb +++ b/meta-boot2qt/recipes-devtools/virtualbox/virtualbox-guest-additions_5.2.18.bb | |||
@@ -1,6 +1,6 @@ | |||
1 | ############################################################################ | 1 | ############################################################################ |
2 | ## | 2 | ## |
3 | ## Copyright (C) 2017 The Qt Company Ltd. | 3 | ## Copyright (C) 2018 The Qt Company Ltd. |
4 | ## Contact: https://www.qt.io/licensing/ | 4 | ## Contact: https://www.qt.io/licensing/ |
5 | ## | 5 | ## |
6 | ## This file is part of the Boot to Qt meta layer. | 6 | ## This file is part of the Boot to Qt meta layer. |
@@ -38,18 +38,20 @@ PR = "${MACHINE_KERNEL_PR}" | |||
38 | 38 | ||
39 | SRC_URI = "http://download.virtualbox.org/virtualbox/${PV}/VirtualBox-${PV}.tar.bz2" | 39 | SRC_URI = "http://download.virtualbox.org/virtualbox/${PV}/VirtualBox-${PV}.tar.bz2" |
40 | 40 | ||
41 | SRC_URI[md5sum] = "37ebbd51370841eed8ab80f2f38446d6" | 41 | SRC_URI[md5sum] = "d8e291525b84569356773eef507c49ce" |
42 | SRC_URI[sha256sum] = "78071c3172f3bd3c7981c352c3ae6c6a9c01f6ab24bc0aa7ec79f3528b2291a7" | 42 | SRC_URI[sha256sum] = "ed0a7efd56c7f39fae79c7ec3321473da412ef0d7914457b66f42679d513efcf" |
43 | 43 | ||
44 | S = "${WORKDIR}/vbox" | 44 | S = "${WORKDIR}/vbox" |
45 | 45 | ||
46 | export KERN_DIR="${STAGING_KERNEL_DIR}" | 46 | export KERN_DIR="${STAGING_KERNEL_DIR}" |
47 | export KERN_VER="${KERNEL_VERSION}" | ||
47 | export KBUILD_VERBOSE="1" | 48 | export KBUILD_VERBOSE="1" |
48 | export BUILD_TARGET_ARCH="${ARCH}" | 49 | export BUILD_TARGET_ARCH="${ARCH}" |
49 | 50 | ||
50 | do_compile_prepend() { | 51 | do_compile_prepend() { |
51 | ${WORKDIR}/VirtualBox-${PV}/src/VBox/Additions/linux/export_modules ${WORKDIR}/vbox.tar.gz | 52 | ${WORKDIR}/VirtualBox-${PV}/src/VBox/Additions/linux/export_modules.sh ${WORKDIR}/vbox.tar.gz |
52 | tar xf ${WORKDIR}/vbox.tar.gz -C ${WORKDIR}/vbox | 53 | tar xf ${WORKDIR}/vbox.tar.gz -C ${WORKDIR}/vbox |
54 | find ${WORKDIR}/vbox -name Makefile.include.header | xargs sed -i -e '/KERN_DIR :=/d' | ||
53 | } | 55 | } |
54 | 56 | ||
55 | do_install() { | 57 | do_install() { |