summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt
diff options
context:
space:
mode:
Diffstat (limited to 'meta-boot2qt')
-rw-r--r--meta-boot2qt/classes/populate_b2qt_qt5_sdk.bbclass11
-rw-r--r--meta-boot2qt/classes/qt5-features.bbclass40
-rw-r--r--meta-boot2qt/conf/layer.conf2
-rwxr-xr-xmeta-boot2qt/files/configure-qtcreator.sh12
-rw-r--r--meta-boot2qt/recipes-qt/automotive/gammaray_git.bb2
-rw-r--r--meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb3
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb3
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qtivi_git.bb3
8 files changed, 71 insertions, 5 deletions
diff --git a/meta-boot2qt/classes/populate_b2qt_qt5_sdk.bbclass b/meta-boot2qt/classes/populate_b2qt_qt5_sdk.bbclass
index e98565c..ee1a25f 100644
--- a/meta-boot2qt/classes/populate_b2qt_qt5_sdk.bbclass
+++ b/meta-boot2qt/classes/populate_b2qt_qt5_sdk.bbclass
@@ -34,6 +34,7 @@ NATIVE_SDK_MKSPEC_DIR = "${SDK_OUTPUT}${SDKPATHNATIVE}${libdir}/${QT_DIR_NAME}/m
34SDK_MKSPEC = "devices/linux-oe-generic-g++" 34SDK_MKSPEC = "devices/linux-oe-generic-g++"
35SDK_DEVICE_PRI = "${SDK_MKSPEC_DIR}/qdevice.pri" 35SDK_DEVICE_PRI = "${SDK_MKSPEC_DIR}/qdevice.pri"
36SDK_DYNAMIC_FLAGS = "-O. -pipe -g" 36SDK_DYNAMIC_FLAGS = "-O. -pipe -g"
37MACHINE_CMAKE = "${SDK_OUTPUT}${SDKPATHNATIVE}${datadir}/cmake/OEToolchainConfig.cmake.d/${MACHINE}.cmake"
37 38
38create_sdk_files_append () { 39create_sdk_files_append () {
39 # Create the toolchain user's generic device mkspec 40 # Create the toolchain user's generic device mkspec
@@ -79,6 +80,16 @@ EOF
79 80
80 # Link /etc/resolv.conf is broken in the toolchain sysroot, remove it 81 # Link /etc/resolv.conf is broken in the toolchain sysroot, remove it
81 rm -f ${SDK_OUTPUT}${SDKTARGETSYSROOT}${sysconfdir}/resolv.conf 82 rm -f ${SDK_OUTPUT}${SDKTARGETSYSROOT}${sysconfdir}/resolv.conf
83
84 # Create and add cmake toolchain file
85 echo "set(CMAKE_SYSROOT ${SDKTARGETSYSROOT})" > ${MACHINE_CMAKE}
86 echo "set(CMAKE_PREFIX_PATH ${SDKTARGETSYSROOT}${OE_QMAKE_PATH_LIBS}/cmake)" >> ${MACHINE_CMAKE}
87 echo "set(compiler_flags \"${TARGET_CC_ARCH}\")" >> ${MACHINE_CMAKE}
88 echo "set(CMAKE_C_COMPILER_ARG1 \"\${compiler_flags}\")" >> ${MACHINE_CMAKE}
89 echo "set(CMAKE_CXX_COMPILER_ARG1 \"\${compiler_flags}\")" >> ${MACHINE_CMAKE}
90 echo "set(OE_QMAKE_PATH_EXTERNAL_HOST_BINS ${SDKPATHNATIVE}${OE_QMAKE_PATH_HOST_BINS})" >> ${MACHINE_CMAKE}
91 mkdir -p ${D}${datadir}/cmake/OEToolchainConfig.cmake.d/
92 install -m 0644 ${MACHINE_CMAKE} ${D}${datadir}/cmake/OEToolchainConfig.cmake.d/
82} 93}
83 94
84create_qtcreator_configure_script () { 95create_qtcreator_configure_script () {
diff --git a/meta-boot2qt/classes/qt5-features.bbclass b/meta-boot2qt/classes/qt5-features.bbclass
new file mode 100644
index 0000000..89b3ee6
--- /dev/null
+++ b/meta-boot2qt/classes/qt5-features.bbclass
@@ -0,0 +1,40 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FEATURES := "${THISDIR}/features/${QT_MODULE}.opt"
31do_configure[file-checksums] += "${FEATURES}:True"
32
33def qt_features(d):
34 featurefile = d.getVar('FEATURES', True)
35 with open(featurefile, 'r') as f:
36 features = f.read().replace('\n', ' ')
37 return features
38
39QT_CONFIG_FLAGS_append_class-target = " ${@qt_features(d)}"
40EXTRA_QMAKEVARS_CONFIGURE_append_class-target = " ${@qt_features(d)}"
diff --git a/meta-boot2qt/conf/layer.conf b/meta-boot2qt/conf/layer.conf
index b8ba222..c51ea68 100644
--- a/meta-boot2qt/conf/layer.conf
+++ b/meta-boot2qt/conf/layer.conf
@@ -43,3 +43,5 @@ QT_LICENSE = "${LAYERDIR}/licenses/The-Qt-Company-Commercial"
43B2QTBASE = "${LAYERDIR}" 43B2QTBASE = "${LAYERDIR}"
44 44
45HOSTTOOLS += "git-lfs" 45HOSTTOOLS += "git-lfs"
46
47LAYERSERIES_COMPAT_b2qt = "sumo"
diff --git a/meta-boot2qt/files/configure-qtcreator.sh b/meta-boot2qt/files/configure-qtcreator.sh
index 105e476..3e5db2d 100755
--- a/meta-boot2qt/files/configure-qtcreator.sh
+++ b/meta-boot2qt/files/configure-qtcreator.sh
@@ -100,6 +100,7 @@ ${SDKTOOL} rmQt --id ${BASEID}.qt || true
100${SDKTOOL} rmTC --id ProjectExplorer.ToolChain.Gcc:${BASEID}.gcc || true 100${SDKTOOL} rmTC --id ProjectExplorer.ToolChain.Gcc:${BASEID}.gcc || true
101${SDKTOOL} rmTC --id ProjectExplorer.ToolChain.Gcc:${BASEID}.g++ || true 101${SDKTOOL} rmTC --id ProjectExplorer.ToolChain.Gcc:${BASEID}.g++ || true
102${SDKTOOL} rmDebugger --id ${BASEID}.gdb 2>/dev/null || true 102${SDKTOOL} rmDebugger --id ${BASEID}.gdb 2>/dev/null || true
103${SDKTOOL} rmCMake --id ${BASEID}.cmake 2>/dev/null || true
103 104
104if [ -n "${REMOVEONLY}" ]; then 105if [ -n "${REMOVEONLY}" ]; then
105 echo "Kit removed: ${NAME}" 106 echo "Kit removed: ${NAME}"
@@ -133,6 +134,11 @@ ${SDKTOOL} addQt \
133 --type "Qdb.EmbeddedLinuxQt" \ 134 --type "Qdb.EmbeddedLinuxQt" \
134 --qmake "$(type -p qmake)" 135 --qmake "$(type -p qmake)"
135 136
137${SDKTOOL} addCMake \
138 --id "${BASEID}.cmake" \
139 --name "CMake ${NAME}" \
140 --path "$(type -p cmake)"
141
136${SDKTOOL} addKit \ 142${SDKTOOL} addKit \
137 --id "${BASEID}.kit" \ 143 --id "${BASEID}.kit" \
138 --name "${NAME}" \ 144 --name "${NAME}" \
@@ -143,6 +149,10 @@ ${SDKTOOL} addKit \
143 --Ctoolchain "ProjectExplorer.ToolChain.Gcc:${BASEID}.gcc" \ 149 --Ctoolchain "ProjectExplorer.ToolChain.Gcc:${BASEID}.gcc" \
144 --Cxxtoolchain "ProjectExplorer.ToolChain.Gcc:${BASEID}.g++" \ 150 --Cxxtoolchain "ProjectExplorer.ToolChain.Gcc:${BASEID}.g++" \
145 --icon ":/boot2qt/images/B2Qt_QtC_icon.png" \ 151 --icon ":/boot2qt/images/B2Qt_QtC_icon.png" \
146 --mkspec "${MKSPEC}" 152 --mkspec "${MKSPEC}" \
153 --cmake "${BASEID}.cmake" \
154 --cmake-config "CMAKE_TOOLCHAIN_FILE:FILEPATH=${OECORE_NATIVE_SYSROOT}/usr/share/cmake/OEToolchainConfig.cmake" \
155 --cmake-config "CMAKE_CXX_COMPILER:FILEPATH=$(type -p ${CXX})" \
156 --cmake-config "CMAKE_C_COMPILER:FILEPATH=$(type -p ${CC})"
147 157
148echo "Configured Qt Creator with new kit: ${NAME}" 158echo "Configured Qt Creator with new kit: ${NAME}"
diff --git a/meta-boot2qt/recipes-qt/automotive/gammaray_git.bb b/meta-boot2qt/recipes-qt/automotive/gammaray_git.bb
index 3f2f680..a3ec584 100644
--- a/meta-boot2qt/recipes-qt/automotive/gammaray_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/gammaray_git.bb
@@ -9,7 +9,7 @@ inherit cmake_qt5
9SRC_URI = "git://github.com/KDAB/GammaRay;branch=${BRANCH}" 9SRC_URI = "git://github.com/KDAB/GammaRay;branch=${BRANCH}"
10 10
11BRANCH = "5.11" 11BRANCH = "5.11"
12SRCREV = "3a35d9ec64a3c32503c1252edc2608ad49f05b40" 12SRCREV = "2cd4585e287a2bcf80572505537e5e75d020c5f5"
13PV = "${BRANCH}+git${SRCPV}" 13PV = "${BRANCH}+git${SRCPV}"
14 14
15DEPENDS = "qtdeclarative qtlocation qtsvg qttools qtconnectivity qt3d qtivi qtscxml qtscxml-native \ 15DEPENDS = "qtdeclarative qtlocation qtsvg qttools qtconnectivity qt3d qtivi qtscxml qtscxml-native \
diff --git a/meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb b/meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb
index 061e3a8..54539e2 100644
--- a/meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb
@@ -39,12 +39,13 @@ inherit qt5-module systemd
39require recipes-qt/qt5/qt5-git.inc 39require recipes-qt/qt5/qt5-git.inc
40 40
41QT_GIT_PROJECT = "qt-apps" 41QT_GIT_PROJECT = "qt-apps"
42QT_MODULE_BRANCH = "dev"
42 43
43SRC_URI += " \ 44SRC_URI += " \
44 file://neptune.service \ 45 file://neptune.service \
45 " 46 "
46 47
47SRCREV = "4509d7d8a1e5675cebf17ffeb74ba72a90ed296f" 48SRCREV = "7b244d7f3d7db956756aa721dffe65b184bade98"
48 49
49QMAKE_PROFILES = "${S}/neptune3-ui.pro" 50QMAKE_PROFILES = "${S}/neptune3-ui.pro"
50 51
diff --git a/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb b/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb
index 82a9bcd..87ce644 100644
--- a/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb
@@ -34,7 +34,8 @@ LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=ff238b33ff354a0d8d79851a9c061717"
34inherit qt5-module 34inherit qt5-module
35require recipes-qt/qt5/qt5-git.inc 35require recipes-qt/qt5/qt5-git.inc
36 36
37SRCREV = "201656bedec57dbd22b3fc3089148e6c7453875c" 37QT_MODULE_BRANCH = "dev"
38SRCREV = "08ee6cf6bfff3bfc1cde8552231da12a51dd3b49"
38 39
39DEPENDS = "qtbase qtdeclarative libyaml libarchive \ 40DEPENDS = "qtbase qtdeclarative libyaml libarchive \
40 ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland qtwayland-native", "", d)}" 41 ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland qtwayland-native", "", d)}"
diff --git a/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb b/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
index c933cfb..164edeb 100644
--- a/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
@@ -43,6 +43,7 @@ inherit qt5-module
43inherit python3native 43inherit python3native
44require recipes-qt/qt5/qt5-git.inc 44require recipes-qt/qt5/qt5-git.inc
45 45
46QT_MODULE_BRANCH = "dev"
46QT_MODULE_BRANCH_QFACE = "upstream/develop" 47QT_MODULE_BRANCH_QFACE = "upstream/develop"
47 48
48SRC_URI += " \ 49SRC_URI += " \
@@ -50,7 +51,7 @@ SRC_URI += " \
50 file://0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch \ 51 file://0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch \
51" 52"
52 53
53SRCREV_qtivi = "9597934087e395659aedb7735e1fc233a3407fd7" 54SRCREV_qtivi = "e507a49be6387361ae4862ec6c6dc5aaac9d0c77"
54SRCREV_qface = "9da793d6cbc63d617ad5e2ffd13e9f6d055c88e8" 55SRCREV_qface = "9da793d6cbc63d617ad5e2ffd13e9f6d055c88e8"
55SRCREV = "${SRCREV_qtivi}" 56SRCREV = "${SRCREV_qtivi}"
56SRCREV_FORMAT = "qtivi_qface" 57SRCREV_FORMAT = "qtivi_qface"