diff options
Diffstat (limited to 'meta-fsl-extras/recipes')
-rw-r--r-- | meta-fsl-extras/recipes/qt5/qtbase/0001-egl_viv-cast-EGLNative-types-from-vivante-functions.patch | 57 | ||||
-rw-r--r-- | meta-fsl-extras/recipes/qt5/qtbase_git.bbappend | 33 |
2 files changed, 0 insertions, 90 deletions
diff --git a/meta-fsl-extras/recipes/qt5/qtbase/0001-egl_viv-cast-EGLNative-types-from-vivante-functions.patch b/meta-fsl-extras/recipes/qt5/qtbase/0001-egl_viv-cast-EGLNative-types-from-vivante-functions.patch deleted file mode 100644 index dc56cfc..0000000 --- a/meta-fsl-extras/recipes/qt5/qtbase/0001-egl_viv-cast-EGLNative-types-from-vivante-functions.patch +++ /dev/null | |||
@@ -1,57 +0,0 @@ | |||
1 | From 40e76307c1ee1ebe4e0142d623071d0f768f2450 Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuli Piippo <samuli.piippo@qt.io> | ||
3 | Date: Wed, 9 Jan 2019 13:01:01 +0000 | ||
4 | Subject: [PATCH] egl_viv: cast EGLNative types from vivante functions | ||
5 | |||
6 | All vivante functions return void* even when the actual native type | ||
7 | (EGLNativeDisplayType, EGLNativeWindowType, etc.) might be typedef'ed | ||
8 | as something else, as they do when the CFLAGS from egl.pc are now used. | ||
9 | --- | ||
10 | .../deviceintegration/eglfs_viv/qeglfsvivintegration.cpp | 4 ++-- | ||
11 | .../deviceintegration/eglfs_viv_wl/qeglfsvivwlintegration.cpp | 4 ++-- | ||
12 | 2 files changed, 4 insertions(+), 4 deletions(-) | ||
13 | |||
14 | diff --git a/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv/qeglfsvivintegration.cpp b/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv/qeglfsvivintegration.cpp | ||
15 | index 763a4a462b..2fc076ad0c 100644 | ||
16 | --- a/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv/qeglfsvivintegration.cpp | ||
17 | +++ b/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv/qeglfsvivintegration.cpp | ||
18 | @@ -65,7 +65,7 @@ void QEglFSVivIntegration::platformInit() | ||
19 | VivanteInit(); | ||
20 | mNativeDisplay = fbGetDisplay(); | ||
21 | #else | ||
22 | - mNativeDisplay = fbGetDisplayByIndex(framebufferIndex()); | ||
23 | + mNativeDisplay = static_cast<EGLNativeDisplayType>(fbGetDisplayByIndex(framebufferIndex())); | ||
24 | #endif | ||
25 | |||
26 | fbGetDisplayGeometry(mNativeDisplay, &width, &height); | ||
27 | @@ -88,7 +88,7 @@ EGLNativeWindowType QEglFSVivIntegration::createNativeWindow(QPlatformWindow *wi | ||
28 | Q_UNUSED(window) | ||
29 | Q_UNUSED(format) | ||
30 | |||
31 | - EGLNativeWindowType eglWindow = fbCreateWindow(mNativeDisplay, 0, 0, size.width(), size.height()); | ||
32 | + EGLNativeWindowType eglWindow = static_cast<EGLNativeWindowType>(fbCreateWindow(mNativeDisplay, 0, 0, size.width(), size.height())); | ||
33 | return eglWindow; | ||
34 | } | ||
35 | |||
36 | diff --git a/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv_wl/qeglfsvivwlintegration.cpp b/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv_wl/qeglfsvivwlintegration.cpp | ||
37 | index 61e2f17766..3bdae239cd 100644 | ||
38 | --- a/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv_wl/qeglfsvivwlintegration.cpp | ||
39 | +++ b/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv_wl/qeglfsvivwlintegration.cpp | ||
40 | @@ -60,7 +60,7 @@ void QEglFSVivWaylandIntegration::platformInit() | ||
41 | } | ||
42 | |||
43 | mWaylandDisplay = wl_display_create(); | ||
44 | - mNativeDisplay = fbGetDisplay(mWaylandDisplay); | ||
45 | + mNativeDisplay = static_cast<EGLNativeDisplayType>(fbGetDisplay(mWaylandDisplay)); | ||
46 | fbGetDisplayGeometry(mNativeDisplay, &width, &height); | ||
47 | mScreenSize.setHeight(height); | ||
48 | mScreenSize.setWidth(width); | ||
49 | @@ -81,7 +81,7 @@ EGLNativeWindowType QEglFSVivWaylandIntegration::createNativeWindow(QPlatformWin | ||
50 | Q_UNUSED(window) | ||
51 | Q_UNUSED(format) | ||
52 | |||
53 | - EGLNativeWindowType eglWindow = fbCreateWindow(mNativeDisplay, 0, 0, size.width(), size.height()); | ||
54 | + EGLNativeWindowType eglWindow = static_cast<EGLNativeWindowType>(fbCreateWindow(mNativeDisplay, 0, 0, size.width(), size.height())); | ||
55 | return eglWindow; | ||
56 | } | ||
57 | |||
diff --git a/meta-fsl-extras/recipes/qt5/qtbase_git.bbappend b/meta-fsl-extras/recipes/qt5/qtbase_git.bbappend deleted file mode 100644 index 373e614..0000000 --- a/meta-fsl-extras/recipes/qt5/qtbase_git.bbappend +++ /dev/null | |||
@@ -1,33 +0,0 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2018 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
31 | SRC_URI += " \ | ||
32 | file://0001-egl_viv-cast-EGLNative-types-from-vivante-functions.patch \ | ||
33 | " | ||