diff options
Diffstat (limited to 'meta-fsl-extras')
-rw-r--r-- | meta-fsl-extras/recipes/linux/linux-warp7/0001-Fix-dev-hwrng-by-enabling-warp7-crypto-device.patch | 25 | ||||
-rw-r--r-- | meta-fsl-extras/recipes/linux/linux-warp7_4.1.bbappend | 15 | ||||
-rw-r--r-- | meta-fsl-extras/recipes/u-boot/u-boot-fslc/0001-use-imx7d-warp.dtb.patch | 22 | ||||
-rw-r--r-- | meta-fsl-extras/recipes/u-boot/u-boot-fslc_%.bbappend (renamed from meta-fsl-extras/recipes/u-boot/u-boot-fslc_2016.%.bbappend) | 1 | ||||
-rw-r--r-- | meta-fsl-extras/recipes/u-boot/u-boot-toradex_%.bbappend | 1 |
5 files changed, 64 insertions, 0 deletions
diff --git a/meta-fsl-extras/recipes/linux/linux-warp7/0001-Fix-dev-hwrng-by-enabling-warp7-crypto-device.patch b/meta-fsl-extras/recipes/linux/linux-warp7/0001-Fix-dev-hwrng-by-enabling-warp7-crypto-device.patch new file mode 100644 index 0000000..dbb7995 --- /dev/null +++ b/meta-fsl-extras/recipes/linux/linux-warp7/0001-Fix-dev-hwrng-by-enabling-warp7-crypto-device.patch | |||
@@ -0,0 +1,25 @@ | |||
1 | From 9ffa222dbaa3b11c3b1399192e0abd478fc3b564 Mon Sep 17 00:00:00 2001 | ||
2 | From: Sami Nurmenniemi <sami.nurmenniemi@qt.io> | ||
3 | Date: Mon, 18 Sep 2017 12:45:54 +0300 | ||
4 | Subject: [PATCH 1/1] Fix /dev/hwrng by enabling warp7 crypto-device | ||
5 | |||
6 | --- | ||
7 | arch/arm/boot/dts/imx7d-warp.dts | 2 +- | ||
8 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
9 | |||
10 | diff --git a/arch/arm/boot/dts/imx7d-warp.dts b/arch/arm/boot/dts/imx7d-warp.dts | ||
11 | index ee72690..19aee0e 100755 | ||
12 | --- a/arch/arm/boot/dts/imx7d-warp.dts | ||
13 | +++ b/arch/arm/boot/dts/imx7d-warp.dts | ||
14 | @@ -181,7 +181,7 @@ | ||
15 | }; | ||
16 | |||
17 | &crypto { | ||
18 | - status = "disabled"; | ||
19 | + status = "okay"; | ||
20 | }; | ||
21 | |||
22 | &clks { | ||
23 | -- | ||
24 | 2.7.4 | ||
25 | |||
diff --git a/meta-fsl-extras/recipes/linux/linux-warp7_4.1.bbappend b/meta-fsl-extras/recipes/linux/linux-warp7_4.1.bbappend index 5efcce0..72db716 100644 --- a/meta-fsl-extras/recipes/linux/linux-warp7_4.1.bbappend +++ b/meta-fsl-extras/recipes/linux/linux-warp7_4.1.bbappend | |||
@@ -27,8 +27,23 @@ | |||
27 | ## | 27 | ## |
28 | ############################################################################ | 28 | ############################################################################ |
29 | 29 | ||
30 | SRCBRANCH = "linux_4.1.29" | ||
31 | SRCREV = "881845d84e3c2e58a00b9c36616203d748b7df0e" | ||
32 | LOCALVERSION = "-warp7" | ||
33 | |||
34 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" | ||
35 | SRC_URI += " \ | ||
36 | file://0001-Fix-dev-hwrng-by-enabling-warp7-crypto-device.patch \ | ||
37 | " | ||
38 | |||
30 | do_configure_prepend() { | 39 | do_configure_prepend() { |
31 | echo "CONFIG_NAMESPACES=y" >> ${B}/.config | 40 | echo "CONFIG_NAMESPACES=y" >> ${B}/.config |
32 | echo "CONFIG_FHANDLE=y" >> ${B}/.config | 41 | echo "CONFIG_FHANDLE=y" >> ${B}/.config |
33 | echo "CONFIG_USB_FUNCTIONFS=m" >> ${B}/.config | 42 | echo "CONFIG_USB_FUNCTIONFS=m" >> ${B}/.config |
43 | |||
44 | echo "CONFIG_MXC_CAMERA_OV2680_MIPI=m" >> ${B}/.config | ||
45 | echo "CONFIG_FB_MXC_TRULY_PANEL_TDO_ST7796H=y" >> ${B}/.config | ||
46 | echo "CONFIG_TOUCHSCREEN_SYNAPTICS_DSX_CORE=y" >> ${B}/.config | ||
47 | echo "CONFIG_TOUCHSCREEN_SYNAPTICS_DSX_RMI_DEV=y >> ${B}/.config | ||
48 | echo "CONFIG_TOUCHSCREEN_SYNAPTICS_DSX_FW_UPDATE=y >> ${B}/.config | ||
34 | } | 49 | } |
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-fslc/0001-use-imx7d-warp.dtb.patch b/meta-fsl-extras/recipes/u-boot/u-boot-fslc/0001-use-imx7d-warp.dtb.patch new file mode 100644 index 0000000..e8a0573 --- /dev/null +++ b/meta-fsl-extras/recipes/u-boot/u-boot-fslc/0001-use-imx7d-warp.dtb.patch | |||
@@ -0,0 +1,22 @@ | |||
1 | From ef2f2eeef6974bda0fd878c5f76b8b05ac16aa3d Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuli Piippo <samuli.piippo@qt.io> | ||
3 | Date: Wed, 13 Sep 2017 09:40:44 +0300 | ||
4 | Subject: [PATCH] use imx7d-warp.dtb | ||
5 | |||
6 | --- | ||
7 | include/configs/warp7.h | 2 +- | ||
8 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
9 | |||
10 | diff --git a/include/configs/warp7.h b/include/configs/warp7.h | ||
11 | index b3e1f2e..edbd43f 100644 | ||
12 | --- a/include/configs/warp7.h | ||
13 | +++ b/include/configs/warp7.h | ||
14 | @@ -35,7 +35,7 @@ | ||
15 | "ethact=usb_ether\0" \ | ||
16 | "fdt_high=0xffffffff\0" \ | ||
17 | "initrd_high=0xffffffff\0" \ | ||
18 | - "fdt_file=imx7s-warp.dtb\0" \ | ||
19 | + "fdt_file=imx7d-warp.dtb\0" \ | ||
20 | "fdt_addr=0x83000000\0" \ | ||
21 | "boot_fdt=try\0" \ | ||
22 | "ip_dyn=yes\0" \ | ||
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-fslc_2016.%.bbappend b/meta-fsl-extras/recipes/u-boot/u-boot-fslc_%.bbappend index c5201a0..b1df421 100644 --- a/meta-fsl-extras/recipes/u-boot/u-boot-fslc_2016.%.bbappend +++ b/meta-fsl-extras/recipes/u-boot/u-boot-fslc_%.bbappend | |||
@@ -31,4 +31,5 @@ FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" | |||
31 | SRC_URI += " \ | 31 | SRC_URI += " \ |
32 | file://0001-Updated-kernel-arguments-for-sabre-sd.patch \ | 32 | file://0001-Updated-kernel-arguments-for-sabre-sd.patch \ |
33 | file://0001-Use-hdmi-as-primary-display-only-if-connected.patch \ | 33 | file://0001-Use-hdmi-as-primary-display-only-if-connected.patch \ |
34 | file://0001-use-imx7d-warp.dtb.patch \ | ||
34 | " | 35 | " |
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-toradex_%.bbappend b/meta-fsl-extras/recipes/u-boot/u-boot-toradex_%.bbappend index 78e32d3..3d288f1 100644 --- a/meta-fsl-extras/recipes/u-boot/u-boot-toradex_%.bbappend +++ b/meta-fsl-extras/recipes/u-boot/u-boot-toradex_%.bbappend | |||
@@ -33,3 +33,4 @@ SRC_URI += " \ | |||
33 | file://0002-apalis-imx6-test-for-Capacitive-Touch-Display-7-Para.patch \ | 33 | file://0002-apalis-imx6-test-for-Capacitive-Touch-Display-7-Para.patch \ |
34 | file://0003-apalis-imx6-Ixora-v1.0-support.patch \ | 34 | file://0003-apalis-imx6-Ixora-v1.0-support.patch \ |
35 | " | 35 | " |
36 | DEPENDS += "dtc-native" | ||