summaryrefslogtreecommitdiffstats
path: root/meta-fsl-extras
diff options
context:
space:
mode:
Diffstat (limited to 'meta-fsl-extras')
-rw-r--r--meta-fsl-extras/recipes/qt5/qtbase_%.bbappend38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-fsl-extras/recipes/qt5/qtbase_%.bbappend b/meta-fsl-extras/recipes/qt5/qtbase_%.bbappend
new file mode 100644
index 0000000..11fbab1
--- /dev/null
+++ b/meta-fsl-extras/recipes/qt5/qtbase_%.bbappend
@@ -0,0 +1,38 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23do_configure_prepend_mx6() {
24 sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf
25 cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF
26IMX6_CFLAGS = -DLINUX=1 -DEGL_API_FB=1
27QMAKE_LIBS_EGL += -lEGL
28QMAKE_LIBS_OPENGL_ES2 += -lGLESv2 -lEGL -lGAL
29QMAKE_LIBS_OPENVG += -lOpenVG -lEGL -lGAL
30QMAKE_CFLAGS += \$\$IMX6_CFLAGS
31QMAKE_CXXFLAGS += \$\$IMX6_CFLAGS
32
33EGLFS_PLATFORM_HOOKS_SOURCES = \$\$PWD/../devices/linux-imx6-g++/qeglfshooks_imx6.cpp
34
35load(qt_config)
36
37EOF
38}