summaryrefslogtreecommitdiffstats
path: root/meta-raspberrypi-extras
diff options
context:
space:
mode:
Diffstat (limited to 'meta-raspberrypi-extras')
-rw-r--r--meta-raspberrypi-extras/conf/layer.conf2
-rw-r--r--meta-raspberrypi-extras/recipes/userland/userland/0001-khronos-backport-typedef-for-EGL_EXT_image_dma_buf_i.patch34
-rw-r--r--meta-raspberrypi-extras/recipes/userland/userland_git.bbappend35
3 files changed, 1 insertions, 70 deletions
diff --git a/meta-raspberrypi-extras/conf/layer.conf b/meta-raspberrypi-extras/conf/layer.conf
index 0e85afe..6b2e55a 100644
--- a/meta-raspberrypi-extras/conf/layer.conf
+++ b/meta-raspberrypi-extras/conf/layer.conf
@@ -39,4 +39,4 @@ BBFILE_COLLECTIONS += "b2qt_rpi"
39BBFILE_PATTERN_b2qt_rpi := "^${LAYERDIR}/" 39BBFILE_PATTERN_b2qt_rpi := "^${LAYERDIR}/"
40BBFILE_PRIORITY_b2qt_rpi = "20" 40BBFILE_PRIORITY_b2qt_rpi = "20"
41 41
42LAYERSERIES_COMPAT_b2qt_rpi = "sumo" 42LAYERSERIES_COMPAT_b2qt_rpi = "thud"
diff --git a/meta-raspberrypi-extras/recipes/userland/userland/0001-khronos-backport-typedef-for-EGL_EXT_image_dma_buf_i.patch b/meta-raspberrypi-extras/recipes/userland/userland/0001-khronos-backport-typedef-for-EGL_EXT_image_dma_buf_i.patch
deleted file mode 100644
index d21fd09..0000000
--- a/meta-raspberrypi-extras/recipes/userland/userland/0001-khronos-backport-typedef-for-EGL_EXT_image_dma_buf_i.patch
+++ /dev/null
@@ -1,34 +0,0 @@
1From e977e56df364e3a89e08bd7b8a27d30360b0ccc7 Mon Sep 17 00:00:00 2001
2From: Hugo Hromic <hhromic@gmail.com>
3Date: Sun, 13 May 2018 10:49:04 +0100
4Subject: [PATCH] khronos: backport typedef for EGL_EXT_image_dma_buf_import
5
6The `gstreamer1.0-plugins-base` package version `1.14` uses `EGL_EXT_image_dma_buf_import`, which
7expects the `EGLuint64KHR` typedef that is present in recent versions of Khronos.
8However, the older version included in userland does not provide it.
9
10This patch backports the missing typedef from recent Khronos into userland.
11See: <https://www.khronos.org/registry/EGL/api/EGL/eglext.h>
12
13Submitted to userland in <https://github.com/raspberrypi/userland/pull/467>
14
15Upstream-Status: Submitted
16---
17 interface/khronos/include/EGL/eglext.h | 4 ++++
18 1 file changed, 4 insertions(+)
19
20diff --git a/interface/khronos/include/EGL/eglext.h b/interface/khronos/include/EGL/eglext.h
21index 89a3369..87cf7d2 100755
22--- a/interface/khronos/include/EGL/eglext.h
23+++ b/interface/khronos/include/EGL/eglext.h
24@@ -190,6 +190,10 @@ typedef EGLBoolean (EGLAPIENTRYP PFNEGLSIGNALSYNCKHRPROC) (EGLDisplay dpy, EGLSy
25 typedef EGLBoolean (EGLAPIENTRYP PFNEGLGETSYNCATTRIBKHRPROC) (EGLDisplay dpy, EGLSyncKHR sync, EGLint attribute, EGLint *value);
26 #endif
27
28+#ifndef EGL_KHR_uint64_typedef
29+#define EGL_KHR_uint64_typedef 1
30+typedef khronos_uint64_t EGLuint64KHR;
31+#endif /* EGL_KHR_uint64_typedef */
32
33 #ifdef __cplusplus
34 }
diff --git a/meta-raspberrypi-extras/recipes/userland/userland_git.bbappend b/meta-raspberrypi-extras/recipes/userland/userland_git.bbappend
deleted file mode 100644
index dc421e5..0000000
--- a/meta-raspberrypi-extras/recipes/userland/userland_git.bbappend
+++ /dev/null
@@ -1,35 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
31
32SRC_URI += "file://0001-khronos-backport-typedef-for-EGL_EXT_image_dma_buf_i.patch"
33
34SRCREV = "2448644657e5fbfd82299416d218396ee1115ece"
35PV = "20180511"