summaryrefslogtreecommitdiffstats
path: root/recipes-qt/automotive/neptune-ui_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/automotive/neptune-ui_git.bb')
-rw-r--r--recipes-qt/automotive/neptune-ui_git.bb62
1 files changed, 0 insertions, 62 deletions
diff --git a/recipes-qt/automotive/neptune-ui_git.bb b/recipes-qt/automotive/neptune-ui_git.bb
deleted file mode 100644
index 7987958..0000000
--- a/recipes-qt/automotive/neptune-ui_git.bb
+++ /dev/null
@@ -1,62 +0,0 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22DESCRIPTION = "Neptune IVI UI"
23LICENSE = "GPLv3"
24LIC_FILES_CHKSUM = "file://LICENSE.GPLv3;md5=024d61f4545fb889faa57982553ce094"
25
26inherit qt5-module systemd
27
28SRC_URI = " \
29 git://codereview.qt-project.org/qt-apps/neptune-ui;branch=${BRANCH};protocol=http \
30 file://neptune.service \
31 "
32
33SRCREV = "b3f10d156349727310ec30b27d01e639cce4f570"
34BRANCH = "master"
35
36S = "${WORKDIR}/git"
37
38DEPENDS = "qtbase qtdeclarative"
39RDEPENDS_${PN} = "qtapplicationmanager qtivi qtvirtualkeyboard \
40 ${@base_contains('DISTRO_FEATURES', 'webengine', 'qtwebengine', '', d)}"
41
42do_configure_prepend() {
43 echo "qml.path = /opt/neptune" >> ${S}/neptuneui.pro
44}
45
46do_install_append() {
47 install -m 0755 -d ${D}${systemd_unitdir}/system
48 install -m 0644 ${WORKDIR}/neptune.service ${D}${systemd_unitdir}/system/
49
50 install -m 0644 ${S}/Main*.qml ${D}/opt/neptune
51 install -m 0644 ${S}/am-config.yaml ${D}/opt/neptune
52}
53
54PACKAGES =+ "${PN}-apps"
55RRECOMMENDS_${PN} += "${PN}-apps"
56
57FILES_${PN}-apps += "/opt/neptune/apps"
58FILES_${PN} += "\
59 /opt/neptune \
60 "
61
62SYSTEMD_SERVICE_${PN} = "neptune.service"