diff options
Diffstat (limited to 'recipes-qt/automotive/qtapplicationmanager_git.bb')
-rw-r--r-- | recipes-qt/automotive/qtapplicationmanager_git.bb | 58 |
1 files changed, 0 insertions, 58 deletions
diff --git a/recipes-qt/automotive/qtapplicationmanager_git.bb b/recipes-qt/automotive/qtapplicationmanager_git.bb deleted file mode 100644 index 502dd06..0000000 --- a/recipes-qt/automotive/qtapplicationmanager_git.bb +++ /dev/null | |||
@@ -1,58 +0,0 @@ | |||
1 | ############################################################################## | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: http://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:COMM$ | ||
9 | ## | ||
10 | ## Commercial License Usage | ||
11 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
12 | ## accordance with the commercial license agreement provided with the | ||
13 | ## Software or, alternatively, in accordance with the terms contained in | ||
14 | ## a written agreement between you and The Qt Company. For licensing terms | ||
15 | ## and conditions see http://www.qt.io/terms-conditions. For further | ||
16 | ## information use the contact form at http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## $QT_END_LICENSE$ | ||
19 | ## | ||
20 | ############################################################################## | ||
21 | |||
22 | DESCRIPTION = "Qt component for application lifecycle management" | ||
23 | LICENSE = "GPLv3" | ||
24 | LIC_FILES_CHKSUM = "file://LICENSE.GPLv3;md5=311507adb75495acc0b61d69109485ce" | ||
25 | |||
26 | inherit qmake5 | ||
27 | |||
28 | SRC_URI = " \ | ||
29 | git://codereview.qt-project.org/qt/qtapplicationmanager;branch=${BRANCH};protocol=ssh \ | ||
30 | " | ||
31 | |||
32 | SRCREV = "b7578378b578788c2ae9c60708a2908d3b090c16" | ||
33 | BRANCH = "dev" | ||
34 | |||
35 | DEPENDS = "qtbase qtdeclarative libyaml libarchive \ | ||
36 | ${@base_contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}" | ||
37 | |||
38 | S = "${WORKDIR}/git" | ||
39 | |||
40 | EXTRA_QMAKEVARS_PRE += "\ | ||
41 | -config force-singleprocess \ | ||
42 | -config enable-dummydata \ | ||
43 | -config enable-ivi-logging \ | ||
44 | -config install-prefix=/usr \ | ||
45 | -config systemd-workaround \ | ||
46 | " | ||
47 | |||
48 | do_install_append() { | ||
49 | install -m 0755 -d ${D}/opt/am/ | ||
50 | install -m 0644 ${S}/template-opt/am/config.yaml ${D}/opt/am/ | ||
51 | } | ||
52 | |||
53 | FILES_${PN} += "\ | ||
54 | /opt/am \ | ||
55 | ${libdir}/appman \ | ||
56 | ${datadir}/dbus-1" | ||
57 | FILES_${PN}-dbg += "${libdir}/appman/.debug" | ||
58 | FILES_${PN}-dev += "${OE_QMAKE_PATH_LIBS}/*.prl" | ||