summaryrefslogtreecommitdiffstats
path: root/recipes-qt/b2qt-addons/b2qt-demos.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/b2qt-addons/b2qt-demos.bb')
-rw-r--r--recipes-qt/b2qt-addons/b2qt-demos.bb68
1 files changed, 68 insertions, 0 deletions
diff --git a/recipes-qt/b2qt-addons/b2qt-demos.bb b/recipes-qt/b2qt-addons/b2qt-demos.bb
new file mode 100644
index 0000000..d031b0a
--- /dev/null
+++ b/recipes-qt/b2qt-addons/b2qt-demos.bb
@@ -0,0 +1,68 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "Boot to Qt Demos"
24LICENSE = "QtEnterprise"
25LIC_FILES_CHKSUM = "file://sensors/Accelbubble.qml;md5=1bf19846314f7b0fa81dc4db92338713;beginline=1;endline=40"
26
27inherit qmake5
28
29SRC_URI = " \
30 git://qt-gerrit.it.local/QtRD-15810/b2qt-demos;branch=${QT_BRANCH};protocol=ssh;name=demos \
31 git://code.qt.io/qt-labs/qt5-everywhere-demo.git;protocol=git;name=everywhere;destsuffix=qt5-everywhere-demo \
32 "
33QT_BRANCH = "dev"
34SRCREV_demos = "d6979299a7809e5b832738c4cf39bba2c9a185eb"
35SRCREV_everywhere = "6178748a6ea34df40a8e3c9ce67137e33383bb0e"
36GITDIR_everywhere = "${DL_DIR}/qt5-everywhere-demo"
37
38
39S = "${WORKDIR}/git/basicsuite"
40
41DEPENDS = "qtbase qtdeclarative qtxmlpatterns qtquickcontrols qtgraphicaleffects qtsensors qtmultimedia qtwebengine"
42
43do_install_append() {
44 # we only need plugins from the demos
45 rm -rf ${D}/data/user/camera
46 rm -rf ${D}/data/user/sensorexplorer
47
48 cp -r ${S}/* ${D}/data/user/qt/
49 cp -r ${S}/../images ${D}/data/
50 cp -r ${S}/../videos ${D}/data/
51
52 cp -r ${WORKDIR}/qt5-everywhere-demo/QtDemo/qml ${D}/data/user/qt/qt5-everywhere/
53
54 # we can't have several top-level windows in b2qt, replace Window -> Rectangle
55 sed -i '/import QtQuick.Window/c\' ${D}/data/user/qt/qt5-everywhere/qml/QtDemo/main.qml
56 sed -i 's/Window /Rectangle /1' ${D}/data/user/qt/qt5-everywhere/qml/QtDemo/main.qml
57}
58
59FILES_${PN} += " \
60 /data/images/ \
61 /data/videos/ \
62 /data/user \
63 "
64
65FILES_${PN}-dbg += " \
66 /data/user/*/.debug/ \
67 /data/user/qt/*/*/.debug/ \
68 "