diff options
Diffstat (limited to 'recipes-qt/b2qt-addons/b2qt-launcher.bb')
-rw-r--r-- | recipes-qt/b2qt-addons/b2qt-launcher.bb | 51 |
1 files changed, 51 insertions, 0 deletions
diff --git a/recipes-qt/b2qt-addons/b2qt-launcher.bb b/recipes-qt/b2qt-addons/b2qt-launcher.bb new file mode 100644 index 0000000..9e9c94b --- /dev/null +++ b/recipes-qt/b2qt-addons/b2qt-launcher.bb | |||
@@ -0,0 +1,51 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | DESCRIPTION = "Boot to Qt Demo Launcher" | ||
24 | LICENSE = "QtEnterprise" | ||
25 | LIC_FILES_CHKSUM = "file://src/main.cpp;md5=1fcdf6b49fbbf2bc9c831893cca1b279;beginline=1;endline=17" | ||
26 | |||
27 | inherit qmake5 | ||
28 | |||
29 | SRC_URI = " \ | ||
30 | git://qt-gerrit.it.local/QtRD-15810/b2qt-launcher;branch=${QT_BRANCH};protocol=ssh \ | ||
31 | file://b2qt-startup.sh \ | ||
32 | " | ||
33 | |||
34 | SRCREV = "e824e206f28eb20bcb6f1d9064990f5e927261f4" | ||
35 | QT_BRANCH = "dev" | ||
36 | |||
37 | S = "${WORKDIR}/git" | ||
38 | |||
39 | DEPENDS = "qtbase qtdeclarative qtwebengine" | ||
40 | |||
41 | do_install_append() { | ||
42 | install -m 0755 -d ${D}${sysconfdir}/init.d | ||
43 | install -m 0755 ${WORKDIR}/b2qt-startup.sh ${D}${sysconfdir}/init.d/ | ||
44 | } | ||
45 | |||
46 | FILES_${PN} += "${sysdir}/init.d/b2qt-startup.h" | ||
47 | |||
48 | INITSCRIPT_NAME = "b2qt-startup.sh" | ||
49 | INITSCRIPT_PARAMS = "defaults 30" | ||
50 | |||
51 | inherit update-rc.d | ||