summaryrefslogtreecommitdiffstats
path: root/recipes-qt/b2qt-addons/b2qt-utils.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/b2qt-addons/b2qt-utils.bb')
-rw-r--r--recipes-qt/b2qt-addons/b2qt-utils.bb40
1 files changed, 19 insertions, 21 deletions
diff --git a/recipes-qt/b2qt-addons/b2qt-utils.bb b/recipes-qt/b2qt-addons/b2qt-utils.bb
index ee26caf..16ce360 100644
--- a/recipes-qt/b2qt-addons/b2qt-utils.bb
+++ b/recipes-qt/b2qt-addons/b2qt-utils.bb
@@ -1,27 +1,35 @@
1############################################################################## 1############################################################################
2## 2##
3## Copyright (C) 2016 The Qt Company Ltd. 3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/ 4## Contact: https://www.qt.io/licensing/
5## 5##
6## This file is part of the Boot to Qt meta layer. 6## This file is part of the Boot to Qt meta layer.
7## 7##
8## $QT_BEGIN_LICENSE:COMM$ 8## $QT_BEGIN_LICENSE:GPL$
9##
10## Commercial License Usage 9## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in 10## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the 11## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in 12## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms 13## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further 14## and conditions see https://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us. 15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
17## 25##
18## $QT_END_LICENSE$ 26## $QT_END_LICENSE$
19## 27##
20############################################################################## 28############################################################################
21 29
22DESCRIPTION = "Boot to Qt Utils module" 30DESCRIPTION = "Boot to Qt Utils module"
23LICENSE = "QtEnterprise" 31LICENSE = "GPL-3.0 | The-Qt-Company-DCLA-2.1"
24LIC_FILES_CHKSUM = "file://src/wifi/qwifimanager.h;md5=0b2892e6aca7d0750bbd7fe6b6b1c033;beginline=1;endline=17" 32LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504"
25 33
26inherit qt5-module 34inherit qt5-module
27require recipes-qt/qt5/qt5-git.inc 35require recipes-qt/qt5/qt5-git.inc
@@ -30,16 +38,6 @@ SRC_URI = " \
30 git://codereview.qt-project.org/qt/qtdeviceutilities;branch=${QT_MODULE_BRANCH};protocol=http \ 38 git://codereview.qt-project.org/qt/qtdeviceutilities;branch=${QT_MODULE_BRANCH};protocol=http \
31 " 39 "
32 40
33SRCREV = "a34cacb1a239dff4033b6beffd811b35db7c339f" 41SRCREV = "d0d70c3311b3dc3f0e4c11147a4b31e4da0ff56c"
34
35DEPENDS = "qtbase qtdeclarative wpa-supplicant"
36 42
37FILES_${PN}-examples-dbg = " \ 43DEPENDS = "qtbase qtdeclarative wpa-supplicant qtconnectivity"
38 /data/user/qt/.debug/* \
39 /data/user/qt/wifi-cpp/.debug/* \
40 "
41
42FILES_${PN}-examples = " \
43 /data/user/qt/wifi-cpp/wifi-cpp \
44 /data/user/qt/wifi-qml \
45 "