summaryrefslogtreecommitdiffstats
path: root/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb')
-rw-r--r--recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb b/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
new file mode 100644
index 0000000..d740991
--- /dev/null
+++ b/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
@@ -0,0 +1,55 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "Target packages for B2Qt embedded Qt5 SDK"
24LICENSE = "QtEnterprise"
25PR = "r0"
26
27inherit packagegroup
28
29PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
30
31RDEPENDS_${PN} += " \
32 packagegroup-b2qt-embedded-toolchain-target \
33 qt3d-dev \
34 qtbase-dev \
35 qtbase-staticdev \
36 qtconnectivity-dev \
37 qtdeclarative-dev \
38 qtdeclarative-staticdev \
39 qtgraphicaleffects-dev \
40 qtimageformats-dev \
41 qtlocation-dev \
42 qtmultimedia-dev \
43 qtsensors-dev \
44 qtserialport-dev \
45 qtsvg-dev \
46 qtsystems-dev \
47 qttools-dev \
48 qttools-staticdev \
49 ${@base_contains('DISTRO_FEATURES', 'wayland', 'qtwayland-dev', '', d)} \
50 qtwebsockets-dev \
51 qtwebchannel-dev \
52 qtxmlpatterns-dev \
53 qtquickcontrols-dev \
54 qtwebengine-dev \
55 "